1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Apache startet nicht automatisch

Dieses Thema im Forum "macOS & OS X" wurde erstellt von csharp, 22.07.06.

  1. csharp

    csharp Gast

    obwohl ich Personal File Sharing eingeschaltet habe.
    In den System/Library/StartupItems hats nen Folder Apache.

    Irgend wer ne Ahnung an was das liegen könnte?
     
  2. Terminal

    Terminal Gast

    Das von dir besagte Verzeichnis enthält nur die Startanweisungen. Geändert werden diese aber erst nach Aktivierung in Systemeinstellungen > Sharing > Personal WebSharing. Hier wird auch angezeigt ob Apache startet oder nicht. Wenn ja - werden dir die Urls zu deinem Webserver angezeigt. Wenn nicht - bleibt alles so wie es war.

    Zum korrekten Start von Apache ist eine angemessene Konfiguration nötig. Diese nimmt man in der Datei /private/etc/httpd/httpd.conf vor. Dazu bitte die Suche benutzen, es gibt hier genug Material zur Konfig von Apache.
     
  3. csharp

    csharp Gast

    Naja ne Lösung im eigentlichen Sinne ist das nicht, eher das was man von Windows gewohnt ist.
    WebSharing deaktivieren und wieder aktivieren, nun startet der Apache selbst.
     
  4. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    hmmm

    irgendwas im mittelteil hab ich wohl falsch verstanden.
    was bitte hat personal filesharing mit dem apache zu tun?
    und was vergleichst du mit windows?

    bist du zu spät draufgekommen, das websharing den apache startet?
     
  5. wolfsbein

    wolfsbein Jerseymac

    Dabei seit:
    29.06.05
    Beiträge:
    448
    Schau mal in das Logfile vom Apache. Wenn etwas falsch konfiguriert wurde startet er nicht vollstaendig, ohne eine extra Fehlermeldung in den Systemeinstellungen.
     
  6. csharp

    csharp Gast

    Nein, aber zu spät drauf gekommen, dass es eventuell erst beim zweiten mal aktivieren funktioniert, so wars dann auch. Gibts hier einige Threads dazu.
     
  7. ZENcom

    ZENcom Goldener Apfel der Eris

    Dabei seit:
    30.03.06
    Beiträge:
    2.650
    Apache laufen zu lassen ist eine Sache ;) Ihn für deine Bedürfnisse einzurichten eine andere... Apache ist kein MacOS spezifisches Servermodul. Es wird in allen Betriebssystemen eingesetzt und unterliegt, je nach OS, dem UNIX - Interpreter für Webserverapplikationen.

    Es spielt also keine Rolle ob du dein Apache in Win oder Mac oder Linux einrichtest. Die Vorgehensweise ist die Gleiche.

    (Gibt es für Apache eigentlich eine GUI unter MacOS - Server?) o_O
     
  8. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    logisch! alles dabei.
     
  9. csharp

    csharp Gast

    Ich betreibe Apaches unter diversen Systemen, ich habe ja lediglich geschrieben, dass der Apache nicht automatisch startete. Das konnte behoben werden indem ich Websharing ein / aus und wieder eingeschaltet habe. Diesert Zustand (beim ersten mal gehts nicht, nochmal gemacht und es geht) habe ich mit Windows vergliechen, nichts anderes.
     

Diese Seite empfehlen