1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Anmeldung bei LDAP verzeichnis

Dieses Thema im Forum "macOS & OS X Server" wurde erstellt von cybo, 19.07.06.

  1. cybo

    cybo Aargauer Weinapfel

    Dabei seit:
    23.05.06
    Beiträge:
    753
    Hallo,

    hoffe, ihr könnt weiterhelfen. Habe einen OS X Server 10.4.7, in dem Arbeitsgruppenmanager bin ich bei dem LDAP Verzeichnis als user xxx angemeldet.
    Nun folgendes Problem: Ich möchte einen neuen User anlegen, allerdings habe ich keine Rechte das zu tun, da der beim LDAP verzeichnis angemeldet User xxx den Server nicht verwalten darf, somit auch keine neuen benutzer anlegen darf.
    Frage: Wie melde ich mich bei LDAP Verzeichnis im Arbeitsgruppenmanager mit User xxx ab und dann als neuer User (der den Server verwalten darf) wieder an ?

    Anbei eine Grafik zum besseren Verständnis. Dort sieht man, dass ich als diradmin
    bei 127.0.0.1 angemeldet bin. Und nun will ich mich "ummelden"...



    Danke für Hilfe, gruß
    cabo
     

    Anhänge:

  2. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    Du mußt einem User (in dem Fall Dir selbst) als angmeldeter diradmin die Rechte für die Administration des LDAP-Verzeichnisses übertragen. Also einen zusätzlichen Admin für das LDAP erzeugen. Einfach im Arbeitsgruppen-Manager den User aufrufen, und im Reiter "Allgemein" den Haken bei "Benutzer darf diese Verzeichnis-Domain verwalten" setzen.

    Gruß Stefan
     
  3. cybo

    cybo Aargauer Weinapfel

    Dabei seit:
    23.05.06
    Beiträge:
    753
    Danke für die schnelle Antwort. Problem ist: Ich bin nicht als diradmin angemeldet (die angehängte Grafik war nur als Beispiel gedacht), sondern als "normaler" User und da kann ich unter Allgemein keine Veränderungen mehr vornehmen.
    Ich müsste also den jetzigen angemeldeten user (nicht diradmin !), der nur auf den Account zugreifen kann, von LDAP abmelden und mich dann als user wieder anmelden, der den Server verwalten, bzw. die verzeichnis Domäne verwalten darf.
    Und genau diesen Ab- und Anmeldevorgang vom LDAP Verzeichnis bekomme ich nicht hin. :(
     
  4. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    Beende einfach mal den WGM und starte ihn neu - danach sollte er Dich nach dem Server, dem User und dem zugehörigen PW fragen. An der Ecke sicherstellen, das Du Dich als User mit Adminrechten einloggst und schon kannst weitere Admins erzeugen.

    Gruß Stefan
     
  5. cybo

    cybo Aargauer Weinapfel

    Dabei seit:
    23.05.06
    Beiträge:
    753
    Ich habe ihn schon neu gestartet, hilft nix.
    Ich melde mich als Admin im WGM an, bin aber immer noch als der user angemeldet, mit dem ich es vorher auch war, nicht als admin. Brrr, das nervt. :mad:

    Edit: Der meldet mich autom. als den User an (an das LDAP), den ich gerade nicht will.
     
  6. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    dann schmeiß doch mal die Prefs vom WGM weg.

    Gruß Stefan
     
  7. cybo

    cybo Aargauer Weinapfel

    Dabei seit:
    23.05.06
    Beiträge:
    753
    Nutz auch nix. Melde mich als Administrator (so ist gleichzeitig auch der Benutzername) am WGM an und werde autom. als diradmin bei LDAP angemeldet und identifiziert.
     
  8. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    wenn Du diradmin bist, kannst Doch die Rechte vergeben? :oops:
    Arbeitest Du am Server direkt (auch per ARD/VNC) oder mit dem WGM im Remotezugriff?

    Gruß Stefan
     
  9. cybo

    cybo Aargauer Weinapfel

    Dabei seit:
    23.05.06
    Beiträge:
    753
    OK, ich versuch es mal genauer zu erklären:

    Ich habe einen Server, auf dem ist der Benutzer admin angelegt (mit Adminrechten) und Passwort ist auch vergeben. Nun starte ich den WGM.
    Der Anmeldedialog erscheint, ich verbinde mich. In dem WGM sind weitere 10 user angelegt, 8 davon dürfen nur auf den Account zugreifen, 2 besitzen vollen Zugriff, u.a. auch der Directory Administrator.
    Nun war das Problem, dass ich einen neuen Benutzer hinzufügen wollte, aber nicht mehr dass Paßwort des diradmin wusste, sodass ich mich als anderen user angemeldet habe (beim LDAP verzeichnis) von dem ich das passwort wusste.
    Problem: Der user, mit dem ich mich nun erfolgreich angemeldet habe, darf nur auf seinen Account zugreifen, hat sonst aber keinerlei rechte, kann also auch keine neuen betzer hinzufügen.
    jetzt muß ich mich irgendwie wieder als diradmin beim WGM anmelden. und genau das geht nicht.
    Hoffe, das war einigermassen verständlich...:eek:
     
  10. El Capitan

    El Capitan Bismarckapfel

    Dabei seit:
    27.02.06
    Beiträge:
    75
    Der Diradmin hat standardmässig das selbe Passwot wie der Admin, der den Rechner erstmalig aufgesetzt hat (User 501). Vielleicht hilft Dir das ja.
     
  11. cybo

    cybo Aargauer Weinapfel

    Dabei seit:
    23.05.06
    Beiträge:
    753
    Leider auch nicht wirklich. Ich muß "nur" wissen, wie man sich bei der LDAP Datenbank mit dem aktuellen User (der keine Rechte hat) abmeldet und als anderer user (der en server verwalten darf) wieder anmeldet.
    Suche auch schon in den OS X Server Büchern, in der Server Hilfe, nirgendwo ist auch nur ansatzweise beschrieben, wie ich das mache. Ich könnte so kotzen...:mad:
     
  12. El Capitan

    El Capitan Bismarckapfel

    Dabei seit:
    27.02.06
    Beiträge:
    75
    Auf das Schloss klicken im Arbeirgruppen Mgr. zum abmelden. Dann nochmal um anzumelden. Jetzt wird Passwort fällig. Evtl. Neues Fenster aufmachen
     
  13. cybo

    cybo Aargauer Weinapfel

    Dabei seit:
    23.05.06
    Beiträge:
    753
    Gut, ganz so blöd bin ich auch nicht, dass ich das nicht schon versucht hätte...:-D
    Auch ohne Erfolg. Wenn ich mich abmelde (Schloß geloggt) und dann wieder anmelde, bin ich autom. wieder mit dem user angemeldet, mit dem ich mich abgemeldet habe.
    Server neu gestartet, Prefs. gelöscht, PRAM + NVRAM gelöscht, alles nix geholfen.
    Kann das denn wirklich so ein Hexenwerk sein... ?
     
  14. El Capitan

    El Capitan Bismarckapfel

    Dabei seit:
    27.02.06
    Beiträge:
    75
    Du bist deshalb automatisch wieder angemeldet, weil das Passwort im Schlüsselbund abgespeichert ist. Vorher löschen. Eventuell hilt es auch schon, auf das Schloss zu klicken (abmelden), Dann ZUSÄTZLICH ein neues Fenster vom Arbeitsgruppen Mgr aufmachen und im NEUEN Fenster anmelden. Klappt jedenfalls bei mir so.
     
    cybo gefällt das.
  15. cybo

    cybo Aargauer Weinapfel

    Dabei seit:
    23.05.06
    Beiträge:
    753
    HOSSA ! :-D
    Das war es ! Herzlichen Dank, da wäre ich nicht drauf gekommen, obwohl Dein Lösungsweg ja naheliegend ist. Klasse, dann kann ich jetzt endlich weiterarbeiten.
    Also, vielen Dank nochmal und einen schönen Tag noch.

    Gruß
    cybo
     

Diese Seite empfehlen