1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Airport IP Problem

Dieses Thema im Forum "WLAN, Airport & TimeCapsule" wurde erstellt von insanity, 03.10.06.

  1. insanity

    insanity Klarapfel

    Dabei seit:
    06.07.06
    Beiträge:
    277
    Hi @ll,
    ich habe folgendes Problem:

    Meine eigene I-Net Verbindung sieht wie folgt aus,
    DSL-Modem -> Airport Express -> MacBook

    Wenn alle 3 ausgeschaltet sind, und ich dann alle einschalte, verbindet Airport Express mit dem DSl-Modem, baut die I-Net Verbindung auf und teilt mir in meinem lokalen W-Lan Netz die IP 192.168.1.2 zu. Soweit so gut. Möchte ich nun z.B. bei ICQ die Option zum Filetransfer nutzen, so muss ich den öffentlichen Port (z.B. 1234) mit dem Tool Airport Admin Portumleitung auf den Privaten Port 1234 der Privaten IP des MacBook in meinem W-Lan Netz umleiten.

    Das sieht dann so aus:
    Öffentlicher Port | Private IP | Privater Port
    1234 | 192.168.1.2 | 1234

    Funktioniert auch einwandfrei. Keine Probleme, die fangen erst jetzt an:

    Wenn ich zu meiner Freundin fahre, so bekomme ich dort in ihrem W-Lan Netz die IP 192.168.1.117 vom Router zugewiesen. I-Net funktioniert dort auch prima.
    Sobald ich aber nach Hause komme, in mein eigenes W-Lan Netz, besitze ich nicht mehr die .2 in meinem eigenen Netz sondern Airport Express übernimmt die .117 aus dem Netz meiner Freundin!?!

    Damit ist natürlich die Portumleitung hinfällig da die Ports ja weiterhin auf die .2 umgeleitet werden, ich nun aber die .117 habe.
    Also habe ich gedacht ich richte die Portumleitung wie folgt ein:

    Öffentlicher Port | Private IP | Privater Port
    1234 | 192.168.1.2 | 1234
    1234 | 192.168.1.117 | 1234

    Wenn ich nun die .117 habe funktioniert es auch einwandfrei. Aber nach einiger Zeit, das kann manchmal Stunden dauern, hin und wieder aber auch Tage, wechselt plötzlich meine IP wieder zurück auf die .2!?! Ich habe leider noch nicht rausgefunden unter welchen Bedingungen genau das der Fall ist.

    Ich bin davon ausgegangen das er dann jedenfalls trotzdem die Ports umgeleitet bekommt da die .2 ja auch eingetragen ist in der Portumleitung. Dies ist aber nicht der Fall, wenn die Liste in der Portumleitung so aktiv ist wie oben geschrieben bekomme ich den Port nur auf die .117 weitergeleitet, nicht aber auf die .2!

    Dies Funktioniert erst wieder sobald ich die Umleitung auf die .117 aus der Portumleitung entfernt habe...

    Mein Problem ist also das ich ständig die Portumleitungseinstellungen für sämtliche Ports die ich brauche ändern muss. :(

    Daher meine Frage, gibt's für eins der beiden Probleme eine Lösung?
    Entweder das er die Ports auf beide IPs (.2 und .117) umleiten kann oder aber das ich immer in meinem eigenen Netzwerk die .2 automatisch zugewiesen bekomme und Airport Express eben nicht die .117 aus dem Netzwerk meiner Freundin übernimmt?

    Hoffe jemand hat den Sinn meines Posts verstanden (blicke da selbst so gerade nicht mehr durch ;) ) und kennt eine Antwort? :)

    Achso, eine Bitte: Von der Antwort fahr nicht mehr zu deiner Freundin bitte mal absehen... ;) *gg*
     
  2. Terminal

    Terminal Gast

    Ja, alles verstanden.

    Die zuerst vergebene IP wird meißt so lange beibehalten bis du mal einen Neustart des Rechners machst. Dann werden die DHCP-Eintragungen normalerweise entfernt.

    Wenn nicht, kannst du auch deine Konfiguration in Systemeinstellungen > Netzwerk löschen und neu anlegen.

    Weiterhin kannst du auch eine manuelle IP eintragen (DHCP aus und Manuell ein), so kann dir die Airportstation oder der Router keine eigene IP zuweisen die du nicht möchtest. Du mußt dann allerdings auf die Automatik des Airport-Menü oben in der Menüleiste verzichten. (Verbindungszeit, Abmelden, Trennen)
     
  3. astraub

    astraub Champagner Reinette

    Dabei seit:
    17.06.04
    Beiträge:
    2.651
    Hallo,

    ja, die manuelle IP ist das beste Verfahren - das verwende ich aus dem gleichen Grunde auch. Der letzte Satz stimmt aber nicht - es gibt bei manueller IP-Vergabe keine Einschränkung bei Verwendung / Anzeige des Airport Menüs. "Trennen" kann man die Verbindung durch Auswahl von "Internet Verbindung ...", die Anzeige der Verbindungsphase und der Verbindungszeit sind nach wie vor möglich. Alle diese Dinge haben auch mit der PPPoE Verbindung und nicht mit der DHCP IP-Vergabe zu tun.

    Gruss
    Andreas

    PS: nicht vergessen! Eine IP-Adresse wählen, die in beiden Netzen gilt!
     
  4. Stargate

    Stargate Weisser Rosenapfel

    Dabei seit:
    16.05.04
    Beiträge:
    782
    >Hoffe jemand hat den Sinn meines Posts verstanden (blicke da selbst so gerade nicht

    Du legst auf deinem Mac in den Netzwerkeinstellungen Airport, jeweils eine Umgebung für Zuhause und Freundin an. In jeder dieser Einstellungen verwendest du die dafür notwendigen Parameter. Du schaltest bei Bedarf händisch um.

    Oder du stellst das oben genannte auf "Automatisch" und:

    In den Airporteinstellungen finden sich unter dem Button "Optionen" Möglichkeiten bevorzugte Netzwerke einzutragen. Du nimmst an jedem Standort die Einstellungen auf und trägst dann das entstprechende Netz ein.

    Ich wette, alles was du willst, geht vollkommen automatisch, an jedem Standort ;)

    Es ist manchmal einfacher als man denkt.

    Das macht man einmal für jeden Standort an dem man arbeitet, dann vom
    Prinzip her nie mehr. Das Book loggt sich an jedem Standort korrekt ein.
     
  5. Terminal

    Terminal Gast

    Ich weiß nicht wie es bei dir ist. Ich habe eine Airportstation und bekomme meine IP per DHCP zugeteilt. Wenn ich aber eine manuelle IP eintrage, wird mir nicht mehr das komplette Airport-Menü angezeigt. Keine laufende Verbindungszeit und kein Abmelden-Dialog mehr. Daher schätze ich, dass es bei anderen genauso ist.
     
  6. astraub

    astraub Champagner Reinette

    Dabei seit:
    17.06.04
    Beiträge:
    2.651
    Hallo,

    bei mir ist neben dem Namen des benutzten Netzwerks ein schwarzes Dreieck, das anzeigt, dass es zusätzliche Optionen gibt. Bei der Auswahl des Netzwerks klappen dann die Optionen für die Verbindungszeit und den Status beim Anmelden auf.

    Gruss
    Andreas
     
  7. insanity

    insanity Klarapfel

    Dabei seit:
    06.07.06
    Beiträge:
    277
    danke erstmal für die viel antworten,

    wenn ich versuche die adresse manuell zu vergeben bekomme ich keine internet verbindung mehr. obwohl ich testweise erstmal die manuellen eingaben genauso gesetzt habe wie die automatischen dhcp einstellungen...

    ip: 192.168.1.2
    teilnetzmaske: 255.255.255.0
    router: 192.168.1.1

    keine verbindung zum internet!

    unter dhcp mit manuelle adressvergabe

    adresse: 192.168.1.2

    gleiche effekt, keine internet verbindung :(

    aber wenn ich dhcp an mache dann zeigt er mir genau diese einstellungen an und ich habe eine verbindung?!?



    das bitte nochmal langsam zum mitschreiben... :( bekomme das nicht hin. was meinst du mit umgebungen anlegen? oben wo jetzt umgebung: automatisch steht auf neue umgebung meinst du? dort kann ich dann ja die einstellungen für meinen router machen und einmal in einer anderen umgebung für den meiner freundin, aber wie ich gerade geschrieben habe funktioniert nur die einstellungen dhcp, manuell nicht :( und wenn ich beide profile als dhcp hab übernimmt er dann nicht wieder die .117 aus dem netz meiner freundin? :(

    und was meinst du mit ...oder du stellst das oben genannte auf automatisch und:...

    :( sorry bin nicht so vertraut mit netzwerk einstellungen... :(
     
  8. Terminal

    Terminal Gast

    Also 1. nicht die manuelle DHCP-Eingabe verwenden, sondern einfach nur Manuell. Dort dann deine "Koordinaten" eintragen.

    Eine weitere Umgebung legt man hier an: Bild 1

    Die Einwahlknoten die dein Rechner zuletzt benutzt hat, liegen in "Bevorzugte Netzwerke". Und wenn du alles auf "Automatisch" stellst, wählt sich dein Rechner demnächst immer automatisch in das Netz ein wo du dich gerade aufhältst. (Freundin, Weihnachtsmann, Hure) Bild 2
     

    Anhänge:

    • 001.jpg
      001.jpg
      Dateigröße:
      55,4 KB
      Aufrufe:
      101
    • 002.jpg
      002.jpg
      Dateigröße:
      69,9 KB
      Aufrufe:
      90
    #8 Terminal, 04.10.06
    Zuletzt von einem Moderator bearbeitet: 04.10.06
  9. insanity

    insanity Klarapfel

    Dabei seit:
    06.07.06
    Beiträge:
    277
    das meinte ich oben mit manuell funktioniert nicht, es funktioniert weder manuell oder dhcp mit manueller adresse... nur dhcp funktioniert die internet verbindung, oder muss ich an der airport express station auch noch bestimmte einstellungen vornehmen?

    weil ich stell mir das gerade so vor, wenn ich 2 umgebungen anlege mit "standartmäßig verbinden mit: automatisch" und jeweils dort in den einstellungen dhcp auswähle ändert sich doch trotzdem nichts zu jetzt? ob er nun ein profil hat oder 2, die einstellungen sind ja die selben... woher will er also wissen mit welches profil er nutzen soll? er hat ja in beiden profilen wenn ich unter "standartmäßig verbinden mit: bevorzugte netzwerke" gehe die gleichen netze drin... weil er ja jeweils einfach das verfügbare netzwerk nimmt mit dhcp, und dann hab ich ja wieder das problem das er dann doch sicher einfach weiter wieder die .117 nimmt wenn ich von meiner freundin nach hause komme?

    kann man ihn nicht einfach anweisen bei jedem netzwerk einfach ne neue dhcp anzuvordern vom router? :)

    ps: sorry für meine eventuell dummen fragen... bissle geduld bitte... :)
     
  10. astraub

    astraub Champagner Reinette

    Dabei seit:
    17.06.04
    Beiträge:
    2.651
    Hallo,

    Du kannst unter Systemeinstellungen - Netzwerk - Airport - TCP/IP eine neue DHCP Adresse anfordern (irgendetwas mit DHCP Lease ...). Manuell sollte es aber auf jeden Fall auch gehen. Zeige uns doch mal Dein TCP/IP Kontrollfeld ...

    Gruss
    Andreas
     
  11. insanity

    insanity Klarapfel

    Dabei seit:
    06.07.06
    Beiträge:
    277
    also wenn ich "dhcp lease erneuern" klicke läd er zwar kurz, aber ich habe trotzdem weiter die .117, wie gesagt wäre ja ok wenn ich immer die .117 hätte, dann würde ich die portumleitung so setzten und gut :) aber nach einiger zeit habe ich wieder die .2 bei mir im netz. kann es sein das dies irgendwas mit meiner konfig meiner airport express station zu tun hat. denn wenn ich bei meiner freundin war mit der .117 und zu einem bekannten fahre der auch airport express hat, dann bekomme ich dort sofort die .5 zugewiesen, und wenn ich danach nach hause komme habe ich dessen .5 bei mir, irgendwann wechselt er dann auch wieder auf die .2 bei mir. wenn ich mit seiner .5 zu meiner freundin fahre bekomme ich dort auch gleich wieder die .117. das lässt mich irgendwie auf die idee kommen das vielleicht an airport express was falsch eingestellt ist, und nich an meiner umgebung?

    [​IMG]
    [​IMG]
    [​IMG]

    aso, auf den fotos ist der "jetzt anwenden" button nich auswählbar weil ich das nur schnell fürs screenshot nochmal ausgewählt habe, hatte das beim ausprobieren natürlich gedrückt gehabt... :)
     
  12. astraub

    astraub Champagner Reinette

    Dabei seit:
    17.06.04
    Beiträge:
    2.651
    Hallo,

    Du kannst beim Airport Express Setup vorgeben, welchen IP Adressbereich die AEX per DHCP anbietet. Vielleicht ist es ja auch eine Möglichkeit bei Dir diesen Bereich auf .117 bis .117 einzustellen ? Dann kannst Du die Portumleitungen fest auf diese Adresse stellen.

    Gruss
    Andreas

    PS: Ich konnte Deine Bilder nicht sehen ... zumindest hier im Büro.
     
  13. insanity

    insanity Klarapfel

    Dabei seit:
    06.07.06
    Beiträge:
    277
    komisch, ich bekomme die bilder ohne probs angezeigt, sind .tiff dateien.



    also wenn ich an der airport express station anstelle von eine einzige ip adresse gemeinsam nutzen (dhcp / nat) auswähle einen bereich von ip adressen gemeinsam nutzen (nur dhcp) dann bekomme ich die meldung:

    Wenn Sie einen Bereich von DHCP-Adressen gemeinsam nutzen möchten, muss die Basisstation so konfiguriert sein, das sie statische IP-Adressen verwendet.

    Das Bild wechselt dann automatisch auf die Einstellungen am AEX für "Internet".
     
  14. insanity

    insanity Klarapfel

    Dabei seit:
    06.07.06
    Beiträge:
    277
    ok ich hab einen weg gefunden denke ich:

    a) wenn man manuell die tcp/ip einstellungen vorgibt sollte man wohl den router als dns-server angeben... *ups*

    ich habe aber jetzt meine netzwerk einstellungen weiterhin auf dhcp und alles auf automatik stehen, stattdessen habe ich folgendes gefunden:

    b) unter airport admin dienstprogramm zum einstellen der express station habe ich dort ip-adresse gemeinsam nutzen an, aber den bereich nicht versucht einzuschränken über einen teil gemeinsam nutzen, was ja nicht funktioniert hat, sondern ganz normal über eine einzige ip adresse gemeinsam nutzen. dort haber ich aber nicht das vorausgewählte 192.168.1.1 - adressierung gewählt sondern "andere" und in dem popup fenster 192.168.1 eingestellt und pool: 3

    so stellt er nurnoch die .1, .2 und .3 zur verfügung (die .3 ist für das problem unrelevant, ist für die psp... :) ), mit pool: 2 gings auch nur hab ich dann keine ip mehr für die psp *gg*.

    [​IMG]

    er kann ja dann die .117 von vorher nicht ünernehmen, wird also sicher eine neue anfordern, und damit dann direkt die .2 erhalten. getestet habe ich dies noch nicht, werde wohl erst am fr zu meiner freundin kommen und das dann auch erst abend bei mir zuhause überprüfen können, hört sich aber (zumindest für mich ;) ) logisch an, oder?

    c) eine frage noch: was hat es mit "systemeinstellungen > netzwerk > airport > optionen > verbindungen zu drahtlosen netzwerken beim abmelden trennen" auf sich? muss ich den hacken setzten? wofür ist das gut?
     
  15. Stargate

    Stargate Weisser Rosenapfel

    Dabei seit:
    16.05.04
    Beiträge:
    782
    >wenn ich versuche die adresse manuell zu vergeben bekomme ich keine internet verbindung mehr. obwohl ich testweise erstmal die manuellen eingaben genauso gesetzt habe wie die automatischen dhcp einstellungen...

    ip: 192.168.1.2
    teilnetzmaske: 255.255.255.0
    router: 192.168.1.1

    >keine verbindung zum internet!

    Netzwerkeinstellungen -> TCP/IP, dort unter DNS und Router die IP-Adresse
    des Routers eintragen. Wenn es dann nicht klappen sollte, unter DNS die IP-Adressen der Nameserver (DNS) deines Internetproviders eintragen.
     
  16. insanity

    insanity Klarapfel

    Dabei seit:
    06.07.06
    Beiträge:
    277
    danke funzt, aber hab es jetzt so gemacht wie im post drüber, pool der ips reduziert...
     

Diese Seite empfehlen