1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

AirPort Extreme - statische IP-Vergabe

Dieses Thema im Forum "WLAN, Airport & TimeCapsule" wurde erstellt von bw1faeh0, 13.03.09.

  1. bw1faeh0

    bw1faeh0 Uelzener Rambour

    Dabei seit:
    06.01.08
    Beiträge:
    368
    Hallo Leute,

    ich suche einen Weg in meinem (heute gekauftem) Airport Extreme das DHCP abzuschalten.
    Ausgangssituation:
    Ich habe drei Rechner in meinem Netzwerk: Server auf der 192.168.1.2, iMac auf der 192.168.1.3, MacBook auf der 192.168.1.4. Alle haben eine statische IP.

    Nun schließe ich heute den Airport Extreme an, konfiguriere ihn über das Airport Dienstprogramm, bekomme aber keinen Zugriff über Ethernet auf das Internet. Grund liegt daran, dass meine IP statisch konfiguriert war (siehe oben). Erst als ich auf DHCP-Konfiguration umgestellt habe, hat mich der Airport Extreme ins WWW gelassen (habe gerade die 192.168.1.10).

    Was zum Teufel soll das??

    Wieso lässt er keine Geräte ins Netz, die eine statische IP haben??? Ich habe jetzt eine Option gefunden, mit der man DHCP-Adresse fest einer Mac zuordnen kann.

    Gibt es irgendwie einen anderen Weg mit einer statischen IP über einen Airport Extreme ins Netz zu gehen?
    Wie kann ich DHCP abschalten?
    Was hat sich Apple hiermit gedacht?

    *argh*
     
  2. gimmick24

    gimmick24 Antonowka

    Dabei seit:
    23.02.09
    Beiträge:
    361
    Ich tippe mal dauf, das bei Deiner Statischen IP irgendwas falsch ist. Evtl. falsches Gateway oder DNS-Server.
    Normalerweise ist einem Router das sowas von Egal, ob statisch oder über DHCP. Ich habe hier auch eine Mischung zwischen beidem.
     
  3. bw1faeh0

    bw1faeh0 Uelzener Rambour

    Dabei seit:
    06.01.08
    Beiträge:
    368
    Nein, ich habe über DHCP die identische Adresse von Router/Gateway und DNS übertragen bekommen - das ist ja das bescheuerte.
     
  4. gimmick24

    gimmick24 Antonowka

    Dabei seit:
    23.02.09
    Beiträge:
    361
    Vieleicht ist das ja genau das Problem. Versuch mal als statische IP-Adresse irgendwas nahe der 254 (als letztes Oktett).
    Evtl. geht das nicht, weil der Router die Adresse irgendwie für DHCP reserviert hat.
     
  5. bw1faeh0

    bw1faeh0 Uelzener Rambour

    Dabei seit:
    06.01.08
    Beiträge:
    368
    Nein, ich habe den Router so eingestellt, dass er DHCP von 192.168.1.10 bis 192.168.1.100 vergibt. Die Adressen davor und danach sind somit frei.
    Bei jedem normalen Router kann man so auf den Router zugreifen, wenn man eine statische IP hat - nur Apple tanzt aus der Reihe...
     
  6. gimmick24

    gimmick24 Antonowka

    Dabei seit:
    23.02.09
    Beiträge:
    361
    Gibt es zum AE ein Konfigurationsprogramm? Evtl. musst Du die Adressen da "zum Netzwerk hinzufügen"... ist aber nur so eine Idee. Ansonsten bin ich da auch etwas ratlos jetzt. Ich habe hier eine Fritzbox, und der ist es völlig egal.
     
  7. bw1faeh0

    bw1faeh0 Uelzener Rambour

    Dabei seit:
    06.01.08
    Beiträge:
    368
    Ja, habe es gefunden. Ich muss zu erst die Mac-Adresse des Rechners angeben, der eine statische IP bekommen soll und anschließend eine IP einstellen, die der Rechner bekommen soll. Erst dann darf ich diese IP im Rechner selbst als statisch konfigurieren.

    D.h. doppelter Aufwand, um statische IPs im Netzwerk zu vergeben...

    Anwenderfreundlich ist das aus meiner Sicht nicht...
     
  8. gimmick24

    gimmick24 Antonowka

    Dabei seit:
    23.02.09
    Beiträge:
    361
    Na ha, hauptsache es geht :) Nacht man ja nicht täglich.

    OT: Ich habe früher mal in Rautheim gewohnt!
     
  9. Goglo

    Goglo Querina

    Dabei seit:
    08.10.08
    Beiträge:
    180
    Damit hast Du dem DHCP-Server gesagt, dass er diesem Rechner immer genau diese IP geben soll. Damit bekommst Du auch die DNS-Server wieder über DHCP. Und damit funktioniert auch das "Internet". (Schreibe ich in der Annahme, dass Netmask und Gateway vorher schon korrekt waren)

    Apple macht da auch nix anderes als anderer Hersteller.
     
  10. bw1faeh0

    bw1faeh0 Uelzener Rambour

    Dabei seit:
    06.01.08
    Beiträge:
    368
    ja, aber wenn ich meinem altem Router sage, dass die Adressen in einem Bereich von 192.168.1.10 bis 192.168.1.100 per DHCP vergeben werden sollen und ich meinen Rechner die IP 192.168.1.2 gab (sowie die korrekte DNS und Gateway), dann kam ich trotzdem mit dem Rechner ins Netz.

    Mit dem APE geht dies nicht.

    Und das größte Problem dabei war, dass das nicht dokumentiert ist. Die gehen davon aus, dass man im Rechner die Netzwerkkarte so konfiguriert hat, dass sie die IP per DHCP bekommt.
    Ich habe eine Stunde lang gesucht...
     
  11. deloco

    deloco Carmeliter-Renette

    Dabei seit:
    14.11.07
    Beiträge:
    3.304
    Also mit meiner Airport Express hatte ich nie irgendwelche Probleme in der Art, da ging das ohne jedes Problem, die Macs wahren schon statisch konfiguriert und die Airport habe ich danach angestöpselt…
    Na ja, wenn's jetzt geht ist ja gut…
     
  12. Goglo

    Goglo Querina

    Dabei seit:
    08.10.08
    Beiträge:
    180
    Du meinst also, dass ein ping von dem Mac, dem Du eine statische IP und die korrekte netmask zugewiesen hast, auf den Router nicht erfolgreich war? Fällt mir wirklich schwer, das zu glauben.

    Wenn danach ein "ping auf 80.67.28.71" fehlschlägt, ist's der gateway. (bzw. die "default route")

    Wenn dann ein "ping apfeltalk.de" nicht funktioniert, funktioniert DNS nicht.

    "Nicht ins Netz kommen" bzw. "Internet funktioniert nicht" kann durchaus verschieden Ursachen haben. Ganz sicher möchte ich da die "ganz speziellen Eigenarten der APE" ausschliessen.
     
  13. bw1faeh0

    bw1faeh0 Uelzener Rambour

    Dabei seit:
    06.01.08
    Beiträge:
    368
    Also ich konnte weder 192.168.1.1 (router) noch www.google.de anpingen. Jedoch konnte ich 192.168.1.3 anpingen (da 192.168.1.1, 192.168.1.2 und 192.168.1.3 über einen separaten Switch verbunden sind).

    Also wurde scheinbar auch ICMP vom Router geblockt. (Vermutung)
     
  14. Fly_Eagle

    Fly_Eagle Allington Pepping

    Dabei seit:
    09.04.08
    Beiträge:
    193
    Hi,

    ich habe hier auch 3 Rechner (2 Mac, 1 Windows) über eine TimeCapsule miteinander und dem Internet verbunden.

    Ging ganz easy. Alles statisch.

    Bei mir ist die Internetverbindung statisch (im Menüpunkt Internetverbindung ist die Adresse des WLAN-Accesspoints eingerichtet) und eine "öffentliche IP-Adresse nutzen".. Eventuell hast Du diesen Punkt vergessen.

    Grüße
    Sven:-D
     
  15. schnuffelschaf

    schnuffelschaf Rheinischer Bohnapfel

    Dabei seit:
    28.03.07
    Beiträge:
    2.452
    Das Problem ist häufig die Apple-Terminologie, weil die verwendeten Begriffe nicht unbedingt den geläufigen Termini entsprechen, wie sie unter Netzwerkern üblich sind. Musste mich vor ein paar Tagen auch erst umgewöhnen nach dem Umstieg von einer FritzBox auf eine Airport Extreme.

    Wo genau ist das Problem? Das ist das Standardvorgehen, wenn man in einer DHCP-Umgebung einem oder mehreren Clients eine statische IP zuordnen will. Da tanzt Apple weder aus der Reihe noch sonstwas. Ist eine Sache des Standpunktes: DHCP ist in den meisten Fällen die Default-Einstellung weil es am einfachsten und benutzerfreundlichsten ist. Also betrachtet man statische IPs als Spezialfall in einem Netz mit DHCP. Außer in einer Reihe von Spezialfällen (Netzdrucker, Server) macht die statische IP-Vergabe im kleinen privaten Netz nicht unbedingt großen Sinn.
     

Diese Seite empfehlen