1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

AFP, angeblich nicht kompatibles Protokoll...

Dieses Thema im Forum "macOS & OS X" wurde erstellt von hendsch, 01.08.05.

  1. hendsch

    hendsch Elstar

    Dabei seit:
    23.03.04
    Beiträge:
    72
    Hallo Ihr Lieben!

    Da ist man einmal im Urlaub...
    Folgendes Problem:
    Ich kann mich unter meinem Benutzer unter Mac OS 10.4.2 (& 10.4.1) nicht mehr über AFP an unserem File Server (eine Dose) anmelden.

    Folgende Fehlermeldung erscheint:

    Verbindung Fehlgeschlagen
    Dieser File Server verwendet eine nicht kompatible Version des AFP Protokolls...

    Ich habe danach gegoogelt und nur Hinweise auf Mac OS 9 gefunden. Unser Server ist aber eine Dose, ich benutze 10.4 und jetzt kommt der Hammer: unter einem anderen Benutzer auf den gleichen Rechner kann ich mich anmelden, sehe den Server aber nur unter dem einen Benutzer.

    Hat jemand eine Idee woran das ganze liegen kann? Was mach ich jetzt nur?


    Danke und viele Grüße!
    Hendsch
     
  2. Sputnik

    Sputnik Zwiebelapfel

    Dabei seit:
    15.10.04
    Beiträge:
    1.284
    Hast Du schon mal den Account auf dem Server überprüft und beide miteinander verglichen?
     
  3. michaelbach

    michaelbach Roter Seeapfel

    Dabei seit:
    05.01.04
    Beiträge:
    2.109
    Oh oh, das ist ein grauenhaftes problem von Tiger, höchstwahrscheinlich würde es bei Panther noch gehen.

    Bei uns ist es ein Novell-Server (muss sein, klinikumsweit), auf dem ein sog. "AppleTalk Stack" läuft. Damit können sich seit Urzeiten alle Macs gut anmelden. Nur seit Tiger nicht mehr... ich hatte das damals in der beta-version gleich als fehler an Apple gemeldet und auch mehrfach eskaliert... Die haben kein interesse daran. Die fehlermeldung ist genau die "nicht unterstützes protokoll". "nicht MEHR" sollte es heißen.

    Für uns ein Mac-Killer: wir können keine neuen Macs mehr kaufen, bloß weil Apple so blöd ist ein funktionierendes protokoll abzustellen. WUTAUSBRUCH!
     
  4. yjnthaar

    yjnthaar Schwabenkönig

    Dabei seit:
    07.06.04
    Beiträge:
    2.657
    Moin, Moin,

    Uiuiui... :eek:

    Da haben wir ja nochmal Glück gehabt. Wenn ich mich auf unseren Novell (v 6.x) Server anmelde, geht das unter Tiger (noch?) problemlos.

    [​IMG]
    Screenshot: Mit Server verbinden -> Novell Server

    Wir haben das in Novell 6.x integrierte AFP-Modul (Native File Access) angeschaltet. Einziges Manko im Moment ist, dass nur unverschlüsselte, sechsstellige PWDs akzeptiert werden.

    Aber es läuft... o_O
     
  5. michaelbach

    michaelbach Roter Seeapfel

    Dabei seit:
    05.01.04
    Beiträge:
    2.109
    das problem hängt von der Novell-version ab. Bei höheren versionen geht es wieder, und ich freue mich dass es bei Dir, yjinthaar geht. Es ist nur nicht so einfach, und auch nicht billig, innerhalb des ganzen klinikums die Novell-version hochzufahren, und erst recht nicht nur um es Apple in seiner idiotie recht zu machen...
     
  6. Sputnik

    Sputnik Zwiebelapfel

    Dabei seit:
    15.10.04
    Beiträge:
    1.284
    Ich konnte bis jetzt keine Probleme feststellen. Bei uns auf der Arbeit nutzen wir zwar zu 99% w2k maschinen, die aber ohne probleme funktionieren.

    Novell ist doch eh tot. :p [SIZE=-3]*duck*[/SIZE]
     
  7. yjnthaar

    yjnthaar Schwabenkönig

    Dabei seit:
    07.06.04
    Beiträge:
    2.657
    Moin,

    @Michael: Da hast Du natürlich vollkommen recht. Wegen den paar Macs würde hier auch niemand die Server-Infrastruktur verändern.

    Vielleicht gibts trotzdem Hoffnung, da ein Update auf X.4.3 angekündigt wurde, dass einen Fix in der AFP-Unterstützung bringen soll.

    @André: Sag dass mit dem Novell ist Tot der deutschen Uni-/Hochschul-Landschaft! :eek:

    Gruss,
    Simon
     
  8. michaelbach

    michaelbach Roter Seeapfel

    Dabei seit:
    05.01.04
    Beiträge:
    2.109
    @yjnthaar: ja, ich hoffe auch auf 10.4.3, hab schon überlegt ob ich's mir nur deshalb schon mal holen soll. Normalerweise hat man aber viel ärger mit betas, und ich habe auch nicht den eindruck dass Apple meine bug reports ernsthaft verfolgt -- schon mehrfach hatte ich das auf fehler hingewiesen, die in der endversion immer noch drin waren und erst noch einige updates brauchten.

    @Sputnik: das war wohl ein witz, gell? Novell ist weder tot noch schlecht. U.a. haben die ein open-source calendering-projekt unterstützt, was vielleicht nächstens in OSX-server einzieht (wenn man der gerüchteküche glauben kann), denn iCal ist nix für gruppen.
     
  9. Sputnik

    Sputnik Zwiebelapfel

    Dabei seit:
    15.10.04
    Beiträge:
    1.284
    Die Produkte von Novell sind keinesfalls schlecht... aber leider nur ist Novell nicht wirklich gut vertreten
     
  10. hendsch

    hendsch Elstar

    Dabei seit:
    23.03.04
    Beiträge:
    72
    Hi,

    na da habe ich aber was losgetreten...
    Sehr wichtig ist, aber das das ganze nur mit einem User Probleme macht. Der andere user auf dem gleichen Rechner mit dem gleichen System meldet sich an.

    Gruß Hendsch
     
  11. michaelbach

    michaelbach Roter Seeapfel

    Dabei seit:
    05.01.04
    Beiträge:
    2.109
    na ok, dann ist es was _ganz_anderes. Ich weiß aber nicht was :-c, tut mir leid.
     
  12. Sputnik

    Sputnik Zwiebelapfel

    Dabei seit:
    15.10.04
    Beiträge:
    1.284
    Hast Du meinen ersten Tipp beachtet?
     
  13. hendsch

    hendsch Elstar

    Dabei seit:
    23.03.04
    Beiträge:
    72
    Hi Sputnik,

    das hab ich übersehen. Ich hab aber auf dem Server gar keinen Account. Ich komme auch gar nicht soweit, irgendetwas einzugeben. Eigentlich ignoriert er mich schon beim klicken der Schaltfläche "Verbinden..."
     
  14. Sputnik

    Sputnik Zwiebelapfel

    Dabei seit:
    15.10.04
    Beiträge:
    1.284
    Hmmm... Ich gehe mal davon aus das Deine Netzsettings OK sind und Du auch die möglichkeit besitzt an den Server heranzukommen.
    Schweres Ding, so ganz ohne drauf zu gucken. Evtl. ist es eine Falsche Konfiguration in eier PLIST-Datei, aber welche?

    Vielleicht weiss das Jemand von euch?

    Schöne Grüße

    Andre
     
  15. Tekl

    Tekl Fairs Vortrefflicher

    Dabei seit:
    01.06.05
    Beiträge:
    4.622
  16. hendsch

    hendsch Elstar

    Dabei seit:
    23.03.04
    Beiträge:
    72
    Nee nee nee!

    Ich wusste ja das es mit einem anderen Benutzer auf gleicher Maschine geht. Also habe ich eben mal den "Library-Umbenennen-und-Stück-für-Stück-wieder-zurück-schiebe Trick" angewendet.

    Jetzt geht die Anmeldung wieder (ja über AFP auf den "DOSen Server"), nur muss mir ein Fehler unterlaufen sein beim zurück-ersetzen. Ich konnte also leider nicht eingrenzen an welcher Datei es nun genau gelegen hat.

    Danke nochmal für eure Hilfe!!!

    Gruß hendsch
     
  17. fusspilz

    fusspilz Jonathan

    Dabei seit:
    19.04.04
    Beiträge:
    81
    hallo


    hab genau das gleiche prob mit dem AFP Protokoll! :mad:
    bin von 10.3 auf 10.4 tiger gewechselt, LEIDER!!! :-c
    ich habe einen g3 mit os 9.2.1 und einen g5 dual mit tiger 10.4 mit clasic umgebung 9.2.2 und möchte daten zwischen diesen beiden rechnern austauschen aber seit dem wechsel kommt immer genau diese meldung.

    "Dieser File Server verwendet eine nicht kompatible Version des AFP Protokolls..." :-c :-c

    meine frage jetzt welche dateien hast du umgeschrieben und wie damit es bei dir jetzt wieder funktioniert?

    gruß
    christian
     
  18. hendsch

    hendsch Elstar

    Dabei seit:
    23.03.04
    Beiträge:
    72
    hi,

    wie ich in meinem letzten Beitrag berichtete: der Fehler hat sich "leider" einfach so in Luft aufgelöst.
    Vielleicht probierst du mal einen anderen Benutzer? Wenn es dann geht, könntest du es ja mit meiner Methode noch mal probieren.

    Gruß Hendsch
     

Diese Seite empfehlen