[13'' MBPr] USB-Probleme nach Ruhezustand

Dieses Thema im Forum "Mobil-Macs" wurde erstellt von 505, 12.07.16.

  1. 505

    505 deaktivierter Benutzer

    Dabei seit:
    12.07.16
    Beiträge:
    4
    Hi Leute,

    mein 13 Zoll MacBook Pro retina (Early 2015) muckt seit einiger Zeit mit im Ruhezustand eingesteckten USB-Sticks und Speicherkarten rum. Leider finde ich im Internet nichts passendes (außer einigen weiteren USB-Problemen wegen des neuen Stacks in El Capitan), daher bräuchte ich mal eure Hilfe, um herauszufinden, was hier schief geht oder ob das vielleicht sogar "normal" ist derzeit?

    Ist das MacBook eingeschaltet, erkennt es idR alle neu angesteckten Speichermedien. Ebenso verhält es sich, wenn es ausgeschaltet ist, ich einen USB Stick anstecke und dann boote. Klappe ich den Mac jedoch zu bzw. wenn er im Ruhezustand ist und ich einen USB Stick oder eine Speicherkarte einstecke, wird dieser beim Reaktivieren aus dem Ruhezustand wohl nicht korrekt gemountet. Nun das merkwürdige: Im FDP erscheint er ebenfalls nicht, wohl aber im Systembericht. Dort sehe ich dann auch, dass der CardReader als Gerät nach dem Ruhezustand nur hin und wieder erkannt wird, bei angestecktem USB Stick häufig nicht. Das kann doch kein "Regelverhalten" sein, oder?

    Sticks, die vor dem Ruhezustand angesteckt waren, werden auch danach wieder korrekt angezeigt, nur neu eingesteckte Medien nicht. Ich hab jetzt schon alles versucht, was einem da in der Regel geraten wird, SMC, PRAM zurücksetzen - erfolglos. Das Problem zeigt sich auch mit mehreren Sticks und Speicherkarten, bisher hab ich es mit 4 von SanDisk, Corsair, CnMemory und Verbatim versucht.

    Kann jemand von euch mal versuchen, das zu reproduzieren? Falls das ein Hardwareproblem ist, müsste ich noch diese Woche zum AASP, die Garantie läuft am 20. ab....
     
  2. Fresh_Prince

    Fresh_Prince Moderator
    AT Moderation

    Dabei seit:
    22.10.14
    Beiträge:
    7.189
    Das ist bei mir auch so. Ist der Stick oder die externe Festplatte vor dem Ruhezustand eingesteckt, sind sie danach auch noch angezeigt. Verbindet man die Geräte im Ruhezustand mit dem Mac, dann werden sie nicht erkannt. Das habe ich jedoch schon immer so bemerkt. Mit jedem System was ich bisher durch hatte. Von 10.6 bis jetzt. Für mich ist das immer eine Folge des Ruhezustands gewesen, weil dort die USB Ports quasi deaktiviert sind durch die Stromsparmaßnahmen. Egal ob mit oder ohne angeschlossener Stromversorgung.


    PS:

    Jedoch wird der USB Stick den ich gerade getestet habe, von der Energie her erkannt. Das Lämpchen am USB Stick leuchtet auch beim Anschließen im Ruhezustand genauso wie im Normalmodus.
     
    505 gefällt das.
  3. 505

    505 deaktivierter Benutzer

    Dabei seit:
    12.07.16
    Beiträge:
    4
    Danke. da bin ich ja erstmal beruhigt. Gehe mal davon aus, dass du derzeit auch einen neueren Mac besitzt. Mit meinem 2008er MBP ging das übrigens durchaus noch und geht noch immer, auch mit El Capitan. Das mit dem Strom im Ruhezustand hab ich aber auch wahrgenommen, das hatte zumindest mich eigentlich viel mehr gewundert. Trotz allem finde ich es merkwürdig, dass er nach dem Ruhezustand im Systembericht angezeigt wird. Muss doch dann auch möglich sein, das Ding dann auch systemseitig korrekt zu mounten!
    War gestern bei nem Apple Händler und hab da mal nachgefragt, die sagten mir, das könne nur ein Softwarefehler sein und ich solle OS X mal neu installieren. Konnte es aber auch leider nicht vorführen, da ich das MacBook nicht dabei hatte. Vielleicht komm ich nächste Woche mal dazu, dann kann ich berichten ob das was hilft.
     
  4. m1LLo

    m1LLo Osnabrücker Reinette

    Dabei seit:
    29.05.10
    Beiträge:
    991
    Wie @Fresh_Prince bereits richtig erwähnt hat: Seit 2009 hab ich dieses Problem bei jedem Mac/OS X . Scheint aber kein Fehler zu sein welcher Apple interessiert.
     
    Ohana und 505 gefällt das.
  5. Fresh_Prince

    Fresh_Prince Moderator
    AT Moderation

    Dabei seit:
    22.10.14
    Beiträge:
    7.189
    Ich kann privat jetzt leider nur mit Erfahrungen dienen die sich auf mindestens 2010er Modelle beziehen. Denn von Modellen von 2010 bis 2015 hatte ich schon eine Menge Macs. Dort war es im er so. Egal ob 10.6 oder 10.11.
    Auf der Arbeit haben wir auch noch ältere Macs, jedoch auch nur 2009. Deshalb kann ich das leider nicht mit noch älteren Geräten gegentesten.
    Die Frage ist, ob es wirklich ein Fehler ist oder ob sich ab 2009 irgendwas änderte. Das wird sich nicht so leicht herausfinden lassen.

    Ich muss aber auch sagen, das ich noch nie wirklich drauf geachtet hatte, auch wenn uch diesen Umstand schon früher bemerkte. Ich habe meine Peripherie immer erst nach dem Aufklappen oder besser gesagt nach dem Ruhezustand verbunden.
     
    505 gefällt das.
  6. 505

    505 deaktivierter Benutzer

    Dabei seit:
    12.07.16
    Beiträge:
    4
    @m1LLo @Fresh_Prince Auf jeden Fall ein riesen Dankeschön fürs Nachsehen und Berichten an euch beide! So gibt das ganze ja auch ein Bild und würde auch erklären, warum es an meinem 2008er MacBook noch funktioniert. Muss dann mal schauen obs wegen dem CardReader woanders klemmt, aber insgesamt auf jeden Fall beruhigend.
    Die meisten Nutzer werden das ja vermutlich gar nicht erst merken, denke das hängt immer ein bisschen vom persönlichen "Workflow" ab. Ich steck an das MacBook wenn ich nach Hause komm häufig gleich alles dran bevor ich es aufklappe und ärgere mich dann jedes Mal, wenn da ein USB-Stick dabei ist. Wer das nicht macht, merkt es ja nicht. Vielleicht soll das auch ein Schutzmechanismus sein? Auf jeden Fall komisch, dass man im Internet nichts dazu findet...
    War mir jetzt nur wichtig, das ganze mal abzuchecken bevor die Garantie abläuft (und für 250 Euro will ich die eigentlich nicht erweitern...). Wäre das ein Hardwareproblem, wäre die "Lösung" ja sicher nicht ganz billig