Apfeltalk Weihnachtsbanner 2014

LCD-Manager (Logitech) Symbol aus dem Dock "entfernen"

Dieses Thema im Forum "OS X" wurde erstellt von Venom.gg, 22.07.10.

  1. Venom.gg

    Venom.gg Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    26.05.10
    Beiträge:
    116
    Zustimmungen:
    6
    Steinigt mich, wenn das hier nicht richtige Unterforum ist. *g*

    Nunja, ich hab seit langer Zeit mal wieder meine G15 ausgepackt und sie an mein MBP angeschlossen.
    Alles schön und gut, funkioniert auch, doch allerdings nervt mich das Key - Profiler Symbol im Dock ein wenig.

    Es zu schließen ist ansich schon möglich, aber dann funkionieren die G-Tasten nichtmehr.

    Ich hab diesbezüglich auch schon ein wenig gegoogl'et, hab auch einen Eintrag gefunden, doch irgendwie funkioniert diese Lösung bei mir nicht, oder ich stell mich einfach zu dumm dafür an. %)

    Es handelt sich hierbei um die Version "3.03.113


    Vielleicht kann mir ja jemand weiterhelfen.


    Grüße Dennis
    #1
  2. fyysh

    fyysh Goldparmäne

    Dabei seit:
    25.01.10
    Beiträge:
    1.386
    Zustimmungen:
    47
    Die Anleitung, die du gepostet hast, funktioniert nur, wenn du die Developer tools installiert hast.

    Wenn nicht, müsste es so funktionieren:
    1. Im Terminal, gib folgendes ein:
    open -a textedit /Applications/Logitech/GamePanel\ Software/G-series\ Software/G-series\ Key\ Profiler.app/Contents/Info.plist

    2. Im Textedit stellst du dann sicher, dass die ersten paar Zeilen so aussehen:
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    	<key>LSUIElement</key>
    	<true/>
    
    Guck dass du
    Code:
    	<key>LSUIElement</key>
    	<true/>
    
    nicht doppelt drin hast.

    App neu starten, dann sollte das Dockicon nicht mehr angezeigt werden.

    EDIT: Vor app neu starten natürlich die plist speichern ;)
    #2
  3. Venom.gg

    Venom.gg Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    26.05.10
    Beiträge:
    116
    Zustimmungen:
    6
    Hey, erstmsl vielen Dank für deine rasche Antwort, doch allerdings funkioniert das absolut nicht so.

    Wenn ich den Befehl ins Terminal eingeb, pop der TextEdit auf und zeigt folgendes an (siehe screenshot). Textedit.jpg


    Vielleicht hilft es ja.
    Vielen Dank schonmal.
    #3
  4. fyysh

    fyysh Goldparmäne

    Dabei seit:
    25.01.10
    Beiträge:
    1.386
    Zustimmungen:
    47
    ah verstehe. das problem ist, dass die plist binär ist.


    mach so:
    und dann
    Dann sollte es leserlich werden.

    wenn du fertig bist, machst du ein
    dann ist die plist wieder binär.

    EDIT: ähm, alles im terminal, natürlich :)
    #4
  5. fyysh

    fyysh Goldparmäne

    Dabei seit:
    25.01.10
    Beiträge:
    1.386
    Zustimmungen:
    47
    ah, moment, wobei mir einfällt: hast du die plist schon mit dem plist editor bearbeitet und gespeichert? das hätte sie nämlich binär gemacht. standardmäßig sind info.plists im xml-format, nicht binär. wenn das also der grund sein sollte, warum sie binär ist, musst du sie nicht zurückkonvertieren, kannst also den letzten schritt weglassen...
    #5
  6. Venom.gg

    Venom.gg Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    26.05.10
    Beiträge:
    116
    Zustimmungen:
    6
    Hat funktioniert!
    Super, tausend Dank dafür =)
    #6

Diese Seite empfehlen