1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Leo´s Webserver läuft nicht

Dieses Thema im Forum "Webhosting/DSL-Anbieter" wurde erstellt von ***elvis***, 28.09.08.

  1. ***elvis***

    ***elvis*** Empire

    Dabei seit:
    30.11.07
    Beiträge:
    84
    ich wollt leo´s hauseigenen webserver aktivieren. Aber der läuft nicht.

    Das ganze sollte auf einem MacBok mit Leo incl aller updates laufen. Wenn ich das richtig weis, brauch dazu nur in der Systemeinstellung Web-Sharing aktivieren und schon sollte das über http://macbook/ oder http://macbook/~Sascha/ oder http://localhost oder http://IP erreichbar sein.

    Ich bekomme aber immer nur die Antwort:

    Safari kann den Server nicht finden.
    Safari kann die Seite „http://macbook/“ nicht öffnen, da Safari den Server „macbook“ nicht finden kann.

    Was kann ich tun???

    DANKE
     
  2. Ikezu Sennin

    Ikezu Sennin Schöner von Bath

    Dabei seit:
    15.07.07
    Beiträge:
    3.649
    Lies dir doch mal die Beschreibung zu Web-Sharing durch...

     
  3. ***elvis***

    ***elvis*** Empire

    Dabei seit:
    30.11.07
    Beiträge:
    84
    das klappt ebenfalls nicht.

    wie bekomme ich den zum laufen? Gibt´s dazu ne Anleitung?

    DANKE
     
  4. nickch4nge

    nickch4nge Süsser Pfaffenapfel

    Dabei seit:
    16.01.08
    Beiträge:
    665
    Schaue mal bei "Einstellungen >> Sicherheit >> Firewall" wie die Firewall eingestellt ist.
     
  5. Ikezu Sennin

    Ikezu Sennin Schöner von Bath

    Dabei seit:
    15.07.07
    Beiträge:
    3.649
    Übers Internet wirst du wohl nur auf Umwegen auf deinen Mac zugreifen können, mit Boardmitteln gestaltet sich das als schwierig.
     
  6. ***elvis***

    ***elvis*** Empire

    Dabei seit:
    30.11.07
    Beiträge:
    84
    ähm, steh gerade auf dem Schlauch wo finde ich die Firewall Einstellungen ???

    Das ganze soll auch nicht aus dem Netz erreichbar sein. Sondern nur als Intranet laufen.
     
  7. Macbeatnik

    Macbeatnik Golden Noble

    Dabei seit:
    05.01.04
    Beiträge:
    24.957
    Übers Internet geht es auch, die Webadresse unter der der Rechner zu erreichen ist, siehst du in Systemeinstellungen-Sharing-Websharing:
     

    Anhänge:

  8. nickch4nge

    nickch4nge Süsser Pfaffenapfel

    Dabei seit:
    16.01.08
    Beiträge:
    665
    [​IMG]

    evtl hilft dir das.
     
  9. MacApple

    MacApple Lord Grosvenor

    Dabei seit:
    05.01.04
    Beiträge:
    3.470
    Geht es denn auch nicht, wenn Du die IP-Adresse des MacBooks angibst? Also http://x.x.x.x?

    Die Fehlermeldung von Safari sagt nämlich aus, dass für „macbook” keine IP-Adresse gefunden wurde. Safari versucht über eine DNS-Anfrage „macbook” in eine IP-Adresse aufzulösen, was natürlich nicht klappen kann.

    MacApple
     
  10. ***elvis***

    ***elvis*** Empire

    Dabei seit:
    30.11.07
    Beiträge:
    84
    *von kopf klatsch*

    logisch, ja, sieht bei mir genauso aus. Eingehende Verbindungen erlaubt
     
  11. ***elvis***

    ***elvis*** Empire

    Dabei seit:
    30.11.07
    Beiträge:
    84
    nee, auch nicht....:(
     
  12. mr.winkle

    mr.winkle Fießers Erstling

    Dabei seit:
    16.08.07
    Beiträge:
    126
    Hallo elvis,
    Du kannst natürlich nicht von jedem beliebigen Computer mit http://localhost oder den anderen genannten Adressen auf deinen laufenden Server zugreifen. Um eine feste IP zu bekommen kannst du aber Services wie z.B. DynDNS benutzen - viele Router haben heute bereits eine Funktion zum aktualisieren der IP auf solchen Seiten integriert - für den Anfang reicht es aber sicher schon auf http://www.wieistmeineip.de/ nachzuschauen und eben auf diese IP zuzugreifen.

    Wenn du die Adresse allerdings auf dem Mac aufrufst auf dem du auch den Server betreibst müsste es eigentlich funktionieren - es sei denn du hast dir den Apache zerschossen durch Xampp o.ä.
    Falls das nicht funktioniert bleibt dir wohl nur noch auf eine der Alternativen zu setzen. Eine Xampp Installation ist sehr leicht und bietet bereits PHP und MySQL und noch mehr an, vergiss nur nicht dieses Sicherheitsskript auszuführen, sonst eignet sich Xampp nur zum lokalen Testen.

    mfg
     
  13. nickch4nge

    nickch4nge Süsser Pfaffenapfel

    Dabei seit:
    16.01.08
    Beiträge:
    665
  14. ***elvis***

    ***elvis*** Empire

    Dabei seit:
    30.11.07
    Beiträge:
    84
    ach Du scheiße....

    Ich hatte zunächst MAMP installiert. Das lief auch soweit local Problemlos über http://localhost:8888 problemlos, bzw. tut es auch immer noch. Nur habe ich da das Problem das ich vom zweiten Mac da nicht drauf komme. Es soll ja ein Intranet werden. Ich hab gedacht das dieses Problem vielleicht beim hausegenen Server nicht wäre.


    luppt auch net :(
     
  15. nickch4nge

    nickch4nge Süsser Pfaffenapfel

    Dabei seit:
    16.01.08
    Beiträge:
    665
    Hmm dann versuche mal mit dem Terminal.app die conf vom Apache zu öffnen und schaue mal nach welcher port eingetragen ist.

    im terminal.app

    nano /private/etc/apache2/httpd.conf

    fast ganz unten sollte "Listen 80" stehen.
     
  16. mr.winkle

    mr.winkle Fießers Erstling

    Dabei seit:
    16.08.07
    Beiträge:
    126
    Kenne mich mit MAMPP nicht aus, aber wenn MAMPP einen eigenen Apache installiert dann wird da wohl was in der Konfig nicht mehr stimmen. Aber du sagst der Apache von MAMP funktioniert, also müsste auch dein anderes Macbook darauf zugreifen können. Starte MAMPP und geh mal auf www.wieistmeineip.de und versuchs dann mal unter http://XXX.XXX.XXX.XXX:8888. (PORT 8888 ist ja anscheinend derjenige, den MAMPP für das HTTP Protokoll benutzt, was sehr ungewöhnlich ist. Ich kenne nur http über Port 80 - aber das heisst ja nichts.)
     
  17. ***elvis***

    ***elvis*** Empire

    Dabei seit:
    30.11.07
    Beiträge:
    84
    zwar nicht fast ganz unten sondern eher oben aber da steht Listen 80
     
  18. ***elvis***

    ***elvis*** Empire

    Dabei seit:
    30.11.07
    Beiträge:
    84
    @mr.winkle das funktioniert auch nicht.
     
  19. nickch4nge

    nickch4nge Süsser Pfaffenapfel

    Dabei seit:
    16.01.08
    Beiträge:
    665
    im Terminal mal "sudo /usr/sbin/apachectl start" eingeben und schauen was für eine ausgabe kommt.
     
  20. ***elvis***

    ***elvis*** Empire

    Dabei seit:
    30.11.07
    Beiträge:
    84
    Last login: Sun Sep 28 11:33:05 on console
    MacBook:~ Sascha$ sudo /usr/sbin/apachectl start
    Password:
    org.apache.httpd: Already loaded
    MacBook:~ Sascha$
     

Diese Seite empfehlen