1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

xt:commerce MySQL 5 Update

Dieses Thema im Forum "PHP & Co." wurde erstellt von duderino, 21.04.06.

  1. duderino

    duderino Goldparmäne

    Dabei seit:
    26.01.06
    Beiträge:
    556
    Ich bin auf der Suche nach dem MySQL 5 Update für xt:commerce. Leider habe ich keinen Zugang zu dem "Sponsorenbereich". Ich bin schon seit Tagen auf der Suche nach diesem kleinen Patch aber niemand kann mir helfen.

    Ich hoffe hier hat schonmal jemand dieses Problem gehabt und kann mir wenigstens sagen in welchen Dateien ich etwas ändern muss. Das Problem mit den Kategorien habe ich schon gelöst aber ich habe immernoch Probleme beim Aufruf der Versandkosten und mit den Cross-Link Seiten im Admin Bereich.

    Einfach ne E-Mail schreiben oder ne kleine PM.

    Grüße
    duderino
     
  2. duderino

    duderino Goldparmäne

    Dabei seit:
    26.01.06
    Beiträge:
    556
    Hat sich erledigt. Hab den Patch bekommen. Wenn ihn jemand braucht einfach PN an mich.

    duderino
     
  3. KayHH

    KayHH Gast

    Moin duderino,

    worum geht es denn und ist osCommerce auch betroffen?


    Gruss KayHH
     
  4. duderino

    duderino Goldparmäne

    Dabei seit:
    26.01.06
    Beiträge:
    556
    Es geht darum dass os Commerce und xt Commerce in Ihren aktuellen Versionen nicht kompatibel zu MySQL 5 sind. Der größte Teil der Scripte funktionieren zwar aber wenn man z.B. eine Kategorie aufrufen will oder das Cross-Selling Modul benutzt bekommt man eine Fehlermeldung.

    Das hat etwas mit LEFT und JOIN zu tun. Es gibt aber für beide Script einen Patch. Bei oc Commerce kann man den einfach von der Seite laden aber bei xt Commerce bekommt man den nicht so einfach weil die Entwickler nur sogenannte "Sponsoren" supporten.

    Wenn du aber kein MySQL 5 benutzt ist das Problem eh unrelevant.

    duderino
     
  5. KayHH

    KayHH Gast

    Moin duderino,

    danke für die Info.
    Schon klar, bei mir läuft auch noch 4.0.24, aber das könnte sich ja mal ändern und dann will ich da keine bösen Überraschungen erleben.


    Gruss KayHH
     
  6. duderino

    duderino Goldparmäne

    Dabei seit:
    26.01.06
    Beiträge:
    556
    Also das Update für os Commerce hab ich nicht. Aber das findest sicher auf der Seite von denen. Das für xt Commerce hab ich jetzt hier, wenn es also jemand braucht...

    Hab in letzter Zeit viele Anbieter gesehen die auf MySQL 5 umstellen. Mittlerweile laufen die aktuellen Versionen ja ziemlich stabil.
     
  7. market-web

    market-web Gast

    Hallo Duderino
    Das Problem hat mich über Nacht betroffen. Da wurde bei netbeat von msql 4,0 auf msql 5,0 umgestellt. Ich wäre dir sehr dankbar, wenn du mir das Update von XT-geben könntest.

    Viele Grüße w-schmuck@arcor.de
     
  8. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    ich hänge gerade auch in einem Update von xt:commerce von 3.03 auf 3.04 und hatte dazu eine lokale Testumgebung unter MySQL5 aufgezogen. Insgesamt muß ich sagen, kotzt mich xt:Commerce in den letzten Tagen, in denen ich mich mit der Umstellung befasse ziemlich an. Das Vertriebsmodell ist da nur noch Wasser auf meine Mühlen :(. Nachdem ich etliches an der alten Version schon in Richtung xHTML 1.1 und CSS 2.0 verändert und verbessert habe, darf ich das alles nochmal in dem Minor-Update nachvollziehen. Und beim Kaufen von Sprachversionen im xt:Commerce eigenen Shop beweisen die "Supporter" das sie auch einfache betriebswirtschaftliche Prozesse nicht beherrschen. Ich frage mich ernsthaft: wozu sollte jemand die 99 EUR ausgeben? Für schlechten Code oder für unwissen über Geschäftsmodelle ? :oops:.

    Ich bin geneigt einen eigenen Entwicklungszweig aufzuziehen, wahlweise etwas Krawall in die xt:Commerce Bude zu bringen - Mitstreiter erwünscht!

    Gruß Stefan
     
  9. newman

    newman Roter Eiserapfel

    Dabei seit:
    02.06.05
    Beiträge:
    1.436
    Ich habe bisher immer mit oscommerce gearbeitet, bin aber am Überlegen einen Kunden auf xt:c umzustellen. Wie sieht den der Support im Sponsorenbereich aus, lohnt sich das? De Software selbst ist ja OSS, hab sie die Woche auch schon mal probehalber installiert.
     
  10. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    nochmal: die Leute, die ihr Geld mit xt:Commerce verdienen und den Support verkaufen haben weder Codequalität noch den abgebildeten Geschäftsprozess im Griff - ich würde meine Erwartungen an Support nicht zu hochhängen.

    Gruß Stefan
     
  11. newman

    newman Roter Eiserapfel

    Dabei seit:
    02.06.05
    Beiträge:
    1.436
    Das war eine klare Aussage, danke dir. Ich habe mir die nächsten Tage eine feste Zeit reserviert um mich etwas tiefer mit xt:c zu beschäftigen, werde mir das Template-System und einige der Sourcen mal genauer ansehen.
     
  12. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    das Templatesystem ist an sich eine gute Sache leidet jedoch darunter, das alles noch auf HTML 4.01 und table-Layout beruht. Etliches dieses Tabellencodes findet sich zudem außerhalb des Templates in den Untiefen der Funktionsdateien (wo's am allerwenigsten hingehört). In einer Version 4.0 oder einen eigenen Zweig wären für mich hier die alten Zöpfe, die direkt abgeschnitten gehören. Durch das smarty-System kann man nämlich sehr schöne, leichte und sematisch blitzsaubere Templates aufbauen, die dann auch noch hölle schnell sind.

    Gruß Stefan
     
  13. duderino

    duderino Goldparmäne

    Dabei seit:
    26.01.06
    Beiträge:
    556
    Für alle: Den MySQL 5 Patch kann mich sich unter www.ecombase.de saugen, wenn man sich anmeldet. Es erscheint dann einen Downloadarea in der man auch Mod und PlugIns saugen kann.

    @stk: Willkommen in meiner Welt :) Musste mich die letzten Monate mit XTC beschäftigen. Hab auch selber ein paar Mods geschrieben und bin der absoluten Meinung dass XTC der größte Schrott überhaupt ist. Leider scheint es niemand besser hinzubekommen :(
     
  14. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    yep. XTC ist in der Tat der Einäugige unter den Blinden o_O.

    Gruß Stefan
     
  15. Micha1960

    Micha1960 Gast

    Xtcommerce 3.03 und MySQL 5

    ich arbeite mit Xtcommerce 3.03 und habe jetzt das MySQL 5 Problem
    bekommen weil mein Provider umgestellt hat.

    Ich möchte eigentlich nicht auf Xt 3.04 umstellen. Daher die Frage ob
    es auch eine Lösung für 3.03 gibt?
     
  16. [FONT=&quot]Hallo

    [/FONT][FONT=&quot]Ich wollte euch mal fragen ob ihr mir vielleicht das xt Commerce MySQL 5 Update schicken könntet? Da ich nun auf mysql 5 umstellen muss. Ich würde mich freuen wenn mir hier jemand helfen könnte.

    [/FONT][FONT=&quot]Viele grüße[/FONT]
     
  17. duderino

    duderino Goldparmäne

    Dabei seit:
    26.01.06
    Beiträge:
    556
    Hallo NightWorker, auf www.ecombase.de kannst du dir den Patch runterladen. Du musst du da vorher allerdings Anmelden um in den Downloadbereich zu kommen.

    duderino
     

Diese Seite empfehlen