1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Information ausblenden

XAMPP Problem

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von NexuS, 17.07.06.

  1. NexuS

    NexuS Gast

    Hi Leute,

    habe ein Problem mit der Mac-Version von XAMPP. Ordner, die ich in dem "htdocs"-Verzeichnis ablege, kann ich über den Browser nicht aufrufen. Nur das "xampp"-Verzeichnis in htdocs lässt sich normal öffnen. Ansonsten erhalte ich "Forbidden. You don't have permission..."

    Ist mir mit der Win-Version nie passiert. Was kann ich tun?
     
  2. hochstammapfel

    hochstammapfel Châtaigne du Léman

    Dabei seit:
    18.04.05
    Beiträge:
    826
    Ist eine Indexdatei vorhanden? Nein? Tu mal eine rein. Z.B. index.html und schau mal was passiert.
    Wenns dann immer noch nicht geht, musst du in der Apache-Config (wo sich die bei der XAMPP-Konstruktion befindet, weiss ich nicht) für das entsprechende DocumentRoot entweder ein
    Code:
    Options Indexes
    für den automatischen Index, oder ein
    Code:
    DirectoryIndex index.html
    eingeben, damit "index.html" als Indexdatei akzeptiert wird.

    Code:
    #z.B so, wenn /srv/www/htdocs DocumentRoot ist:
    
    <Directory "/srv/www/htdocs">
         Options Indexes
         DirectoryIndex index.html index.php #Da bin ich nicht ganz sicher, müsste aber funktionieren (index.html und index.php als Indexfile)
    </Directory>
    
    Lässt sich natürlich genauso für VirtualHosts erstellen, aber ich glaube mit XAMPP ist das weniger ein Thema.

    Falls das nicht funktioniert, ist es tatsächlich ein Rechteproblem. Dann musst du gucken, mit welchem Benutzer (evt. "www") Apache ausgeführt wird und diesem dann wenigstens Leseberechtigung auf das entsprechende Verzeichnis erteilen.
     
  3. NexuS

    NexuS Gast

    nun hat es geklappt: habe gesehen, dass die rechte für den xampp-ordner auf "nobody" gestellt waren. Hab ich für mein Verzeichnis auch gemacht und dann ging es mit einem Mal...
     
    #3 NexuS, 17.07.06
    Zuletzt von einem Moderator bearbeitet: 17.07.06

Diese Seite empfehlen