1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

verschwindende Sonderzeichen in Excel! :(

Dieses Thema im Forum "Office:Mac" wurde erstellt von Zille, 06.07.07.

  1. Zille

    Zille Wohlschmecker aus Vierlanden

    Dabei seit:
    30.01.06
    Beiträge:
    237
    Hallo!

    Ich habe das Problem, das mir Excel andauernd die Sonderzeichen versaut. D.h. das die nach dem speichern oft weg sind. Dazu muss ich sagen, dass ich drei TTF Schriften verwende, die nur linguistische Sonderzeichen enthalten, die ich dann je nach Bedarf einsetze. Aber ich kann nicht in einer Tabelle von weit über 2000 Zeilen jeden Eintrag kontrollieren. Weiss jemand woran das liegt und weiss vielleicht jemand auch noch Abhilfe?!

    Danke.
     
  2. Tengu

    Tengu Apfel der Erkenntnis

    Dabei seit:
    05.02.07
    Beiträge:
    721
    Sind diese Dokumente mit solchen Sonderzeichen belegt:
    «∑€®†Ω¨⁄øπ

    Also Zeichen, die es im Standardlayout von ISO nicht gibt, und die Windows fremd sind?
    Wurde das Dokument aus Win-Excel heraus erstellt? Und dann portiert?

    Jedenfalls übersetzt er nach dem Speichern Deinen Zeichensatz, um die Kompatibelität zu erhalten. Schätze ich mal.
    Wenn Du das abstellst, wird kein Windows Nutzer Deine Tabelle fehlerfrei lesen können.
     
  3. Zille

    Zille Wohlschmecker aus Vierlanden

    Dabei seit:
    30.01.06
    Beiträge:
    237
    Also die Zeichen sind z.B. u mit e drüber, s mit Hacek, m mit einem Kreis drunter usw. Erstellt wurde alles aufm Mac. Die Schriften hat sich unsere Arbeitsstelle extra anfertigen lassen. Sind Windows fremd und TTFs. Kompatibilität muss an bleiben, weil ich die Listen an das Institut schicken muss und die haben nur Windowsrechner, leider.
     
  4. Tengu

    Tengu Apfel der Erkenntnis

    Dabei seit:
    05.02.07
    Beiträge:
    721
    Also das Problem ist, dass Excel 2004 Windows Latin-1 Encoding verwendet, Dein Mac aber nicht. Er hält sich an den weitaus älteren Unix Standard, der nicht von Microsoft verändert wurde.

    Das hat mit der Schriftart nichts zu tun, sondern mit der Interpretation der Bytes. Das geht eine Ebene tiefer gen ASCII-Zeichensatz.

    Ich weiß nicht, wie man das so umstellt, das Excel in UTF-8, jedenfalls nicht in WINDOWS Latin-1 codiert. Das sollte aber eigentlich möglich sein... wenn ich was finde.... meld ich mich. Vielleicht kennt jemand anderes ja eine Lösung... kann ja auch über Third Party Software machbar sein.

    http://unicodeconvert.sourceforge.net/changelog.html
    Das geht natürlich, aber aus Excel heraus gibts auch ne Option... dachte ich bis vor ner Minute zumindest.
     

Diese Seite empfehlen