1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Terminalproblem: F1 Taste

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von Nonens, 22.12.05.

  1. Nonens

    Nonens Gast

    Hallo alle Zusammen!

    Ich hoffe, ich bin hier richtig, ich habe hier durch Google hergefunden, weil ich eine Frage habe, aber keine Antwort darauf weiß und auch bislang keine gefunden habe. Vielleicht kann mir ja hier jemand weiterhelfen.

    Folgender Sachverhalt:

    Einloggen auf einem Server über das Terminal / die Shell. Einloggen funktioniert wunderbar, doch auf dem Server ist eine kleine Software auf Textbasis hinterlegt, hier funktioniert also KEIN Befehl außerhalb dieser Software (kein "quit", "exit", etc.). Nun "möchte" diese Software für eine bestimmte Aktion, Starten einer Auswertung, die Funktion der Taste F1 haben. Also normalerweise sollte bei Drücken der Taste F1 eine Auswertung gestartet werden.
    Tut es aber nicht, es passiert gar nichts.

    Ich hab jetzt durch Fragen eines Kumpels herausgefunden (ich bin ja ein DAU), dass es an der Signalsteuerung meines Terminals liegt. Es wird also die eigentliche Funkion der Taste F1 nicht so übermittelt, wie es Standard ist. Weiter konnte er mir aber auch nicht helfen, weil er kein Macuser ist.

    Ich habe also ein wenig an den Terminaleinstellungen herumprobiert. Der Haken bei der escape-sequenz ist gesetzt, UTF-8 Format ist eingestellt, ich habe die Tastaturbelegung gefunden und mal versucht, dort einen mir bekannten Befehl einzugeben für die Belegung der F1-Taste, um zu testen... aber es funktioniert nicht, es wird wirklich nur der reine Text übermittelt, im Datumsfeld der Software. Da steht dann der Befehl als Text drin, den ich für F1 eingegeben hatte.

    Ich habe mehrere Zeichencodierungen ausprobiert, habe es mit Jellyfish getestet, habe in der Systemsteuerung die Tastatursteuerung geändert, nichts hilft, gar nichts. :(

    Ich bin jetzt ratlos und weiß nicht, wie ich diese Software bedienen soll.

    Kann mir hier jemand weiterhelfen?

    Vielen Dank für's Lesen auf jeden Fall und für Eure Hilfen im voraus!

    Gruß,
    Nonens
    P.S. Hier in diesem Unterforum hab ich schon alle Beiträge durchsucht und auch bei ähnlichen Problemstellungen die Tips angenommen und ausprobiert. War aber leider nicht die gleiche Frage, insofern vermute ich, dass daher auch die Lösung nicht passte.
     
  2. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    versuch mal Apfel-F-Taste. Zumindest beim Midnight Commander, der auch div. F-Tasten nutzt klappt das zuverlässig.

    Gruß Stefan
     
  3. Nonens

    Nonens Gast

    Hi stk,

    danke für Deine schnelle Antwort. "Apfel F" öffnet mir das Suchen-Fenster, "Apfel F1" hatte ich auch schon getestet (jetzt noch mal), kommt aber nur der Warnton, es passiert nichts.
     
  4. AhabDE

    AhabDE Wohlschmecker aus Vierlanden

    Dabei seit:
    23.10.04
    Beiträge:
    238
    Im OSX ssh terminal wird F1 ueblicherweise mit ^[OP uebertragen, du musst mal rausfinden, ob der remote server dies akzeptiert bzw. wie er F1 selbst uebersetzt. Das geht mit einem simplen cat F1 - hier die Taste F1, nicht ausgeschrieben! -; die Rueckgabe zeigt dir im terminal wie der remote server die zeichensequenz selber definiert hat, diese dann anstelle von ^[OP als command senden. Ansonsten hilft vielleicht auch 'man ssh' weiter, ueber allocated ttys (option -t).
     
  5. Nonens

    Nonens Gast

    Danke Dir, AhabDE!

    Das Problem ist, dass ich nicht weiß, wie ich das auf dem Server ausprobieren soll. Die Anmeldung ist dort so eingestellt, dass ich ausschließlich und sofort bei dieser Software lande, ich habe KEINE Möglichkeit, Befehle einzugeben und auszuführen. Ich wüßte nicht, wie ich dort und wo ein "Cat F1" eingeben sollte. Das einzige, was mir zur Verfügung steht, sind die Pfeiltasten zum Auswählen mehrerer Optionen und die Eingabetaste, sowie die Einstellung des Datums (um eben einen Zeitraum anzugeben). Mehr funktioniert da nicht.

    Die Taste F1 gibt "OP" zurück. Das habe ich herausgefunden, als ich "F1" drückte, während ich im Datumsfeld war.

    Trotzdem Danke für Deine Hilfe.

    Ich hoffe, es kommen noch weitere Vorschläge, wie ich das herausbekomme, wie ich die Taste belegen muß, denn ich kann mir nicht vorstellen, dass es unmöglich sein soll, dieses Mist§%)§$%-Ding zu bedienen....
     
  6. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    In den Terminalpreferences kann man das Keymapping auch für die F-Tasten einstellen.
     
  7. Nonens

    Nonens Gast

    Dankeschön, aber wie ich schon im ersten Beitrag schrieb, habe ich das bereits längst gefunden, aber es klappt auch damit nicht. Es sei denn, ich schreibe da das falsche hinein, dann bitte ich um Deine Angabe, was genau ich bei der F1-Belegung hineinschreiben soll....

    Danke im voraus! :) Und nachträglich an alle fröhliche Weihnachten! :)
     
  8. Nogger

    Nogger Damasonrenette

    Dabei seit:
    05.11.05
    Beiträge:
    494
    Drück mal Escape und dann 1.
     
  9. Nonens

    Nonens Gast

    Auch schon getestet (war ebenfalls ein Vorschlag eines Kumpels, habe es nicht aufgezählt, weil ich es vergessen hatte durch die große Auswahl an Vorschlägen).

    Klappt nicht. "Er" schreibt die Zahl 1, mehr passiert nicht.
     
  10. Nogger

    Nogger Damasonrenette

    Dabei seit:
    05.11.05
    Beiträge:
    494
    Aber du drückst die schon hintereinander, nicht zusammen, ja?

    Mehr als unter den Terminal-Einstellungen den Terminal-Typ auf VT100 zu stellen und dann nochmal Esc 1 zu versuchen fällt mir aber auch nicht mehr ein.
     
  11. Nonens

    Nonens Gast

    Hi Nogger,

    als Verzweiflungstat habe ich beide Varianten mehrfach probiert (zusammen und nacheinander gedrückt). Dein zweiter Vorschlag läßt sich nicht durchführen, weil ich dann bei dieser Einstellung nicht mehr auswählen kann, das heißt, die Pfeiltasten sind deaktiviert, ich kann nicht mehr unter den einzelnen Optionspunkten auswählen. Habe daraufhin alle Tasten auf der Tastatur gedrückt, nacheinander, um herauszufinden, ob es nun andere Tasten gibt, die die Pfeiltasten ersetzen, aber: no Chance.

    Mittlerweile habe ich das Gefühl, dass das ein Bananensoftwareprogrammierer war, denn zum einen kann ich mir nicht erklären, dass es wirklich UNMÖGLICH sein soll, mit dem Apple diese Software auf Unixbasis bedienen zu können, zum zweiten läßt sich diese Software NUR mit dem neusten Putty bedienen, unter dem alten geht es gar nicht, zum Dritten funktioniert diese Software auf einem anderen Windowssystem (Notebook) aus unbekannten Gründen auch nicht 100%ig... Es läuft also von 3 Systemen, darunter ein Mac OS X, zwei Windows XP Professional, nur auf EINEM einwandfrei. Klingt nicht nach einer sauberen Programmierung, oder sehe ich das falsch?

    Gruß,
    Nonens
     

Diese Seite empfehlen