1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Terminal löschen

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von Appelmus, 16.09.05.

  1. Appelmus

    Appelmus Jonagold

    Dabei seit:
    29.08.05
    Beiträge:
    20
    Hallo!
    Kann mir jemand sagen wie ich folgendes Problem lösen kann?
    ich habe vor einiger Zeit eine Anweisung in das Terminal -Fenster getippt, erfolglos, doch nicht ohne Folgen, denn nun erscheint immer, wenn ich das Terminal öffne, folgender Text:
    Last login:etc
    Welcome to Darwin!
    Und nun kommt immer, was ich nicht haben will:
    -bash:´export`: command not found
    Wie werde ich diese Zeile los?
    ich grüße Euch!
     
  2. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Hast Du da irgend etwas in die Datei ~/.profile eingetragen, einen Befehl der Art
    Code:
    export IRGENDWAS=wasanderes
    vielleicht? Hast Du in der Terminal-Applikation die Default-Shell verändert, von bash auf etwas anderes?
     
  3. Squart

    Squart Pomme Etrangle

    Dabei seit:
    29.01.04
    Beiträge:
    910
    kannst du die seltsame, erfolglose Anweisung vielleicht noch parat? Eventuell, indem du "history" ins Terminal eingibst?
     
  4. Appelmus

    Appelmus Jonagold

    Dabei seit:
    29.08.05
    Beiträge:
    20
    Es war folgender Eintrag.
    echo ´export PATH=/usr/local/mysql/nin:$PATH´>>~//.bash_profile
     
  5. Wikinator

    Wikinator Adams Parmäne

    Dabei seit:
    21.08.04
    Beiträge:
    1.297
    versuche doch mal die .bash_profile zu löschen. Ich glaube, du hast deine PATH-variable überschrieben, wenn das der Fall ist, müsste (wenn du tcsh) eingibst, wieder alles gehen (temporär)
     
  6. Appelmus

    Appelmus Jonagold

    Dabei seit:
    29.08.05
    Beiträge:
    20
    Hallo!
    Die Eingabe von tcsh in das Terminal bringt keine Änderung :(
     
  7. slartibartfast

    slartibartfast Schöner von Nordhausen

    Dabei seit:
    10.05.05
    Beiträge:
    323
    ne, ne... mach mal folgendes:
    Code:
    open .bash_profile
    lösche die Zeile "export PATH=/usr/local/mysql/nin:$PATH" ( <-- Statt $PATH steht da irgendwas anderes. kann auch nix dastehen. oder ganz viel. einfach die Zeile löschen), und speicher es ab.

    Grüße
    slartibartfast
     
  8. mullzk

    mullzk Linsenhofener Sämling

    Dabei seit:
    04.01.04
    Beiträge:
    2.529
    hmm, was soll die löschung des paths genau bringen (ausser dass dann vielleicht plötzlich etwas anderes nicht mehr so geht wie es sollte, weil es sich auf den shell-path beruft). das problem scheint mir doch zu sein, dass die shell mit dem befehl export nichts mehr anfangen kann, und das ist dann ja wohl ein relativ blödes problem. müsste man wohl die bash reinstallieren oder so...
     
  9. slartibartfast

    slartibartfast Schöner von Nordhausen

    Dabei seit:
    10.05.05
    Beiträge:
    323
    Das löscht nur den PATH-Eintrag, der Probleme bereitet...

    Das einzige was dann nicht mehr geht, sind einige mysql-Terminal-Befehle.
    Aber nach der derzeitigen Einstellung dürften die auch nicht funktionieren...

    Falls du die mysql-Befehle brauchst, füge das besser .profile hinzu... Aber mache aus "/nin" "/bin", gelle? ;)

    Wo aber das Problem mit dem "export" liegt, kann man schlecht sagen. Eigentlich dürfte er den Fehler nicht bringen...
    Führe mal "chsh" aus, und sag uns, ob da steht:
    Code:
    Shell: /bin/bash
    falls nicht, kann hier der Fehler liegen.

    Gruß
    slartibartfast

    PS:
    Als Übergangslösung würde ich die Zeile löschen, oder auskommentieren ("#" davorsetzen)
     
  10. Appelmus

    Appelmus Jonagold

    Dabei seit:
    29.08.05
    Beiträge:
    20
    Hallo!
    Wenn ich das mache, bekomme ich folgende Meldung:
    Vigor10:~ berndmertens$ open .bash_profile
    2005-09-19 18:42:17.824 open[244] LSOpenFromURLSpec() returned -10814 for application (null) urls file://localhost/Users/berndmertens/.bash_profile.
    Vigor10:~ berndmertens$
    DAs Problem bleibt aber bestehen. :(
    Wenn ich chsh eingebe, kommt die oben von Dir angegebene Zeile: shell bin bash
     
  11. sneumann

    sneumann Gast

    Mach mal anstatt von 'open .bash_profile' das:
    Code:
    emacs .bash_profile
    Ich bin zwar eher fuer vim, aber ich hab jetzt keine Lust dir vim naeher zu bringen :)

    Guck auch mal, ob du in ~/.profile oder /etc/profile oder in /etc/bashsrc etwas wie 'alias export="xxx"' drin hast. Ausgeben lassen kannst du die mit 'cat *meinFile*'.

    sneumann
     
  12. Appelmus

    Appelmus Jonagold

    Dabei seit:
    29.08.05
    Beiträge:
    20
    Hallo!
    Wenn ich das mache,bekomme ich die Meldung:
    File Edit Options Buffers Tools Insert Help
    \342\200\231export PATH=/usr/local/mysql/bin:/bin:/sbin:/usr/bin:/usr/sbin\342\\
    200\231
    Was erzählt uns das? :(
    Viele Grüße!
     
  13. atl

    atl Niederhelfenschwiler Beeriapfel

    Dabei seit:
    04.11.04
    Beiträge:
    842
    Versuch doch mal die Terminal-Einstellungen (Library/Preferences/com.apple.Terminal.plist) zu löschen. Ich hatte auch mal etwas ähnliches und das hat bei mir damals geholfen. :)

    ByE...
     
  14. rydl

    rydl Bismarckapfel

    Dabei seit:
    03.02.05
    Beiträge:
    77
    soweit ich das weiß, steht der path der shell in ~/.profile
    lösche doch einfach mal die .bash_profile... schau aber vorher mal nach ob du überhaupt ne .profile hast ;)
    die ganzen zeichen vor und nach deinem path sehen für mich aus, wie geparste umlaute.

    ja, denn poste mal deine .profile
     
  15. Appelmus

    Appelmus Jonagold

    Dabei seit:
    29.08.05
    Beiträge:
    20
    Hallo!
    Ich habe die apple.Terminaal.plist gelöscht, aber es ändert sich nichts.
    Dann habe ich versucht, die bash_profile zu finden, aber die gibt es nicht. Ich habe einen leeren bash -Ordner.
    Viele Grüße!
    PS.Was sind geparste Umlaute?
     
  16. sneumann

    sneumann Gast

    Probier mal in den Einstellungen eine andere Shell als Standardshell einzustellen - z.B. die zsh. Da sollte der Fehler nicht mehr kommen und du solltest erstmal wieder in Ruhe dein Terminal nutzen koennen. Wenn der Fehler dann immer noch kommt, wissen wir naemlich schon, dass es nicht an Einstellungen mit der Bash, sondern an weitgehenderen geht.

    Neum
     
  17. Kernelpanik

    Kernelpanik Ingol

    Dabei seit:
    05.03.04
    Beiträge:
    2.098
    Terminal ist was ganz unheimliches... :oops:
     
  18. Ram

    Ram Riesenboiken

    Dabei seit:
    19.06.05
    Beiträge:
    286
    Ich hab da son buch namens macosx for unix geeks, leider noch keine Zeit zum Anschaun
     
  19. mullzk

    mullzk Linsenhofener Sämling

    Dabei seit:
    04.01.04
    Beiträge:
    2.529
    das buch ist toll, aber definitiv kein einstieg für mac-user ins terminal, eher noch für unix-user auf die mac-oberfläche :-D

    mache ich ja selten, aber im konkreten fall würde ich doch mal vorschlagen, radikal aufzuräumen:
    rm .*profile*
    rm .*rc*
    damit kippst du sämtliche persönlichen terminal-einstellungen raus. tutti quanti. aber so wie ich es abschätze gibt es da auch noch nicht viel ausser einem missratenem pfad.
    das problem dürfte mit grösster wahrscheinlichkeit sei, dass bei deinem eintrag a) nin statt bin steht und vor allem b) deine anführungszeichen typographische dinger waren, und nicht das, was unix unter anführungszeichen versteht. daher auch die verwirrdende fehlermeldung, export dürfte wohl immer noch gut sein, aber er versteht die anführungszeichen nicht als metazeichen, sondern als teil des befehls export
     
  20. Appelmus

    Appelmus Jonagold

    Dabei seit:
    29.08.05
    Beiträge:
    20
    Hallo!
    Ich danke Euch allen für Eure Hilfe, besonders Dir, mullzk. Mit dem Befehl rm .*profile* verschwand die Fehlermeldung.
    Es war in der Tat so, daß das Anführungszeichen ein typografisches war, aber welches "versteht" denn unix?
    Ich grüße Euch!
     

Diese Seite empfehlen