1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Tastaturlayout in Parallels Desktop

Dieses Thema im Forum "Windows auf dem Mac" wurde erstellt von DrEvil, 10.06.06.

  1. DrEvil

    DrEvil Fuji

    Dabei seit:
    13.03.06
    Beiträge:
    36
    Hallo beisammen,

    ich habe ein paar Probleme mit dem Tastatur-Layout unter Parallels-Desktop.

    Ich verwende eine deutsche Tastatur und in Parallels auch ein deutsches Windows XP mit deutschen Tastatureinstellungen!

    Wenn ich jetzt unter Mac OS im TextEdit einen Backslash "\" machen möchte klappt das mit Alt+Shift+7 wunderbar. Unter Parallels klappt das aber nicht, da habe ich scheinbar ein englisches Layout, da ich in Parallels mit drücken der "#" einen "\" erzeuge. Mal abgesehen von anderen Sonderzeichen nervt das gewaltig.

    Wie kann ich das nun umstellen, dass ich in beiden Umgebungen das gleiche Tastatur-Layout habe?

    DrEvil
     
  2. Walli

    Walli Blutapfel

    Dabei seit:
    06.01.06
    Beiträge:
    2.594
    Also mein Tastaturlayout stimmt. Hast du die Parallels-Tools installiert? Das geht bei laufender VM unter dem Menüpunkt "VM -> Install Parallels Tools..."
     
  3. DrEvil

    DrEvil Fuji

    Dabei seit:
    13.03.06
    Beiträge:
    36
    ja, die aktuellen Parallels-Tools sind installiert.

    Versuch mal bitte in deiner VM einen "\" zu tippen. Wie funktioniert das bei dir?
    Shift+Alt+7 funktioniert bei mir nicht.

    DrEvil
     
  4. Caminim

    Caminim Golden Delicious

    Dabei seit:
    14.12.05
    Beiträge:
    8
    Moin,

    ich habe auch ein bisschen rumsuchen müssen - ich verwende Win2000 unter Parallels, definitiv mit deutscher Tastaturbelegung.

    \ kriege ich mit Alt-Ctrl-ß
    @ geht über Alt-Ctrl-q

    Probier mal ob das bei Dir auch funktioniert.
     
  5. Walli

    Walli Blutapfel

    Dabei seit:
    06.01.06
    Beiträge:
    2.594
    Ach so, jetzt verstehe ich dein Problem. Manche Sonderzeichen sind bei PC-Tastaturen anders angeordnet. Ob man das so einfach umstellen kann weiß ich nicht.

    siehe auch: http://upload.wikimedia.org/wikipedia/commons/7/78/Cherry_keyboard.jpg

    Wie schon gesagt erreicht man die unten rechts auf der Taste abgebildeten Zeichen durch "Alt Gr+Taste" oder eben durch "Ctrl+Alt+Taste" wenn es keine "Alt Gr"-Taste gibt.
     
  6. stefan.m

    stefan.m Gast

    Hallo zusammen,

    ich hab mich deshalb gerade tierisch genervt.

    Ich habe Parallels Desktop zwar schon länger auf meinem MacBook wollte es heute aber das erste Mal produktiv einsetzen. Die Betonung liegt hier auf "wollte"... Ich habe nun nämlich den ganzen Abend damit verbracht ein Swiss German Keyboard Layout für Windows XP zuerstellen. Mittlerweile bin ich soweit, dass das Keyboard Layout 1:1 dem von Mac OS X entspricht. Zumindest die Sonderzeichen die ich verwende... ;) Eigentlich finde ich es traurig, dass von Seiten von Parallels nicht mehr Unterstützung kommt.

    Gruss, Stefan.
     
  7. team75

    team75 Gast

    Auch ich bin eigentlich von Parallels sehr angetan, kämpfe jedoch so wie ihr alle mit dem Tastaturlayout. So versuche ich die AltGr - Taste auf mit dem remapkey Tool irgendwie auf die Tastatur meines MacBooks zu legen. Die rechte Apfeltaste, die man unter WinXP ja theoretisch entbehren kann, funktioniert nicht, da man bei dem Versuch ein @ - Zeichen mit AltGR und q zu generieren, jedesmal Parallels beendet. Auf irgendeine Funktionstaste möchte ich es aber auch nicht verbannen.
    Braucht man diese ALTGR - Taste denn überhaupt, und wenn ja, wie habt ihr das mit Parallels gelöst?
     
  8. Magoonzy

    Magoonzy Oberösterreichischer Brünerling

    Dabei seit:
    05.04.06
    Beiträge:
    707
    Es ist nur mal so ein Gedanke, aber wie haltet ihr es mit einer kleinen USB PC Tastatur. Ich denke dann müßte alles stimmen und gehen.

    Schätze mal Parallels wird da irgendwann nachbessern. (Hoffe ich mal)

    Lg
    Mag
     
  9. team75

    team75 Gast

    Das mit der PC - Tastatur wäre natürlich die einfache Lösung, aber ich habe an meinen Laptops nie externe Tastaturen benutzt. Und es kann gut vorkommen, dass ich Windows auch mal woanders als am heimischen Schreibtisch nutzen muss. Aber sonst stimme ich mit Dir überein - ich hoffe, dass Parallels in dieser Hinsicht in einer 1.1er Version nachbessert.
     
  10. stefan.m

    stefan.m Gast

    Hi team75,

    ich habe mit dem Keyboard Layout Generator von Microsoft ein passendes Keyboard Layout erstellt. Danach habe ich in Windows die ALT-Gr Taste auf die linke ALT-Taste vom MacBook gemappt. Dazu hier der entsprechende Registry-Eintrag:

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
    "Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,38,e0,38,00,00,00,00,00
    
    Damit verhält sich das Keyboard in Windows genau so wie unter Mac OS X. Damit lässt sich nun wirklich arbeiten. ;)

    Gruss, Stefan.
     
  11. DRathsmann

    DRathsmann Erdapfel

    Dabei seit:
    02.04.10
    Beiträge:
    1
    Bei Parallels Desktop auf MacBook Pro mit Mac OS X 10.6.3

    @ liegt bei mir auf Shift 2 , in diesem Zusammenhang - liegt auf ß und _ liegt auf Shift ß
     
  12. Saufziege

    Saufziege Erdapfel

    Dabei seit:
    01.06.12
    Beiträge:
    2
    Hier gibt's noch eine Erweiterung, da werden die beiden Tasten getauscht und zudem die neben der eins und y:
    http://www.flashdevelop.de/allgemein/prallels-desktop-tastatur-einstellen.html


    Windows Registry Editor Version 5.00[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]"Scancode Map"=hex:00,00,00,00,00,00,00,00,04,00,00,00,38,e0,38,00,38,00,38,e0,56,00,29,00,29,00,56,00,00,00,00,00
     

Diese Seite empfehlen