1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

SSH wird abgewürgt...

Dieses Thema im Forum "macOS & OS X" wurde erstellt von boijin, 26.02.06.

  1. boijin

    boijin Gast

    Hi, wenn ich per ssh auf nen Server zugreifen will, kommt nach 2min Timeout ich denke das liegt an der Firewall finde aber nicht die Einstellung zum abschalten. Wo kann ich das machen? Der Befehl geht übrigends auf meiner Linuxkiste die im selben LAN ist, liegt also nicht am Router... HILFE BITTE! ;)
     
  2. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Was sagt denn
    Code:
    ssh -v user@host
    Firewall einstellen: Systemeinstellungen->Sharing->Firewall->entfernte Anmeldung
     
  3. boijin

    boijin Gast

    debug1: An invalid name was supplied
    A parameter was malformed
    Validation error

    Das habe ich auch schon versucht mit der Firewall, aber das ist ja nur für Zugriffe von aussen auf meinen Mac...
     
  4. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    ... Du musst natürlich fuer 'user' und 'host' Entsprechendes einsetzen ... ;)
     
  5. boijin

    boijin Gast

    Aber das ist doch eine Selbstverständlichkeit, steht übrigens auch oben, dass es unter Linux klappt... So blöd bin ich nun auch wieder nicht ;)
     
  6. the_gimp

    the_gimp Gast

    versuche es mal mit Rbrowser er gibt dir eine genauere Fehlermeldung.
    http://www.rbrowser.com/
    @quarx nicht alle in diesem Forum sind DAU
     
  7. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Peace, Bruder! :-D
    Kannst Du mal eine etwas ausführlichere Ausgabe von 'ssh -v' posten?
     
  8. boijin

    boijin Gast

    debug1: Connection established.
    debug1: identity file /Users/christoph/.ssh/identity type -1
    debug1: identity file /Users/christoph/.ssh/id_rsa type -1
    debug1: identity file /Users/christoph/.ssh/id_dsa type -1
    debug1: Remote protocol version 1.99, remote software version OpenSSH_3.8p1
    debug1: match: OpenSSH_3.8p1 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_3.8.1p1
     
  9. kauan

    kauan Stina Lohmann

    Dabei seit:
    31.12.05
    Beiträge:
    1.043
    Besser gleich ssh -vvv
     
  10. boijin

    boijin Gast

    ssh -vvv root@XYZ
    OpenSSH_3.8.1p1, OpenSSL 0.9.7i 14 Oct 2005
    debug1: Reading configuration data /etc/ssh_config
    debug2: ssh_connect: needpriv 0
    debug1: Connecting to XYZ [XYZ] port 22.
    debug1: Connection established.
    debug1: identity file /Users/christoph/.ssh/identity type -1
    debug1: identity file /Users/christoph/.ssh/id_rsa type -1
    debug1: identity file /Users/christoph/.ssh/id_dsa type -1
    debug1: Remote protocol version 1.99, remote software version OpenSSH_3.8p1
    debug1: match: OpenSSH_3.8p1 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_3.8.1p1
    debug3: Trying to reverse map address XYZ.
    debug1: An invalid name was supplied
    Cannot determine realm for numeric host address

    debug1: An invalid name was supplied
    A parameter was malformed
    Validation error

    XYZ == IP des SERVERs
     
  11. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Sieht nach einem DNS-Problem aus. Kennt der Mac den debug1? Sonst könntest Du mal versuchen, den in /etc/hosts zu ergänzen, wenn gar nichts anderes hilft.
     
  12. kauan

    kauan Stina Lohmann

    Dabei seit:
    31.12.05
    Beiträge:
    1.043
    http://www.google.ch/search?q=Cannot+determine+realm+for+numeric+host+address&sourceid=mozilla-search&hl=de&num=20
    http://www.webmasterworld.com/forum40/1350.htm
     

Diese Seite empfehlen