1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Safari Textkodierung

Dieses Thema im Forum "Browser" wurde erstellt von thrillseeker, 10.01.06.

  1. thrillseeker

    thrillseeker Lord Grosvenor

    Dabei seit:
    06.10.04
    Beiträge:
    3.497
    Hallo!

    Seit ich auf Tiger umgestiegen bin, ärgert mich Safari häufig mit der falschen Darstellung von Sonderzeichen. Ich habe verschiedene Textkodierungen ausprobiert, verwende aber i.d.R. die Einstellung "Standard".
    Sobald die Angabe zur Kodierung im html-header fehlt, ist die Seite mit Fragezeichen oder Verstümmelungen übersät (überall da, wo ä, ö, ü und ß hingehören).
    Besonders komisch ist es bei der Kommentar-Funktion von einigen Weblogs. Da werden die Sonderzeichen in den Beiträgen anderer Nutzer richtig dargestellt, meine eigenen Beiträge sind aber "verstümmelt" :(

    Kennt jemand dieses Problem, und weiss ein schlauer Apfeltalker, wie es zu beheben ist?

    [UPDATE] Hier ein Beispiel. Schalte ich von Textkodierung "Standard" auf "UTF-8" um, wird mein Beitrag richtig dargestellt, allerdings sind die anderen Beiträge verstümmelt. Und das, obwohl ich in Safari's Einstellungen festgelegt habe, dass meine Standard-Kodierung = UTF-8 ist.
     
    #1 thrillseeker, 10.01.06
    Zuletzt bearbeitet: 10.01.06
  2. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.903
    Du hast es doch bereits selber erkannt, woran es liegt.

    Jetzt brauchst du nur noch einige hundert Mio. mit Windows "arbeitende" Genies dazu überreden, sich an Standards zu halten und das Problem ist gelöst...
     
  3. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    wenn man auf die "Genies" nicht warten mag, nimmt man SafariStand und nutzt die SiteAlteration-Funktion. Dort kann man dann bestimmten URLs z.B. eine fixe Kodierung zuweisen und alles ist wieder (für einen selbst) im Lack.

    Oder man surft dran vorbei ;)

    Gruß Stefan
     
    thrillseeker gefällt das.
  4. altowka

    altowka Gast

    Hallo Thrillseeker!

    Der Browser Opera hat eine Darstellungsoption "Automatische Auswahl", die solche Probleme abschafft.

    Sorry, Kommando zurück. Dein Beitrag wird auch hier nicht korrekt dargestellt. Alle anderen aber schon.. o_O?

    Gruß,
    altowka
     
    #4 altowka, 10.01.06
    Zuletzt von einem Moderator bearbeitet: 10.01.06
  5. thrillseeker

    thrillseeker Lord Grosvenor

    Dabei seit:
    06.10.04
    Beiträge:
    3.497
    Rastafari, Deine Beiträge helfen mir immer enorm weiter :(

    @stk: Ich werde jetzt mal SafariStand ausprobieren. Mal sehen, ob's was bringt...
     
  6. thrillseeker

    thrillseeker Lord Grosvenor

    Dabei seit:
    06.10.04
    Beiträge:
    3.497
    Das ist ja eigenartig. Dann machen wir jetzt mal einen Test:

    geschrieben mit Safari, Textkodierung "Standard": Umlaute ä, ö, ü, ß
     
  7. thrillseeker

    thrillseeker Lord Grosvenor

    Dabei seit:
    06.10.04
    Beiträge:
    3.497
    ...und das hier schreibe ich mit Camino:

    Umlaute ä, ö, ü, ß
     
  8. thrillseeker

    thrillseeker Lord Grosvenor

    Dabei seit:
    06.10.04
    Beiträge:
    3.497
    ...und zu guter Letzt schauen wir, ob es einen Unterschied macht, wenn ich die Umlaute über die Funktion "Beitrag bearbeiten" eingebe (Sorry, liebe Admins - in diesem Fall lassen sich Follow-Ups ausnahmsweise nicht vermeiden)

    Über "Beitrag bearbeiten" eingegeben:

    Umlaute ä, ö, ü, ß
     
  9. altowka

    altowka Gast

    Hallo Thrillseeker,

    ich hoffe, Du hast mich nicht falsch verstanden:eek: , ich bezog mich auf die Seite, die Du in Deinem ersten Post als Beispiel angegeben hattest. Und darin auf Deinen Post. Ich habe Dir mal einen Opera-Screenshot angehängt.:)

    Gruß,
    altowka
     

    Anhänge:

  10. Nogger

    Nogger Damasonrenette

    Dabei seit:
    05.11.05
    Beiträge:
    494
    Der Server schickt die Seite als ISO-8859-1 kodiert. Im den Metas und im <from> wird auch keine andere Kodierung erbeten. Safari sollte also deinen Kommentar auch als ISO-8859-1 schicken. Er schickt deinen Kommentar aber als Unicode, deshalb die falsche Darstellung deines Beitrags.
     
    thrillseeker gefällt das.
  11. thrillseeker

    thrillseeker Lord Grosvenor

    Dabei seit:
    06.10.04
    Beiträge:
    3.497
    Danke, das hilft weiter :)
    Eine letzte Frage noch: da ich ISO-8859-1 nicht in der Liste der Textcodierungen finde - was sollte ich nun als Standard festlegen? Ist "Westeuropäisch (ISO Latin 1)" das Gleiche wie ISO-8859-1?
     
  12. Nogger

    Nogger Damasonrenette

    Dabei seit:
    05.11.05
    Beiträge:
    494
    Latin 1 meint das selbe.

    Aber: Wenn ich im Safari (2.0.3) auf deine Beispielseite gehe, habe ich Text-Codierung Standard. Ich geben ein paar Umlaute ein und gehe auf Vorschau, und sie werden richtig angezeigt.

    Vielleicht wirft da irgendeine Safari-Erweiterung oder eine sonstige Einstellung etwas durcheinander.

    Leg doch mal einen neuen Benutzer an und versuche es mit dem einmal.
    Eine Text-Codierung einzustellen bedeutet, daß sie immer verwendet wird. Und dann schickst du auf UTF-8 Seiten Latin1...
     

Diese Seite empfehlen