1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Rails startet mit Ruby 1.8.2 anstatt 1.8.4

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von Gix, 11.05.06.

  1. Gix

    Gix Pferdeapfel

    Dabei seit:
    24.02.06
    Beiträge:
    78
    Das mit SCGI scheint doch nicht wirklich zu laufen - zu früh gefreut :-c . Dafür habe ich jetzt aber FastCgi zum laufen bekommen :-D

    Allerdings habe ich eine andere Frage: Auf der Rails-Startseite zeigt er mir an, dass er mit der Ruby Version 1.8.2 arbeitet. Wenn ich aber im Temrinal ruby - v mache, zeigt er mir korrekterweise 1.8.4. Die Version 1.8.4 liegt dabei in /usr/local/bin/ruby, die vorinstallierte 1.8.2 liegt in /usr/bin/ruby.

    Dateien wie z.B. dispatch.fcgi haben in der ersten Zeile #!/usr/bin/ruby stehen. Dachte mir jetzt also, dass wenn ich die Zeile ändere auf #!/usr/local/bin/ruby müsste er mit 1.8.4. arbeiten. Aber irgendwie macht er das nicht.

    Kann mir jemand helfen? Welche Dateien muss ich ändern? Oder geht das überhaupt so?

    Danke,
    Helge
     

Diese Seite empfehlen