1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

PureFTPd Manager mag keine Dateien mit Umlauten

Dieses Thema im Forum "Filetransfer" wurde erstellt von Tekl, 03.09.07.

  1. Tekl

    Tekl Fairs Vortrefflicher

    Dabei seit:
    01.06.05
    Beiträge:
    4.622
    Hi,

    ich habe mittels PureFTPd Manager einen FTP-Server eingerichtet. Leider können Windows-Leute keine Dateien mit Umlauten hochladen. LeechFTP meldet z. B. ! Upload failed on 192.168.0.1 (/UmläuteTöst.rtf). (upload not allowed) und bei EmFTP klappt es erst, wenn ich die Kodierung auf UTF-7 umschalte. Kann man Pure-FTPd dazu bewegen, dass er auch von Windows Dateien empfängt, auch ohne, dass man dort alles mögliche Konfigurieren muss? Bei LeechFTP gibt es z. B. auch keine Möglichkeit das zu ändern. Wenn die Umlaute falsch übertragen würden, wäre das auch nicht schlimm, er soll es nur nicht ablehnen.

    Muss ich im Router in der NAT eigentlich für einen FTP-Server auch Port 20 freigeben? Einige Leute kommen nicht per TLS rein. Könnte das daran liegen?
     
  2. Tekl

    Tekl Fairs Vortrefflicher

    Dabei seit:
    01.06.05
    Beiträge:
    4.622
    Hi,

    ich habe nun rausgefunden, dass man den optionalen Parameter --clientcharset angeben kann. Damit ist ein Upload möglich, wenn ich z. B. --clientcharset=cp1252 angebe. Doch komischerweise zeigt LeechFTP die Datei nicht korrekt an, ab dem ersten Umlaut wird alles abgeschnitten. Einer eine Idee? Einen anderen Charset verwenden?
     
  3. Tekl

    Tekl Fairs Vortrefflicher

    Dabei seit:
    01.06.05
    Beiträge:
    4.622
    Ah, es muss windows-1252 heißen. Danke für's zuhören ;)
     

Diese Seite empfehlen