1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

PureFTPd Manager IP-Problem

Dieses Thema im Forum "Filetransfer" wurde erstellt von Danisahne, 01.08.07.

  1. Danisahne

    Danisahne Zuccalmaglios Renette

    Dabei seit:
    02.02.06
    Beiträge:
    262
    Hallo,

    habe mir den PureFTPd Manager installiert, um einigen Freunden die Möglichkeit zu geben, etwas von meinem Mac downloaden bzw. auf meinen Mac uploaden zu können.

    Die Installation verlief problemlos und das Programm sieht ja ganz nett aus, aber wenn ich den FTP-Server starte, erscheint unten rechts im PureFTPd Manager die WAN-IP Adresse meines Routers als die IP des FTP-Servers.
    Das führt dazu, dass ich auf der Setup-Seite meines Routers lande, wenn ich über einen anderen Mac im selben Netzwerk im Browser (Firefox) versuche, mich über diese IP mit dem FTP-Server zu verbinden. Eine Verbindung über Cyberduck funktioniert über diese IP logischerweise auch nicht. Ich habe meine Zweifel, ob es überhaupt geht, dass man von einem anderen Mac im selben Netzwerk den FTP-Server erreichen kann, aber das ist ein anderes Thema. Ich habe den Router gemäß der Anleitung des PureFTPd Managers konfiguriert, die angegebenen Ports freigeschaltet und auch entsprechende Einstellungen im Programm selbst vorgenommen.

    Ich versteh einfach nicht, warum die WAN-IP meines Routers als die FTP-Server IP angegeben wird. Müsste es nicht die IP Adresse des Rechners sein, die der Rechner vom Router erhält?

    Bitte um Nachsicht für diese vermutlich etwas blöde Frage, aber von FTP, Routerkonfiguration usw. habe ich nicht viel Ahnung.

    Es wäre schön, wenn mir jemand etwas weiterhelfen könnte.

    Danke und Gruß
     
  2. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Das ist schon korrekt so. Überlege doch mal von wo Deine Freunde (netzwerktechnisch) kommen und wohin sich die verbinden müßten um Deinen Computer zu erreichen. Mit Deiner internen IP kommen sie nirgends hin es sei denn sie sind im selben LAN wie Du. Du mußt Dich zu Testzwecken intern natürlich mit der internen IP des Rechners verbinden. Daß Du Dich selbst mit Deiner eigenen externen IP nicht verbinden kannst ist nicht nur plausibel sondern sogar recht wahrscheinlich. Die meisten Router blocken aus guten Gründen so einen Loop. Bitte doch einfach mal einen Freund, daß er sich testweise mit Deinem FTP Server verbinden möge, dann sollte eigentlich alles klappen sofern die Port Forwardings auf Deinem Server korrekt eingetragen sind.
    Gruß Pepi
     
  3. CRiMe

    CRiMe Englischer Kantapfel

    Dabei seit:
    07.12.06
    Beiträge:
    1.075
    Sorry. Hat sich erledigt.
     
    #3 CRiMe, 01.08.07
    Zuletzt bearbeitet: 01.08.07
  4. Danisahne

    Danisahne Zuccalmaglios Renette

    Dabei seit:
    02.02.06
    Beiträge:
    262
    Habe ich grade versucht; geht nicht. (Ich habe in Firefox eingegeben: "ftp://die.interne.IP.meines.FTPServers")

    Folgendes steht in der Dokumentation von PureFTPd noch dazu:

    [FONT=Lucida Grande,Arial,sans-serif]"2. My FTP server is running on a dedicated machine behind a router / firewall

    This is a slightly more complicated scenario, but the logic is more or less the same. Let's assume we are in the following network topology:

    [/FONT][FONT=Lucida Grande,Arial,sans-serif] Here's what you need to do:
    • 1. Open port 20 and 21 on your firewall
      2. Open a port range on your firewall for passive FTP (42000-42010) 3. On your firewall, activate NAT and redirect traffic on ports 20, 21, and 42000 to 42010 to your FTP server IP address (192.168.1.2) on the same ports.
      4. Specify the port range in the Passive port range box of PureFTPd Manager Settings preference pane."
    [/FONT]Habe ich alles gemacht. Eine interne Verbindung ist trotzdem nicht möglich.

    Was mache ich falsch?

    Ich werde einen Freund bitten, sich von außen über die externe IP meines Routers zum FTP-Server zu verbinden, aber ich befürchte da ist noch irgendwo der Wurm drin.

    Vielen Dank für Deine Antwort!
     
  5. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Hast Du auch die Ports in der internen Mac OS X Firewall freigeschaltet?
    Gruß Pepi
     
  6. Danisahne

    Danisahne Zuccalmaglios Renette

    Dabei seit:
    02.02.06
    Beiträge:
    262
    Der Hinweis ist Gold wert!
    Hab ich jetzt gemacht und ich kann mich von einem angeren Mac im gleichen Netzwerk zum Mac, auf dem der FTP-Setrvr läuft, über Cyberduck verbinden, Dateien up- und downloaden. So weit so gut.

    Ich kann mich jedoch nicht über Firefox über die Eingabe ftp://interne.IP.des.FTPServers verbinden, was ich nicht verstehe. Das ist aber nicht so schlimm, solange eine Verbindung über Cyberduck funktioniert. Ich verstehe es nur nicht ganz, warum das über Firefox nicht klappt.

    Wie bereits erwähnt klappt eine Verbindung über die externe IP des Routers (die bei PureFTPd als die IP des FTP-Servers angegeben wird) nicht innerhalb des Netzwerks.

    Ich muss noch wie gesagt einen Freund bitten, sich über die externe IP des Routers mit dem FTP-Server zu verbinden.
    Ich hoffe nur, dass er dann nicht auf der Setup Seite meines Routers landet.

    Ich frage mich auch, wie genau das funktioniert, dass wenn jemand die externe IP des Routers (die ja gleichzeitig die IP des FTP-Servers sein soll) eingibt, dann auf dem FTP-Server Mac landet, der ja intern eine ganz andere IP hat???
    Bei der Freischaltung der Ports im Router musste ich die freizuschaltenden Ports unter Menüpunkt "Virtual Servers" als "Inbound Port" angeben, dann TCP als Type und dann unter "Private IP Adress" hab ich die interne IP des Mac eingetragen, auf dem der FTP-Server läuft. Dahinter steht noch "Private Port". Dort habe ich das selbe wie bei "Inbound Port" eingetragen.

    Verstehe ich das richtig, dass der Router bei dieser Einstellung alle Anfragen an seine externe IP an die von mir eingetragene interne IP des Rechners mit dem FTP-Server über die eingertagenen Ports weiterleitet? [​IMG]

    Danke und Gruß
     
  7. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Ja. :)
    Gruß Pepi
     
    Danisahne gefällt das.
  8. Danisahne

    Danisahne Zuccalmaglios Renette

    Dabei seit:
    02.02.06
    Beiträge:
    262
    Ok, jetzt hab ichs verstanden. :)

    Mal sehen, ob die Verbindung von außen funktioniert.

    Danke und Gruß
     
  9. Danisahne

    Danisahne Zuccalmaglios Renette

    Dabei seit:
    02.02.06
    Beiträge:
    262
    Alles funktioniert jetzt problemlos. Vielen Dank nochmal @pepi.
     

Diese Seite empfehlen