1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

OpenVPN: TUN/TAP-Device auf Intel-Mac

Dieses Thema im Forum "Officeanwendungen" wurde erstellt von Fabolu, 20.08.06.

  1. Fabolu

    Fabolu Gast

    Hallo,

    ihr habt mir ja schon so oft geholfen, da komme ich jetzt nach einigen Tagen basteln mal wieder auf euch zu.

    Ich bekomme mit meinem Intel-Mac keine OpenVPN-Verbindung zu stande. Beim Verbindungsaufbau kommt es zu "TUN/TAP-Device"-Problemen.
    Hat jemand OpenVPN oder Hamachi auf einem Intel-Mac laufen? Welche TUN/TAP-Extensions habt ihr installiert?

    Diese beiden Seiten bieten entsprechende Kernel-Erweiterungen, beide funktionieren allerdings bei mir nicht...
    http://www-user.rhrk.uni-kl.de/~nissler/tuntap/
    http://collectivity.goof.com/articles/2006/06/04/tun-tap-driver-for-mac-os-x-intel

    Schon mal einen Dank an alle Antworter...
     
  2. Fabolu

    Fabolu Gast

    Hmm ... hier hat wohl keiner eine Idee.
    Schade...

    Das sieht für Hamachi nach einer recht vielversprechenden Seite aus. Werde ich die Tage vielleicht mal ausprobieren. Die TUN/TAP-Devices laden damit wenigstens richtig, aber ich bekomme immer noch Fehlermeldungen bei OpenVPN.

    http://www.maclive.net/sid/202
     
    #2 Fabolu, 28.08.06
    Zuletzt von einem Moderator bearbeitet: 28.08.06
  3. anawak12

    anawak12 Gast

    Möglicherweise hat sich dein Problem bereits erledigt, aber ich verwende auf meinem MacBook diese TUN/TAP-Extension:

    http://www-user.rhrk.uni-kl.de/~nissler/tuntap/tuntap_tiger_20060513.tar.gz


    Alles Gute
    anawak
     
  4. stonefire

    stonefire Granny Smith

    Dabei seit:
    03.01.07
    Beiträge:
    15
    Hallo, ich will keinen neuen Thread eröffnen daher:

    Also ich habe ähnliches Problem

    Ich habe einen openvpn-server auf Suse Linux-Basis laufen und will nun per openvpn vom meinen Intel-MacBook drauf zugreifen.
    Dies hat sich bisher als nichtsbringendes Unterfangen gezeigt.
    Ich nutze "openvpn-2.0.9", habe die TUN/TAP-Extansion, die in diesem Thread vorgeschlagen auch installiert mit hilfe der mpkag (oder so), installiert. wenn ich nun openvpn auf dem Server mit der "server.conf" starte, dann erzeugt er auch ganz toll einen Netzwerk-adapter "tun2", der einsehbar ist mit "ifconfig".
    Etwas ähnliches sollte ja eigentlich auch bei ausführen des "openvpn" Befehls auf dem Client mit "client.client" passieren, aber nix, da nicht mal ansatzweise ein "tun2"-adapter.
    Beide Rechner sind in einem Gemeinsamen Lokalen Netzwerk, in der gleichem Subnetzmaske, und und und.
    Zertifikate sind alle ganz normal per konsole erstellt worden.
    Als Anhang habe ich nochmal ein paar log datein drin, wo von Client und Server Daten zu finden sind, falls jeman die sehen will. Etwa 30 sekunden oderso schaut selbst.

    Also meine "server.config" sieht wie folgt aus:
    Code:
    [SIZE=2]
    # TCP/UDP PORT, which OPENVPN should listen to:
    port 1194
    # (for each instances one port. Recommend)
    # UDP Server:
    proto udp
    # IP Tunnel is wanted:
    dev tun2
    # SSL/TLS root certificate (ca):
    ca /aaa/aaa/keys/ca.crt
    # certificate (cert):
    cert */keys/server.crt
    # certificate-key:
    key */keys/server.key
    # Diffie hellman parameters:
    dh */keys/dh1024.pem
    # (openssl dhparam -out dhxxxx.pem xxxx, xxxx= max. 2048)
    # Configure server VPN subnet supply:
    server 10.0.0.0 255.255.252.0
    # Record of client <-> Virtual-IP List.
    ifconfig-pool-persist /etc/openvpn/ipp.txt
    # Make, Client can see Client, enable:
    ;client-to-client
    # Keepalive directive:
    keepalive 10 120
    # Make Comression enable:
    ;comp-lzo
    # The persist options will try to avoid
    # accessing certain resources on restart
    # that may no longer be accessible because
    # of the privilege downgrade.
    persist-key
    persist-tun
    # Logfile:
    status */openvpn-status.log
    # Logging appropriate level:
    verb 9
    # (0-3,4,5-6,7-9)
     
    [/SIZE]
    meine client.conf:

    Code:
    [SIZE=2]
    # This is a client:
    client
    # Routing like Server:
    dev tun2
    # Connect to a udp-Server
    proto udp
    # Server IP and PORT:
    remote 10.0.0.1 1194
    # (multiple entries possible)
    # Keep trying indefinitely to resolve the Server host name
    resolv-retry infinite
    # Most clients don't need to bind to
    # a specific local port number.
    nobind
    # Try to preserve some state across restarts.
    persist-key
    persist-tun
    # SSL/TLS parms.
    ca */keys/ca.crt
    cert */keys/client1.crt
    key */keys/client1.key
     
    # Enable compression on the VPN link.
    ;comp-lzo
    # Set log file verbosity.
    verb 9 
    # Silence repeating messages
    ;mute 20
    [/SIZE]
     

    Anhänge:

  5. Skeeve

    Skeeve Pomme d'or

    Dabei seit:
    26.10.05
    Beiträge:
    3.121
    Tunnelblick verwenden wir.
     
  6. cixx

    cixx Jonathan

    Dabei seit:
    13.05.07
    Beiträge:
    83
    Tunnelblick läuft hier auch 1a
     
  7. spamhead2k

    spamhead2k Gast

    ich hab das gleiche Problem, Fehler mit den mitgelieferten tun/tap devices, aber auch keine Möglichkeit die weiter oben vorgeschlagenen Packages lassen sich nicht installieren. Die beid Tunnelblick mitgelieferten laufen auch nicht.
     
  8. Nogger

    Nogger Damasonrenette

    Dabei seit:
    05.11.05
    Beiträge:
    494
    Thread bitte in passendes Forum verschieben

    Könnte ein Moderator bitte den Thread in ein Netzwerkforum verschieben? Danke!
     

Diese Seite empfehlen