1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

öffnen mit... Schönheitsfehler

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Victance, 21.06.06.

  1. Victance

    Victance Boskop

    Dabei seit:
    01.11.05
    Beiträge:
    213
    hallo,
    seit meinem umstieg auf mein powerbook, gibt es einen kleinen schönheitsfehler... wenn ich ein z.b. ein lied auf dem desktop habe welches noch nicht in der itunes bibliothek steht, und es öffnen will, gehe ich auf öffnen mit... und dort steht dann itunes,quicktime player, vlc doppelt dort!ich weiß es ist nur eine kleinigkeit aber irgendwie stört es mich!
    woher kommt es, dass es doppelt dort steht und wie bekomme ich es wieder weg?
    gruß und danke
     
  2. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.896
    Du hast ein zweites Volume gemountet (mit System drauf)?
     
  3. Peter Maurer

    Peter Maurer Carmeliter-Renette

    Dabei seit:
    16.03.04
    Beiträge:
    3.274
    Deine LaunchServices-Datenbank ist wahrscheinlich kaputt. Bei MacOSXHints.com z.B. gibt's dazu einen Thread.
     
  4. xScorpiex

    xScorpiex Eifeler Rambour

    Dabei seit:
    02.02.06
    Beiträge:
    596
    Ich würde mal Tippen dass Du aus versehen zwei Versionen von VLC installiert hast! Schau doch einfach mal mit Spotlight! Könnte auch auf externer HD sein.
     
  5. Victance

    Victance Boskop

    Dabei seit:
    01.11.05
    Beiträge:
    213
    was heißt kaputt, ist das was schlimmes kenn mich damit leider gar nicht aus :(
     
  6. Victance

    Victance Boskop

    Dabei seit:
    01.11.05
    Beiträge:
    213
    nein ich habe keine 2versionen installiert, spotlight findet auch nur eine

    aber es wäre toll wenn mir jemand erklären könnte wie ich die LaunchService-Datenbank reparieren kann...
    wäre echt spitze
     
  7. Peter Maurer

    Peter Maurer Carmeliter-Renette

    Dabei seit:
    16.03.04
    Beiträge:
    3.274
    Nicht schlimm, nein.

    Wie im verlinkten Thread nachzulesen ist, repariert man das, indem man diese Datenbank loescht. Wie das geht, steht auch dort; einfach mal alle Kommentare lesen.

    Das System erstellt die Datenbank dann neu. Das merkst Du daran, dass Du wieder fuer jedes Programm gefragt wirst, ob Du entsprechende Dateien tatsaechlich mit diesem Programm oeffnen willst.

    Und damit wir nicht aneinander vorbeireden: Alle Programme in Deinem Kontextmenue sind doppelt, gell?
     
  8. Victance

    Victance Boskop

    Dabei seit:
    01.11.05
    Beiträge:
    213
    nein der mplayer ist nicht doppelt!!!
    nur die drei, die ich oben genannt hatte
    gruß
     
  9. Peter Maurer

    Peter Maurer Carmeliter-Renette

    Dabei seit:
    16.03.04
    Beiträge:
    3.274
    Hier zu Deiner vollstaendigen Bequemlichkeit das entscheidende AppleScript:

    Code:
    display dialog "The Finder must quit and will relaunch after the Launch Services rebuild is complete. The rebuild may take several minutes, during which time you should refrain from using any other apps." buttons {"Cancel", "Rebuild LS Database"} default button 2 with icon caution
    ignoring application responses
    	tell application "Finder"
    		delay 2
    		quit
    	end tell
    end ignoring
    delay 5
    tell application "System Events" to set running_applications_ to get name of every application process
    if running_applications_ contains "Finder" then do shell script "killall Finder"
    do shell script "/System/Library/Frameworks/ApplicationServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user"
    tell application "Finder"
    	delay 2
    	activate
    end tell
    tell me to activate
    display dialog "The Launch Services rebuild is now complete." buttons {"OK"} default button 1 with icon note
    Benutzung auf eigene Gefahr!

    --

    EDIT: einfacher mPlayer macht nix; ich halte das trotzdem fuer die wahrscheinlichste Ursache.
     
  10. Victance

    Victance Boskop

    Dabei seit:
    01.11.05
    Beiträge:
    213
    ich glaub ich stell mich grad sau dämlich an, aber ich hab ehrlich gesagt keine ahnung was ich nun mit dem script anfangen soll, tut mir echt leid :(
     
  11. high-end-freak

    high-end-freak Herrenhut

    Dabei seit:
    16.12.05
    Beiträge:
    2.289
    mit onyx geht das auch...mit grafischer benutzeroberflaeche:D

    allerdings ist onyx mit vorsicht zu geniessen.
     
  12. Peter Maurer

    Peter Maurer Carmeliter-Renette

    Dabei seit:
    16.03.04
    Beiträge:
    3.274
    Onyx -- keine Ahnung. Was das AppleScript betrifft, gehst Du so vor:

    1. Kopiere es komplett (das kann mit der Apfeltalk-Code-Box etwas schwierig sein)
    2. Oeffne /Programme/AppleScript/Skripteditor.app
    3. Ein leeres AppleScript-Dokument erscheint
    4. Da fuegst Du das kopierte Skript rein
    5. Klick auf den "Skript ausfuehren"-Knopf
     
    Herr Sin gefällt das.
  13. Victance

    Victance Boskop

    Dabei seit:
    01.11.05
    Beiträge:
    213
    ok vielen dank! hat einwandfrei geklappt, und sogar ich als dummerchen habs so hingekriegt! danke, danke, danke PETER MAURER und auch den anderen
     
  14. Peter Maurer

    Peter Maurer Carmeliter-Renette

    Dabei seit:
    16.03.04
    Beiträge:
    3.274
    Kein Problem. Diesem Fehler bin ich dank ServiceScrubber schon so oft begegnet, dass ich die Loesung immer griffbereit habe. :-D
     
  15. gabiwan

    gabiwan Gast

    auch ein dankeschön von mir! hat prima geklappt...
     
  16. pumpkin

    pumpkin Gelbe Schleswiger Reinette

    Dabei seit:
    01.11.04
    Beiträge:
    1.764
    .
     
    #16 pumpkin, 07.09.07
    Zuletzt bearbeitet: 07.10.07
  17. meiser

    meiser Zuccalmaglios Renette

    Dabei seit:
    24.08.06
    Beiträge:
    260
    Ein herzliches Dankeschön auch von mir!
    Hat einwandfrei geklappt :)
     
  18. alex_neo

    alex_neo Roter Stettiner

    Dabei seit:
    26.04.05
    Beiträge:
    965
    Kann es sein, dass sich unter Leopard der Pfad für das "LaunchServices.framework" geändert hat? Bei mir (Leopard) ist das jedenfalls unter "CoreServices" zu finden und nicht mehr unter Application Services. Bei Ausführung des ursprünglichen Apple Scriptes habe ich auch immer eine Fehlermeldung bekommen ("No such directory"), nachdem ich per Spotlight den "Launchservices.framework" gefunden hatte und den Pfad im Script angepasst hatte, hat er die Datenbank aber erfolgreich neu aufgebaut.
     
    Peter Maurer gefällt das.
  19. Peter Maurer

    Peter Maurer Carmeliter-Renette

    Dabei seit:
    16.03.04
    Beiträge:
    3.274
    In der Tat. Ich hab' das Skript seit Mac OS X 10.5 noch nicht verwendet, deshalb ist mir das nicht aufgefallen.
     

Diese Seite empfehlen