1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

MacBook WLAN Probleme - Lösungen

Dieses Thema im Forum "Mobil-Macs" wurde erstellt von ontje, 12.12.06.

  1. ontje

    ontje Gast

    Hallo Forengemeinde!

    Nach dem ich nun einige Tage Probleme mit der WLAN-Verbindung zu meinem Router hatte und nun endlich eine Lösung gefunden habe, möchte ich euch diese hier beschreiben, denn ich habe schon viele Beiträge gesehen, in denen es auch um Problem mit AirPort Express ging. Die gleichen Vorschläge sollten auch für alle anderen intel-basierten Macs gelten.

    Bei mir tauchte folgendes Problem auf:

    MacBook C2D, weiß, erkennt mein WLAN und verbindet sich auch mit einer stabilen Verbindung. Nach zuklappen des Deckels findet er beim Öffnen das WLAN zwar, kann sich allerdings nicht verbinden. Ein Dialog erscheint, in diesem kann man auf "Erneut versuchen" klicken und das MB probiert sich nochmal einzuwählen. Nach ca. 3-4 steht die Verbindung dann, bis zum nächsten Sleep oder Neustart. Teilweise musste ich AirPort de- und reaktivieren um eine Verbindung zu erhalten. Kein Windows Client hatte ähnliche Probleme. Nach langem Suchen kam ich eher durch Zufall auf die Lösung. Ich habe in meinem Router als WLAN-Standard statt "mixed-mode" (b/g) einfach auf "g-only" gestellt, sodass er nur noch den g-Standard sendet und empfängt. Seither habe ich keine Probleme, anscheinend sind Apples neuen AirPort Karten noch nicht ausgereift!

    Hier nochmal eine kleine Zusammenfassung der Lösungsvorschläge aus anderen Beiträgen (haben bei mir nicht geholfen, bei anderen schon)

    Router:
    1. Firmwareupdate
    2. MAC-Filterung aktivieren, so dass der DHCP dem MacBook immer die gleiche IP zuweist (manche Router brauchen zu lange um dem Book eine IP zuzuweisen, das Book lässt die Verbindung dann fallen).
    3. SSID-Broadcast aktivieren (heißt oft z.B. "WLAN-Namen anzeigen" bzw. "WLAN ID").
    4. Verschlüsselungstyp ändern (WEP ist _keine_ Option, weil zu unsicher, allerdings gänge beispielsweise WPA2-Privat (WPA2-PSK) oder WPA-Privat (WPA-PSK).
    5. Passwort/Key ändern, so dass er nur HEX-Zeichen (Ziffern 0-9; Buchstaben A-F) enthält, maximale Länge: 64 Zeichen.
    6. WLAN-Standard ändern (das half bei mir) z.B. von "mixed b/g" auf "g-Standard".
    7. Den Standardkanal ändern. (Hier kann es helfen, wenn man mal mit iStumbler nachschaut, auf welchen Kanälen andere Netze funken und dann einen probiert auf dem keiner/wenige funken)
    MacBook:
    1. WLAN zu den "bevorzugten Netzen" hinzufügen: Apfel -> Systemeinstellungen -> Netzwerk -> bei "Anzeigen" "AirPort" auswählen -> "Standardmäßig verbinden mit:" auf "Bevorzugte Netzwerke" stellen -> unten "+" klicken und die WLAN Daten eintragen.
    2. Update installieren, zu finden hier: http://www.apple.com/support/downloads/airportupdate2006002.html und hier: http://www.apple.com/support/downloads/airportextremeupdate2007001.html
    3. Falls WEP benutzt wird (diese Verschlüsselung ist übrigens sehr unsicher), vor dem Passwort ein "$" einsetzen. Also steht dann im Passworteingabefeld z.B. "$mein-wep-passwort".
    4. Apple empfiehlt, die betroffenen Netzwerke in den AirPort-Einstellungen zu löschen und neu anzulegen.
    Ich hoffe, ich kann hiermit dem einen oder anderen helfen! Sollte jemand weitere Tipps haben, bitte Posten und ich werde sie dann eintragen.

    Grüße
     
    #1 ontje, 12.12.06
    Zuletzt von einem Moderator bearbeitet: 31.01.07
  2. bröingö

    bröingö Alkmene

    Dabei seit:
    01.01.07
    Beiträge:
    34
    Hallo Forengemeinde,

    erstmal Lob zu eurem Forum und der kompetenten Unterstützung, gerade für neue Mac-User (...so einer wie ich).

    Ich habe das oben geschriebene in genau der Reihenfolge durchgeführt. Leider konnte ich mich mit dem Router (in diesem Fall ein T-Sinus 154 wie oben) nicht verbinden. Ich kann mir nicht mehr vorstellen, woran das liegen kann. Ich habe drei Router probiert (Zyxel, T-Sinus 154 und FritzBox!) und keiner der drei funtionierte. Nur bei der FritzBox konnte ich ein Netz einrichten, dass aber ungesichert war.

    Gibt es vielleicht in näherer Zukunft ein Update oder so, mit dem dann die Wlan-Karten richtig laufen. Es kann doch nicht sein, dass so viele Leute über das neue MacBook stöhnen, weil Wlan nicht funktioniert. ich habe schon diverse Foren gelesen, überall gleiche Probleme.


    Ich würde mich freuen, wenn ihr mir Vorschläge zu meinen Routereinstellungen für den Sinus 154 machen könntet. Wie gesagt, oben genanntes läuft leider nicht!!!

    Vielen Dank

    BröinGÖ
     
  3. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Ich habe die Sinus Geräte bei 2 Bekannten im Einsatz.
    Verschlüsselung WPA (der eine wird als WPA2 angezeigt)
    SSID wird gesendet
    Key ist etwas länger einfach in ASCI eingegeben (ist halt ein etwas längerer)
    Macfilter ist bei beidem aus.
    Mein MB hat beide Netze direkt gefunden (war auch bei dem ersten Kontakt in der Nähe, danach keine Probleme) und nach dem Schlüssel gefragt. Diesen dann einfach den Schlüsselbund hinzugefügt.
     
  4. gtemmel

    gtemmel Rheinischer Krummstiel

    Dabei seit:
    20.10.06
    Beiträge:
    376
  5. ontje

    ontje Gast

    Ja, genau. Installier dir mal das Update. Hat bei einigen hier schon wunderbar geholfen, mir auch, zumindest beim Router meiner Freundin (ein Netgear) zu dem ich erst nach dem Update verbinden konnte.

    PS: Habe das Update jetzt meiner Liste hinzugefügt
     
    #5 ontje, 03.01.07
    Zuletzt von einem Moderator bearbeitet: 03.01.07
  6. bröingö

    bröingö Alkmene

    Dabei seit:
    01.01.07
    Beiträge:
    34
    Hallo liebe Forenuser,

    habe das Update gerade installiert. Leider klappt die Verbindung zum T-Sinus 154 immer noch nicht. Ich habe verschiedene Dinge ausprobiert (WEP, WPA, Unverschlüsselt, ...). Ich werde die Tage mal das Macbook mit dem Update und einem anderen Router ausprobieren. ich halte euch auf dem laufenden. Irgendwie schon schade, da hat man so ein schönes Gerät und dann läuft doch alles irgendwie nicht so, wie man es sich vorher vorgestellt hat. Trotzdem danke für eure Hilfe, ich habe die Info mit dem Update noch gar nicht gesehen, obwohl ich hier schon fast alle Beiträge gelesen habe!

    Gruß

    BröinGÖ
     
  7. kristofer

    kristofer Weisser Rosenapfel

    Dabei seit:
    15.02.05
    Beiträge:
    779
    Hast Du schonmal dran gedacht einfach Deine Macadresse im Router einzugeben...also auf den ganzen Wepverschlüsselungsheckmeck zu verzichten?
     
  8. crossinger

    crossinger Doppelter Melonenapfel

    Dabei seit:
    30.07.06
    Beiträge:
    3.369
    Und dann? Die MAC-Adresse wird grundsätzlich unverschlüsselt übertragen. Die aus den Paketen herauszufischen ist eine Sache von Sekunden!!! Und die MAC-Adresse am Interface ändern ist auch keine Geheimwissenschaft mehr. Der MAC-Filter am Router ist also nicht mehr als ein Feigenblatt - aber keinesfalls als Ersatz oder gar einzige Sicherheitsmaßnahme zu benutzen.

    *J*
     
  9. kristofer

    kristofer Weisser Rosenapfel

    Dabei seit:
    15.02.05
    Beiträge:
    779
    Also reicht es nicht, wenn ich meinen Router nur auf Macadressen spezialisiere und die ESSID als versteckt betreibe?
     
  10. crossinger

    crossinger Doppelter Melonenapfel

    Dabei seit:
    30.07.06
    Beiträge:
    3.369
    Nein, das ist absolut *NULL* Schutz. Durch reines Belauschen des Datenverkehrs bekommst Du beides im Handumdrehen. Im Gegenteil: MAC-Filter verkomplizieren den Betrieb, weil Du dann erst für "Gäste" konfigurieren mußt. Die versteckte SSID kann sogar Verbindungsprobleme (siehe oben) verursachen.

    Du verkomplizierst den Verbindungsaufbau unnötig ohne einen Mehrwert an Schutz - also nutzlos!

    *J*
     
  11. kristofer

    kristofer Weisser Rosenapfel

    Dabei seit:
    15.02.05
    Beiträge:
    779
    Was ist also dann der sinnvollste Schutz?
     
  12. crossinger

    crossinger Doppelter Melonenapfel

    Dabei seit:
    30.07.06
    Beiträge:
    3.369
    WPA mit pre-shared Key. Und zwar in maximaler Länge (63 Zeichen) und Nonsens:

    6T5Gz;1)v3B7LhpJz92`:TWbSrKGD (und so weiter)

    Hier gibt's sowas fertig:

    http://darkvoice.dyndns.org/wlankeygen/

    Ich habe das selbst so in Betrieb und null Probleme! Und das, obwohl noch ca. 10 weitere Router hier im Haus vor sich hindödeln. Einer davon "offen", einige mit WEP, die meisten mit WPA-PSK. So soll's sein!

    *J*
     
  13. bröingö

    bröingö Alkmene

    Dabei seit:
    01.01.07
    Beiträge:
    34
    Hallöchen,

    hat denn von euch jemand Erfahrung mit dem Zyxel
    660 HW-67 bei Betrieb mit MacBook? Das ist nämlich bei mir zu Hause die Hardware, die bis jetzt OHNE Update aber mit allen möglichen Konfigurationen nicht lief. Weiß einer, ob das mit Update besser läuft? Was mich an diesen Wlan-Konfigurationen auch total wundert ist, dass mein MacBook die Passwörter im Schlüsselbund auch nicht speichert. Ich bin jedesmal gezwungen, die Wörter neu einzugeben. Dabei spielt es keine Rolle, ob ich die Verschlüsselung unter Systemeintellungen etc. oder direkt bei Airport eingebe....

    Grüße

    BröinGÖ
     
    #13 bröingö, 03.01.07
    Zuletzt bearbeitet: 03.01.07
  14. kristofer

    kristofer Weisser Rosenapfel

    Dabei seit:
    15.02.05
    Beiträge:
    779
    [​IMG]

    Soweit ich das sehe kann ich bei mir gar keinen WPA PSK eingeben.
     
  15. crossinger

    crossinger Doppelter Melonenapfel

    Dabei seit:
    30.07.06
    Beiträge:
    3.369
    Probier's mal mit "Persönlicher WPA". Das dort geforderte Kennwort ist der PSK!

    *J*
     
  16. kristofer

    kristofer Weisser Rosenapfel

    Dabei seit:
    15.02.05
    Beiträge:
    779
    Achso...ich dachte da muss wie beim WEP nochmal extra die länge bzw. ACSII oder HEX dabeistehen öööööhm ;)

    ...aber kann es sein, dass mein arcor 100er Modem bzw. die Software drauf nur WEP 256 unterstützt?!
     
  17. crossinger

    crossinger Doppelter Melonenapfel

    Dabei seit:
    30.07.06
    Beiträge:
    3.369
    Kann sein, der Router muß natürlich auch WPA kennen/können - sonst nützt's nix! Der Part mit der schwächsten Verschlüsselung bestimmt die Gesamtverschlüsselung im Netz.

    Aber dafür mußt Du nochmal einen Blick in die Doku zum Arcor Modem werfen. Die Technischen Details Deiner Hardware kann ich nun wirklich nicht aus dem Ärmel schütteln... ;)

    *J*
     
  18. harrym

    harrym Fuji

    Dabei seit:
    26.04.06
    Beiträge:
    37
    Schon mal mit BootCamp und WinXP experimentiert? Ich hatte mal ein MBP der ersten Generation und da funkte das WLAN unter XP einwandfrei, nur unter MacOSX nicht. Das hat so genervt, dass ich von meinem Rückgaberecht gebraucht gemacht habe. Schade eigentlicht, dass die das bei Apple offenbar immer noch nicht im Griff haben, wollte mir nämlich demnächst ein MBP mit Leopard holen. Wird anscheinend wieder nix.
     
  19. sweepy75

    sweepy75 Morgenduft

    Dabei seit:
    27.12.06
    Beiträge:
    167
    Wep

    Also, ich habe einen D-Link.Router und habe ihn einfach mit einem 10-stelligen WEP.Kennwort verschlüßelt.

    Mit meinem MAC-Book komme ich nicht rein. Sowohl unverschlüsselt (bei deaktivierten WEP-Key), als auch verschlüsselt, wenn ich den 10-stelligen Key eingebe.

    Was mach ich falsch?
     
  20. bröingö

    bröingö Alkmene

    Dabei seit:
    01.01.07
    Beiträge:
    34
    Hallöchen

    mit WinXP und BootCamp läuft das Wlan genauso gar nicht wie unte normalen Bedingungen... Scheint also an einem Hardwareproblem zu liegen, oder sehe ich das falsch?

    gruß

    BröInGÖ
     

Diese Seite empfehlen