1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Mac mini wacht ungewollt aus dem Ruhezustand auf

Dieses Thema im Forum "macOS & OS X" wurde erstellt von konradtönz, 31.08.06.

  1. konradtönz

    konradtönz Süssreinette (Aargauer Herrenapfel)

    Dabei seit:
    23.07.04
    Beiträge:
    411
    Guten Morgen allerseits.

    Seit einigen Wochen wacht mein Mac mini (PPC, OS X 10.4.7) ohne offensichtlichen Grund aus dem Ruhezustand auf - und zwar sowohl dann, wenn er nach meinen zeitlichen Vorgaben automatisch schlafen geht, als auch nach einem "herbeigeführten" Ruhezustand. Es dauert nur jeweils ca. ein bis zwei Sekunden bevor er wieder aufwacht.

    Meine erste Vermutung war, dass mein kleiner Freund nach etwas über einem Jahr nun in die Pubertät kommt und sich jeglicher Form von Autorität, mit der er sich durch mich (gewissermaßen als sein Erziehungsberechtigter) konfrontiert sieht, entgegenstellt. Wir kennen das ja alle noch... Vermutlich bin ich hier aber mit meiner Vermutung unserer Zeit etwas voraus - aber wer weiß, vielleicht müssen wir das Forum eines Tages um den Bereich "Systempädagogik und -sozialisation" erweitern.

    Auf der Suche nach einem realistischen Lösungsansatz für das Problem hier im Forum bin ich auch auf einige Beiträge gestoßen, die sich aber meist auf Books bezogen oder keine wirkliche Lösung brachten.

    Ich habe eine Bluetooth-Tastatur und -maus und gestatte diesen auch, den Ruhezustand zu beenden. Bisher gab es dadurch aber keine Probleme. Sonst ist mit dem Mac nur noch ein Drucker über USB verbunden, der in den betreffenden Fällen aber ausgeschaltet war und vorher in diesem Zusammenhang auch keine Probleme gemacht hat.

    Im System-Profiler habe ich entdeckt, dass unter "Ruhezustand bei administrativen Netzwerk-Zugriffen beenden" ein "Ja" steht. Was ist hiermit eigentlich gemeint? Kann oder sollte ich diese Option deaktivieren?

    Habt Ihr andere Lösungsvorschläge?

    Edit: Und dann gibt es noch ein Handy, bei dem Bluetooth aber nur eingeschaltet ist, wenn ich es mit dem Mac synchronisiere.
     
    #1 konradtönz, 31.08.06
    Zuletzt bearbeitet: 31.08.06
  2. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    das würde ich mal deaktivieren.
    und das drucker kabel abhängen.
    und vielleicht posten, ob es geholfen hat
     
  3. konradtönz

    konradtönz Süssreinette (Aargauer Herrenapfel)

    Dabei seit:
    23.07.04
    Beiträge:
    411
    Erst einmal vielen Dank, QuickMik.

    Ich versuche es jetzt mal schrittweise (erst die Netzwerk-Option und dann falls nötig der Drucker).

    Ich habe eben die betreffende Netzwerk-Option in den Systemeinstellungen deaktiviert. Vorher habe ich mit den alten Einstellungen aber noch einmal versucht einen Ruhezustand herbeizuführen - und es hat problemlos funktioniert. Genau das ist auch das Schwierige an diesem Problem: Es passiert nicht bei jedem Ruhezustand.

    Ich lasse es mit den neuen Einstellungen jetzt einfach mal laufen und schaue, was passiert.

    Ich wünsche einen guten Start in den Tag.
     
  4. Neorun

    Neorun Uelzener Rambour

    Dabei seit:
    11.05.06
    Beiträge:
    374
    sehr komisch - in letzter zeit häufen sich die aufwach-Berichte...

    Meine Theorie ist, das die Hardware sich so auf Leopard freut, dass sie ständig bereit sein will...
     
  5. konradtönz

    konradtönz Süssreinette (Aargauer Herrenapfel)

    Dabei seit:
    23.07.04
    Beiträge:
    411
    Das bestätigt dann doch irgendwie meine ursprüngliche Vermutung: Der Mac ist ein Mensch.

    Edit: Und da stellt sich nach kurzer Überlegung für mich doch gleich die Frage, ob man hier einen Anspruch auf Kindergeld geltend machen könnte? Ich würde dann glatt noch eines von diesen Intel-Babies bei mir aufnehmen (vollkommen uneigennützig natürlich).
     
    #5 konradtönz, 31.08.06
    Zuletzt bearbeitet: 31.08.06
  6. sk_dakota

    sk_dakota Morgenduft

    Dabei seit:
    16.10.05
    Beiträge:
    165
    Ich hatte das Problem auch schon einige Male:
    Gern dafür verantwortlich ist z.B. angesteckte (USB)-Hardware, die diesen Zustand offensichtlich nicht mag. Beim letzten Mal war es diese Belkin-USB-Hub

    http://catalog.belkin.com/IWCatProductPage.process?Product_Id=229895

    Genau so wie auch Bluetooth-Geräte wie z.B. die alte Bluetooth-MacMice Maus.
    Hier half die Option "Bluetooth-Geräte dürfen Ruhezustand beenden" zu deaktiveren.

    Helfen tut natürlich in jedem Fall solche Geräte zu entfern, was ich in beiden Fällen getan hab. Hauch wech den Sch... :p
     
  7. Neorun

    Neorun Uelzener Rambour

    Dabei seit:
    11.05.06
    Beiträge:
    374
    Das mit dem Bloototh Haken ist ne gute Idee...mein K8001 liegt immer irgendwo in der gegend rum...werd ich an meinem MBP gleich mal testen!

    Wenn mir nun noch wer saen könnte warum EyeTV nicht mehr automatisch (nach ner Aufnahme) in den ruhezustand wechselt wäre ich happy...
     
  8. klausimausi

    klausimausi deaktivierter Benutzer

    Dabei seit:
    05.01.04
    Beiträge:
    836
    Ich hatte das Problem mit meinem alten G4.

    Nachdem ich das Häkchen bei ""Ruhezustand bei administrativen Netzwerk-Zugriffen beenden" entfernt hatte, schläft das Teil durch, bis ICH es aufgewecke.

    Ich frage mich allerdings bis heute, wer oder was "administrative Zugriffe" gestartet hat??? Ich gehe nur über Airport ins Netz, der Drucker war jedes Mal ausgeschaltet...?


    Gruß

    Klaus
     
  9. konradtönz

    konradtönz Süssreinette (Aargauer Herrenapfel)

    Dabei seit:
    23.07.04
    Beiträge:
    411
    Auch bei mir scheint die Deaktivierung der Netzwerk-Zugriffe die Lösung des Problems zu sein. Zumindest lief jetzt einen Tag lang in Bezug auf den Ruhezustand alles wie gewünscht.

    Aber auch mich würde interessieren, was genau hinter dieser Option steckt.
     
  10. konradtönz

    konradtönz Süssreinette (Aargauer Herrenapfel)

    Dabei seit:
    23.07.04
    Beiträge:
    411
    Da habe ich mich wohl zu früh gefreut. Eben ist mein kleiner Freund wieder in alte Verhaltensmuster verfallen und aus seinem (eigentlich wohlverdienten) Ruhezustand sofort wieder erwacht.

    Ich werde morgen mal schauen, ob es vielleicht der Drucker ist.
     
  11. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    mach das mal...
    sonst gehts ans eingemachte
     
  12. konradtönz

    konradtönz Süssreinette (Aargauer Herrenapfel)

    Dabei seit:
    23.07.04
    Beiträge:
    411
    Dann geht es wohl ans Eingemachte. Der Drucker ist auch nicht das Problem. Außer dem Apple Display hängt jetzt nichts mehr am Rechner. Maus und Tastatur weiter über Bluetooth. Sonst gibt es nur noch eine WLAN-Verbindung mit der Fritz!Box.

    In Beitrag beschreibe ich hier ein anderes aktuelles Problem (Lüfter auf Hochtouren). Ich weiß nicht ob ein Zusammenhang bestehen könnte bzw. ob es für eure Diagnose nützlich ist.
     
  13. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    ok....mal das eingemachte.
    saug dir applejack und cocktail.

    lass cocktail im pilotenmodus mit allen häckchen laufen.
    nach dem neustart gleich mit apfel+s in den singe user mode.
    dann "applejack AUTO restart" eingeben.
    dann den PRAM löschen
    nach dem startton die tasten apel+alt+p+r solange halten,
    bis du den startton das 3te mal hörst.

    danach den NVRAM löschen
    apfel+alt+o+f (open firmware modus)
    du bekommst einen grauen bildschirm mit dunkler schrift.
    beim eingabe prompt schreibst du (vorsicht ami tastatur aktiv der bindestrich ist am ß)

    reset-nvram
    set-defaults
    reset-all

    dann macht die kiste einen neustart.
    du bleibst auf dem einschaltknopf 5 sec. drauf, damit sich die kiste ausschaltet.
    dann kannst ihn wieder einschalten.....
    und hier berichten, ob es was gebracht hat.

    HTH
    mike
     
  14. konradtönz

    konradtönz Süssreinette (Aargauer Herrenapfel)

    Dabei seit:
    23.07.04
    Beiträge:
    411
    QuickMik, ich danke Dir für Deine sehr ausführliche Beschreibung zur Lösung des Problems.

    Nachdem mein kleiner Freund jetzt seit langem die erste Nacht brav durchgeschlafen hat, gebe ich ihm noch ein paar Tage - vielleicht klappt es ja jetzt (die Hoffnung stirbt zuletzt).

    Ich wünsche Dir einen erholsamen Abend.
     
  15. konradtönz

    konradtönz Süssreinette (Aargauer Herrenapfel)

    Dabei seit:
    23.07.04
    Beiträge:
    411
    Also gut, mein kleiner Freund hat seine Chance gehabt.

    QuickMik, ich werde mich jetzt mal durch Deinen Lösungsvorschlag arbeiten. Eines interessiert mich noch: Was genau bewirkt das von Dir beschriebene Verfahren? Nicht, dass ich es mir zutraue ein Verständnis für die Tiefen des Systems zu entwickeln, aber irgendwie bin ich immer um ein Grundverständnis der Abläufe bemüht (oder dieses zumindest anzubahnen, wie es so schön in der Grundschulpädagogik heißt).

    Viele Grüße
     
  16. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    oje, d.h. er schläft noch immer nicht durch :eek:

    oops ein lehrer ?
    ok ich vesuch es mal.
    das system und viele programme legen sich cache dateien und temporäres zeug an.

    da kann es oft passieren, das solche dateien defekt werden oder einfach schlecht aufgeräumt sind.

    mit s.g. maintenance programmen kann man das alles auf einmal löschen.
    dazu verwende ich cocktail und applejack, beide machen ähnliche dinge.
    nachdem ich diese beiden jungs aber sehr oft brauche, hab ich bemerkt,
    das einmal das und einmal das andere besser wirkt.
    was die dinger genau machen steht im manual.

    oder du machst dich z.b. bei versiontracker ein wenig schlau

    mehr info zu PRAM und NVRAM gibts bei apple

    der letzte absatz enthält erfahrungswerte von mir.
    die vergangenheit hat gezeigt, das ausschalten sich oft sehr von einem neustart unterscheidet :-D

    HTH
    mike
     
  17. konradtönz

    konradtönz Süssreinette (Aargauer Herrenapfel)

    Dabei seit:
    23.07.04
    Beiträge:
    411
    Auch wenn ich mit meinen Erfolgsberichten nach dem seit Wochen bestehenden Ruhezustands-Problem etwas zurückhaltender geworden bin:

    Ich hatte jetzt endlich Zeit, mich dem Problem ausführlicher zu widmen und habe einige Dinge noch einmal ausprobiert. Im Moment sieht es so aus:

    Der Ruhezustand wird offenbar durch ein Bluetooth-Gerät ungewollt beendet - und zwar durch die Apple BT-Maus und/oder die Apple BT-Tastatur!

    Ich habe in den Systemeinstellungen die Option "Bluetooth-Geräten ermöglichen, den Ruhezustand beenden" deaktiviert. Plötzlich schlief das Baby tief und fest. Wie gesagt, ich bin vorsichtig geworden - aber im Moment sieht es ganz gut aus.

    Außer der Maus und der Tastatur gibt es bei mir nur noch ein Bluetooth-Handy, bei dem ich Bluetooth aber nur zur Synchronisation einschalte.

    Der schlafende Mini ist zwar das angestrebte Ziel, aber wenn es hier keine andere Lösung gibt, bedeutet es: Wen ich den Ruhezustand beenden möchte, muss ich den Ein-/Aus-Schalter am Mac betätigen. Beim letzten Mal wurde die Maus auch nicht gleich gefunden (nach erneutem Einschalten der Maus ging es dann). Ist ja eigentlich nicht Sinn der Sache...
     
  18. konradtönz

    konradtönz Süssreinette (Aargauer Herrenapfel)

    Dabei seit:
    23.07.04
    Beiträge:
    411
    Hallo allerseits.

    Ich hänge mich noch einmal an diesen Thread. Nach einigen Monaten Ruhe in Bezug auf das Ruhezustands-Problem, stehe ich nun wieder vor der gleichen Situation: Wenn ich den Ruhezustand aktiviere, dauert es vielleicht eine Sekunde bis der Mac mini (PPC, 10.4.8) wieder aufwacht.

    Nichts gebracht hat: Kabel der USB-Geräte rausziehen, Deaktivieren der Optionen "Bluetooth-Geräte dürfen Ruhezustand beenden" und "Bei Netzwerk-Zugriffen aufwachen".

    Nachdem einige Monate vergangen sind: Gibt es irgendwelche neuen Erkenntnisse in dieser Sache?

    Ich wünsche Euch einen erholsamen Abend.
     
  19. konradtönz

    konradtönz Süssreinette (Aargauer Herrenapfel)

    Dabei seit:
    23.07.04
    Beiträge:
    411
    Langsam wird es echt anstrengend. Die Dauer des Ruhezustandes ist bei meinem kleinen Freund inzwischen unberechenbar (reicht von einer Sekunde bis zu mehreren Stunden). In jedem Fall wacht er ohne mein Zutun aus jedem Ruhezustand irgendwann auf. Nach einer vorgegebenen Zeit geht er außerdem nie alleine schlafen - ohne einen von mir hervorgerufenen Ruhezustand geht es gar nicht. Heute kam zwischenzeitlich auch noch die Meldung, der Mac müsse über den Ein-/Aus-Schalter neu gestartet werden. Nach dem Neustart fehlte dann die Verbindung zur BT-Maus. Zusammengefasst: Es nervt und ich habe keine Ahnung, wo das Problem ist. Könnte es ein Bluetooth-Problem sein? Was könnte ich in diesem Fall tun? Any ideas?

    Trotz allem einen schönen Abend (zumindest für Euch).

    Edit: Vielleicht eine nützliche Info: Wenn ich über die Bluetooth-Konfiguration versuche, eine Maus zu konfigurieren, erhalte ich die Meldung, dass meine BT-Maus nicht gefunden werden kann (die Maus ist aber eingeschaltet und sie funktioniert).
     
    #19 konradtönz, 28.02.07
    Zuletzt bearbeitet: 28.02.07
  20. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    vielleicht hilfst du uns mal weiter......
    ich habe dir recht ausführlich einige dinge beschrieben.
    du hast dich aber nie darüber geäußerst, ob das jetzt geholfen hat.

    es reicht ja schon, wenn du mein posting zitierst und drunter

    "alles probiert...genau in dieser reihenfolge....nix gebracht"

    reinschreibst. dann kann man beim thread durchlesen wenigstens sehen, wie weit du schon bist.
    wenn du es nicht versuchst, kannst du es ja auch an dieser stelle schreiben.

    das nennt man kernel panic (KP).
    ist so ca. das schlimmste, was dir passieren kann.
    in den meisten fällen auf ein hardware problem zurückzuführen.

    wenn du allerdings cocktail & applejack NICHT rödeln hast lassen,
    tut man sich auch mit diesem hinweis schwer.

    my2cents
    mike
     

Diese Seite empfehlen