1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Latex und die Umlaute

Dieses Thema im Forum "LaTeX" wurde erstellt von Soul Monkey, 06.05.06.

  1. Habe da ein kleineres Problem mit Umlauten. Beim Setzen eines Dokuments mit dem TeXShop ist das setzen mit

    \usepackage[applemac]{inputenc} oder
    \usepackage[latin1]{inputenc} oder
    \usepackage[utf8]{inputenc}

    kein Problem beim Setzen einfach mit der richtigen Codierung speichern und fertig. Allerdings funktioniert das Setzen in TextMate nur mit UTF8, bei den anderen zwei können die Umlaute nicht dargestellt werden außer ich mache die Umlaute über "u. Ein umstellen des File Encoding in TextMate von UTF-8 auf MacRoman oder Latin1 bringt auch nichts.

    Im Editor werden die Umlaut ohne Probleme dargestellt und auch für die Darstellung ist

    \usepackage[T1]{fontenc}

    vorhanden.

    Empfiehlt es sich ohnehin UTF-8 zu verwenden oder gibt es da vielleicht Probleme bei der Weitergabe von Dokumenten?
     
  2. civi

    civi Gast

    Hast du das german-Paket auch geladen?
    Ich kannte nur "u , um ein ü darzustellen.
     
  3. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Das german-Paket braucht man für "echte" Umlaute nicht. Nur inputenc und im Editor beim Speichern die richtige Zeichenkodierung verwenden.

    Ich denke nicht, dass es bei UTF-8 Probleme geben sollte.
     
  4. Ok dann verwende ich halt einfach UTF-8. Danke.

    \usepackage{ngerman} steht schon im Dokument, aber das wird ja nicht das Problem sein.
     
  5. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Handelt es sich da eigentlich um ein TextMate-Problem? Kannst Du eventuell mal testen, ob die anderen Zeichenkodierungen bei latex-Aufruf im Terminal korrekt gesetzt werden?
     
  6. Wenn du mir erklärst wie das geht mache ich das gerne. Im Moment weiß ich aber nicht wo von du sprichst. ;)

    Im TeXShop gehen die anderen Zeichenkodierungen wie gesagt.
     
  7. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Ach so, wenn bei TeXShop eh alle Kodierungen funktionieren, erübrigt sich die Geschichte mit dem Terminal. Falls Du es doch probieren möchtest: Terminal öffnen, dort ins Verzeichnis des LATeX-Dokuments wechseln mit
    Code:
    cd Verzeichnis
    und dann mit
    Code:
    latex Dokument.tex
    setzen (Dateinamen entsprechend anpassen). Oder statt "latex" mit "pdflatex" setzen, falls Du die Ausgabe direkt auf PDF umgestellt hattest. TeXShop und Konsorten sind ja nur Oberflächen für genau derlei Konsolenaufrufe... ;)
     
  8. So habe das jetzt getestet, gesetzt mit pdflatex

    uft8 geht ohne Probleme
    latin1 schreibt zwar auch das PDF aber kann den Umlaut nicht darstellen
    applemac es kommt eine Fehlermeldung

    Code:
    <inserted text> 
                    $
    l.33 Hier Text einf?
                        ?gen!
    
    Im TeXShop geht es aber nach wie vor. :oops:

    Übrigens der gesamte Inhalt des Dokuments.

    Code:
    %Schriftgröße, Layout, Papierformat, Art des Dokumentes
    \documentclass[10pt,oneside,a4paper]{scrartcl}
    
    %Einstellungen der Seitenränder
    \usepackage[left=3cm,right=4cm,top=3cm,bottom=6cm,includeheadfoot]{geometry}
    
    %neue Rechtschreibung
    \usepackage{ngerman}
    
    %Umlaute ermöglichen
    \usepackage[applemac]{inputenc}
    
    \usepackage[T1]{fontenc}
    
    %Kopf- und Fußzeile
    \usepackage{fancyhdr}
    \pagestyle{fancy}
    \fancyhf{}
    
    %Kopfzeile links bzw. innen
    \fancyhead[L]{\nouppercase{\leftmark}}
    %Kopfzeile rechts bzw. außen
    \fancyhead[R]{\today}
    %Linie oben
    \renewcommand{\headrulewidth}{0.5pt}
    
    %Fußzeile mittig
    \fancyfoot[C]{\thepage}
    %Linie unten
    \renewcommand{\footrulewidth}{0.5pt}
    
    \begin{document}
    Hier Text einfügen!
    
    \end{document}
     
  9. Habe den Fehler gefunden. Das Testdokument wurde in TextMate verfasst und halt immer die Codierung geändert und dann im Terminal probiert.

    Dann das Dokument noch mal neu im TeXShop geschrieben und dann im Terminal gesetzt und dann geht es. Also muss es an TextMate liegen, da muss man nämlich nicht nur in den Preferences die Encodierung umstellen sondern scheinbar unter Save As extra unter der Formatierung speichern? Dann geht es jedenfalls auch mit dem TextMate.
     
  10. Duke Leto

    Duke Leto Boskop

    Dabei seit:
    05.05.05
    Beiträge:
    204
    UTF-8 sollte grundsätzlich kein Problem darstellen, es sei denn Du brauchst sehr ausgefallene Zeichen, die teilweise nicht vorgesehen sind.

    Was Dir aber passieren könnte, sind Inkompatibilitäten zu anderen Paketen. Bin mir nicht sicher, mit welchem ich damals Probleme hatte, könnte csquotes gewesen sein.

    Also ich schwöre auf latin1, da hatte ich bisher die wenigsten PRobleme auch auf anderen Computern zu arbeiten ;)

    Beste Grüsse
     
  11. physuck

    physuck Roter Stettiner

    Dabei seit:
    16.01.06
    Beiträge:
    968
    moinsen,

    hab gerade tierische probleme mit texshop.

    alle umlaute werden als promillezeichen ausgegeben!!! trotz \usepackage[applemac]{inputenc}. vorher ging alles nur jetzt zickt hier alles komplett!!

    alles was ich hier jetzt gelesen habe, habe ich auch probiert. kein ergebnis!
    eine schnelle hilfe wäre super!!! zur zeit ist berichtsabgabe und es hängen noch vier in der schleife!!!o_O :eek: :eek:

    der bildanhang zeigt die eingabe und die ausgabe.
     
    #11 physuck, 15.01.07
    Zuletzt bearbeitet: 09.07.07
  12. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Wieso sind im Quellcode bei den Section-Überschriften keine Umlaute, im Text aber schon? Welchen Editor hast Du benutzt? Welche Codierung?
     
  13. davemed

    davemed Braeburn

    Dabei seit:
    18.02.06
    Beiträge:
    46
    Sehe ich das richtig, dass man mit UTF-8 Umlaute als "ö, ü, ä" schreiben kann, ohne den Umweg über "a, "o, "u gehen zu müssen?
    Ich hab derzeit das Problem, dass Umlaute in TeXShop auf der Titelseite nicht umgewandelt werden, im Fließtext funktioniert es. Hat jemand von euch eine Idee woran das liegen könnte?

    Grüße,
    David
     
  14. physuck

    physuck Roter Stettiner

    Dabei seit:
    16.01.06
    Beiträge:
    968
    ich schreibe über den texshop-editor.

    kodiert wird in iso latin 1.

    eben das mit dem quellcode und dem text wundert mich extrem!!

    so sieht der kopf aus:

    \documentclass[12pt,fleqn,a4paper,titlepage ]{article}
    \pagenumbering{arabic}
    \usepackage{ngerman}
    \usepackage[applemac]{inputenc}
    \usepackage[T1]{fontenc}
    \usepackage{amsmath}
    \usepackage{graphicx}
    \usepackage{longtable}
    \usepackage[paper=a4paper,left=30mm,right=20mm,top=30mm,bottom=50mm]{geometry}

    ich ahbe absolut keine ahnung mehr!!
     
  15. physuck

    physuck Roter Stettiner

    Dabei seit:
    16.01.06
    Beiträge:
    968
    habs raus!!! die kodierung war gändert worden als ich damit rumgespielt hatte!!!
    manchmal sieht man den wald vor lauter bäumen nicht! :p
    trotzdem danke!! ;)
     
  16. Wishi

    Wishi Gast

    Ein anderer Tipp wäre gewesen, und das ist die leichteste Lösung, die ich anwende:

    anstatt documentclass article nutzt Du am besten scrartcl. Das ist eine deutsche Version mit Umlauten und allem PiPaPo.
     

Diese Seite empfehlen