1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

LaTeX: Probleme mit "nomencl" unter Texshop

Dieses Thema im Forum "LaTeX" wurde erstellt von schiffi, 04.08.07.

  1. schiffi

    schiffi Allington Pepping

    Dabei seit:
    02.04.06
    Beiträge:
    193
    Hallo liebes Forum,

    so, ich weiß nicht mehr weiter. Hab jetzt das Internet durchforstet und hab alles ausprobiert, aber mein Symbolverzeichnis will einfach nicht erstellt werden. Ich hab das aktuelle nomencl-Paket in das Verzeichnis teTex/share/texmf.tetex kopiert und im Terminal "texhash" ausgeführt.
    ich hab mir auch eine "glossary.engine" -Datei mit folgendem Inhalt erstellt:

    #!/bin/sh

    bfname=$(dirname "$1")/"`basename "$1" .tex`"
    makeindex "$bfname".nlo -s nomencl.ist -o "$bfname".nls

    So, wenn ich jetzt meine tex-datei kompiliere, also zuerst "LaTeX" setzen, dann "glossary", dann bekomme ich folgende Meldung (Siehe Anhang). Und natürlich wird kein Symbolverzeichnis erstellt. In die .nlo-Datei werden auch die Einträge geschrieben, so wie es sein soll.

    Hat irgend jemand eine Idee, woran es liegen könnte. Ich könnte mir vorstellen, dass ich beim Paket einbinden was falsch gemacht habe, aber ich wüsste nicht was. Vielleicht fällt einem von Euch noch was ein.
    Oder muss ich bei Texshop selbst noch was in den Einstellungen ändern, damit das richtig funktionniert?

    Danke schon Mal für die Hilfe

    Gruß

    Patrick
     

    Anhänge:

  2. phueghy

    phueghy Jamba

    Dabei seit:
    25.07.07
    Beiträge:
    56
    Hallo,

    genau auf die Art und Weise funktioniert es bei mir aber. Vermutlich liegt es an den Abkürzungen, die du definiert hast, denn die Ausgabe von makeindex ist ja
    während es bei mir heißt
    Es wäre also hilfreich, zumindest deine \nomenclature-Einträge zu sehen.

    Das hier funktioniert bei mir auf die von dir beschriebene Weise ohne Probleme:
    Code:
    \documentclass[10pt,a4paper]{article}
    \usepackage[utf8]{inputenc}
    \usepackage{nomencl}
    \makenomenclature
    \begin{document}
    Hallo Welt.\nomenclature{Welt}{Worlds evilest littering things}
    \printnomenclature
    \end{document}
    EDIT: ach ja, und natürlich musst du nach Aufruf des Setzens mit Glossary dann nochmal mit Latex setzen, damit das generierte Symbolvereichnis auch angezeigt wird.

    Grüße, phueghy
     
  3. schiffi

    schiffi Allington Pepping

    Dabei seit:
    02.04.06
    Beiträge:
    193
    Also hier mein Test-Dokument.

    Code:
    \documentclass[11pt,a4paper]{scrartcl}
    
    \usepackage{nomencl}
    \makenomenclature
    
    \begin{document}
    
    Testetsttesttets
    
    \nomenclature{Re}{Reynolds-Number}
    \nomenclature{w}{Velocity\nomunit{[$\frac{m}{s}$]}}
    \nomenclature{N}{The number of angels per needle point}% 
    \nomenclature{A}{The area of the needle point}% 
    
    \printnomenclature
    
    \end{document}
    Mit dem insgesamt drei Mal kompilieren mache ich ja, aber irgendwie wills nicht hinhauen. Muss ich eigentlich noch irgendwelche dokumente in meinem Arbeitsverzeichnis haben?
    Hier noch ein Bild von meinem Verzeichnis: Bild 3.png
     
  4. phueghy

    phueghy Jamba

    Dabei seit:
    25.07.07
    Beiträge:
    56
    Hallo,

    der Befehl \nomunit wird (zumindest so wie ich die Doku von nomencl verstehe) nicht automatisch definiert, sondern ist nur ein Vorschlag. Fügst du die Definition aus Abschnitt 5.2 von nomencl.pdf in deine Präambel ein, so funktioniert auch dein Beispieldokument bei mir.

    Das ganze sieht dann so aus:
    Code:
    \documentclass[11pt,a4paper]{scrartcl}
    
    \usepackage{nomencl}
    \makenomenclature
    % folgende Def. aus nomencl.pdf, Sec5.2
    \newcommand{\nomunit}[1]{% 
    \renewcommand{\nomentryend}{\hspace*{\fill}#1}} 
    %
    \begin{document}
    
    Testetsttesttets
    
    \nomenclature{Re}{Reynolds-Number}
    \nomenclature{w}{Velocity\nomunit{[$\frac{m}{s}$]}}
    \nomenclature{N}{The number of angels per needle point}% 
    \nomenclature{A}{The area of the needle point}% 
    
    \printnomenclature
    
    \end{document}
    Du brauchst eigentlich keine anderen Dokumente oder Dateien in deinem Tex-Verzeichnis (ausser Bilder, Literatur-DB, \include-te .tex Dateien und und und :)), die für das Symbolverzeichnis benötigten Dateien erzeugt sich der Latex-Compiler/makeindex schon selbst.

    Solange nomencl.sty und nomencl.ist gefunden werden (und das werden sie offenbar bei dir, sonst würde es Fehlermeldungen geben), sollte alles funktionieren.
    Grüße, phueghy
     
  5. schiffi

    schiffi Allington Pepping

    Dabei seit:
    02.04.06
    Beiträge:
    193
    Also hier ist das Ergebis des ersten Durchlaufs. Vielleicht kann man da ja einen Fehler erkennen.

    Code:
    This is pdfeTeX, Version 3.141592-1.30.4-2.2 (Web2C 7.5.5)
     \write18 enabled.
    entering extended mode
    (./Test.tex
    LaTeX2e <2005/12/01>
    Babel <v3.8d> and hyphenation patterns for american, french, german, ngerman, b
    ahasa, basque, bulgarian, catalan, croatian, czech, danish, dutch, esperanto, e
    stonian, finnish, greek, icelandic, irish, italian, latin, magyar, norsk, polis
    h, portuges, romanian, russian, serbian, slovak, slovene, spanish, swedish, tur
    kish, ukrainian, nohyphenation, loaded.
    (/usr/local/teTeX/share/texmf.local/tex/latex/base/article.cls
    Document Class: article 2005/09/16 v1.4f Standard LaTeX document class
    (/usr/local/teTeX/share/texmf.local/tex/latex/base/size11.clo))
    (/Users/patrick/Library/texmf/tex/latex/nomencl/nomencl.sty)
    Writing nomenclature file Test.nlo
    (./Test.aux)
    No file Test.nls.
    [1{/usr/local/teTeX/share/texmf.local/fonts/map/pdftex/updmap/pdftex.map}]
    (./Test.aux) )</usr/local/teTeX/share/texmf.tetex/fonts/type1/bluesky/cm/cmr10.
    pfb>
    Output written on Test.pdf (1 page, 4812 bytes).
    Transcript written on Test.log.
    
    Also kompilieren tu ich schon richtig. Hab grad nochmal das ganze Mactex-Paket neu installiert und nomencl noch einmal runtergeladen und eigentlich alles richtig gemacht. Ich versteh das nicht mehr. Ich hab ja auch schon viel mit Latex geschrieben, aber unter Mac noch nie mit Symbolverzeichnis.

    Na Danke schon Mal für deine bisherige Hilfe und für hoffentlich noch weitere.

    Gruß

    Patrick
     
  6. phueghy

    phueghy Jamba

    Dabei seit:
    25.07.07
    Beiträge:
    56
    Hallo,

    hast du dafür jetzt meine Beispiel-Datei genommen? Und nach dem MakeIndex und nochmaligem Latex-Lauf geht es immer noch nicht?

    Dein Log zeigt jedenfalls keine Fehlermeldung. Zeig doch nochmal die Ausgabe vom Makeindex-Lauf (also dem Übersetzen mit der Glossary-Option) und evtl. dann das Log des 2. Latex.Laufs.

    EDIT: ach ja, und lösche vorher mal alle von Latex erstellten Hilfsdateien, damit du einen klar definierten Ausgangspunkt hast (also .aux, .log, .nls, .nlo, .ilg).

    Grüße, phueghy
     
  7. schiffi

    schiffi Allington Pepping

    Dabei seit:
    02.04.06
    Beiträge:
    193
    Hallo phueghy,

    so, also ich hab jetzt dein erstes Beispiel genommen, alle Dateien im Ordner außer der .tex-Datei gelöscht und 3 mal kompiliert. Erst Latex, dann Glossary, dann nochmal Latex.
    Hier sind die drei Log-Einträge:

    Durchlauf1.png Durchlauf2.png Durchlauf3.png


    Also ich seh auch keinen Fehler.....

    So langsam bin ich ratlos...

    Danke und Gruß

    Patrick
     
  8. schiffi

    schiffi Allington Pepping

    Dabei seit:
    02.04.06
    Beiträge:
    193
    Lösung gefunden

    Hallo noch einmal,

    ich glaub, die Lösung gefunden zu haben. Zumindest klappt es jetzt mit den Symbolverzeichnis.
    Ich hab mir mal alle von Latex erstellten Dateien angesehen. Und da ist mir die test.nlg aufgefallen. Dort steht was von "input style error", also das in der nomencl.ist-Datei irgendwas nicht stimmt.
    test-nlg.png
    Also hab ich da nachgeschaut und unter der "for input"-Zeile stand was von wegen "Germans might want to change this and delete the two %%".
    Bild 1.png
    Das hab ich gemacht in der folgenden Zeile, also die %% vor dem "quote", und schon hats geklappt. Warum genau das so ist, weiß ich aber auch nicht. Hat da viellicht jemand ne Ahnung. Oder war ich einfach nur zu doof, das Paket richtig einzubinden?o_O

    Naja, danke bsonders an phueghy für die Hilfe

    Gruß

    Patrick
     
  9. phueghy

    phueghy Jamba

    Dabei seit:
    25.07.07
    Beiträge:
    56
    Hallo,

    hm das ist schon komisch. Bei mir wird zwar auch eine Datei test.ilg erzeugt mit diesem Inhalt, aber trotzdem funktioniert es.

    Setze doch mal in die erste Zeile deines Dokumentes den Befehl \listfiles und poste dann die Versionsnummer von nomencl.sty, die beim Latex-Lauf im Log-File ausgegeben wird.

    Bei mir sieht das so aus:
    Code:
     *File List*
    scrartcl.cls    2006/07/30 v2.95b KOMA-Script document class (article)
    scrkbase.sty    2006/07/30 v2.95b KOMA-Script package (basics and keyval use)
    scrlfile.sty    2006/03/28 v2.95 KOMA-Script package (loading files)
      keyval.sty    1999/03/16 v1.13 key=value parser (DPC)
      size11.clo    2005/09/16 v1.4f Standard LaTeX file (size option)
    typearea.sty    2006/07/30 v2.95b KOMA-Script package (type area)
     nomencl.sty    2005/09/22 v4.2 Nomenclature package (LN)
    
    Vielleicht hast du (oder ich? ;)) ja eine veraltete Version von nomencl.

    Nicht dass du mit der Änderung in der .ist Datei jetzt wieder an anderer Stelle Probleme bekommst. :)

    Grüße, phueghy
     
  10. schiffi

    schiffi Allington Pepping

    Dabei seit:
    02.04.06
    Beiträge:
    193
    Jo, hab das gleiche Paket wie du.
    Is schon irgendwie komisch. Liegt es vielleicht an einer einem Problem mit irgendeinem Sprachformat oder so? Kenn mich in solchen Dingen nich so aus, aber in der nomencl.ist-Datei steht ja, dass man es ändern kann.

    Naja, erst mal klappt es

    Gruß

    Patrick
     
  11. aXon

    aXon Gast

    kompatibilitätsproblem

    Hallo,

    ich bin auf deinen Beitrag durch google aufmerksam geworden, und habe dabei auch einen anderen älteren beitrag aus dem macuser forum gefunden (http://www.macuser.de/forum/archive/index.php/t-221449.html), der besagte, dass die nomencl die bei mactex dabei ist, veraltet ist/sein kann.

    genau dein problem hatte ich auch, bis ich vor ein paar minuten das nomencl von ctan.org gezogen habe und danach installiert habe. danach lief alles wie es sollte :)

    ich hoffe, dass es danach auch bei dir funktioniert
     
  12. Cyrics

    Cyrics Neuer Berner Rosenapfel

    Dabei seit:
    01.04.05
    Beiträge:
    1.975
    Ich hatte keine Kompatibilitätsprobleme.
    Der Ablauf muss nur Folgender sein:
    1. Erstmal die wichtigen Zeilen in die betreffende Latex-Datei eintragen:
      \usepackage{nomencl}
      \makenomenclature

      \nomenclature{Bla}{Neumodische Erscheinung für nicht wichtig}
      \printnomenclature
    2. Das Ganze setzen
    3. Im Terminal dann eingeben: makeindex hauptdatei.nlo -s nomencl.ist -o hauptdatei.nls
    4. Das Ganze setzen
    5. sich freuen nun ein Verzeichnis namens Nomenclature zu haben
    6. Änderungen herbeiführen mit nachfolgendem

    \usepackage[german]{nomencl} # für deutsche Entsprechung (Symbolverzeichnis)
    \renewcommand{\nomname}{Glossar} # Oder Um es zum Beispiel Glossar zu nennen
    \setlength{\nomlabelwidth}{.50\hsize} # Für die Seitliche Begrenzung der Nomenclature auf 50% der Seiten-Breite
    \renewcommand{\nomlabel}[1]{#1 \dotfill} # Um die Lücke mit Punkten zu füllen
    \setlength{\nomitemsep}{\parsep} # Um noch etwas Abstand zwischen den Einträgen zu bekommen
     
  13. entry

    entry Erdapfel

    Dabei seit:
    22.09.08
    Beiträge:
    2
    Hi,

    ich habe genau das gleiche Problem. Habe Mactex installiert und benutze Lyx zum schreiben meiner Arbeit. Ich bekomme mit dem test code genau die beschriebenen Ausgaben(getestet mit TeXShop). Kannst du genauer erklären wie du die nomencl installiert hast? Oder gibt es eine andere Lösung für das Problem?
     
  14. entry

    entry Erdapfel

    Dabei seit:
    22.09.08
    Beiträge:
    2
    Ich habe rausgefunden das es wohl am MacTex Installation liegt. Nachdem ich mittels i-Installer Latex installiert habe lief alles.
     

Diese Seite empfehlen