1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

iphoto bilder sind leer bzw. weg

Dieses Thema im Forum "Fotosoftware" wurde erstellt von atomme, 02.10.07.

  1. atomme

    atomme Idared

    Dabei seit:
    25.10.06
    Beiträge:
    28
    hi leute.
    es gibt ein problem.
    mein iphoto spinnt.
    Es werden nur noch leere Bildrahmen angezeigt. Beim Doppelklick auf ein Bild wird dieses auch nur grau(leer) angezeigt.
    Die Ordnerstruktur in iphoto und die Bildnamen sind aber noch vorhanden.
    Selbst die Bildinfo (Belichtungszeit etc.) sind noch abrufbar.
    Bei "Datei anzeigen"- also im Finder anzeigen passiert aber nichts.
    iphoto hat wahrscheinlich sämtliche Pfade zu den Bildern verloren.
    Mit FP Dienstprogramm die Rechte zu reparieren habsch auch schon gemacht.

    auf der FP - also im iphotlibary ordner ist noch alles vorhanden.
    an der Festplattenstruktur habe ich nix geändert. weder ordner verschoben noch neue benutzer angemeldet. Habe den iphoto-ordner schon ewig auf ner exterenen FP. hatte diese nur neulich mal abgeklemmt. dürfte doch aber kein problem da sein.


    gibts denn nicht die möglichkeit, die libary zu atualisieren?
    alle bilder per hand neu in iphoto zu importieren mag ich eigentlich nich machen, da dann alles neu sortiert werden muss und die Wertungspunkte etc verloren gehen?

    danke für die vorschlägsels
    tom.
     
  2. domeru

    domeru Jamba

    Dabei seit:
    05.07.06
    Beiträge:
    55
    Hatte das in iPhoto noch nicht, jedoch schon des öfteren in Aperture. Löschen der .plist und Neustart des Programms hilft da immer. Versuche also mal die com.apple.iPhoto.plist zu löschen. Keine Angst, passiert schon nichts.

    domeru
     
  3. atomme

    atomme Idared

    Dabei seit:
    25.10.06
    Beiträge:
    28
    com.apple.iPhoto.plist löschen bringt nix

    ...danke...
    hat aber nicht geholfen die com.apple.iPhoto.plist datei zu löschen.
    er startet iphoto und zaeigt dann totale leere an.
    wo iphoto vorher wenigstens noch ordner und leere bildrahmen angezeigt hat.
    habe alte com.apple.iPhoto.plist datei also wieder hergestellt.
     
  4. gbyte

    gbyte Gelbe Schleswiger Reinette

    Dabei seit:
    07.04.07
    Beiträge:
    1.750
    Hast Du eventuell in die Ordnerstruktur von iPhoto manuell eingegriffen? Das leere Rahmen angezeigt werden, ist ein Zeichen dafür, dass die Thumbnails im Ordner ~User/Pictures/iPhoto Library/Data entweder umbenannt, oder entfernt worden. Das beim Doubleclick auf ein Bild, dieses nicht mehr angezeigt wird, lässt vermuten, dass entweder der Ordner ~User/Pictures/iPhoto Library/Originals und/oder der Ordner ~User/Pictures/iPhoto Library/Modified modifiziert, bzw. verschoben/gelöscht wurden.

    Schau doch mal in Deiner Ordnerstruktur nach, ob die Bilder wirklich noch vorhanden sind. Solltest Du das neue iLife-Paket besitzen, so handelt es sich nicht um einen Ordner; hier kannst Du die Bibliothek mit einem Rechtsklick auf's Library-Icon und anschließendem auswählen von "Paketinhalt zeigen" öffnen.

    Gruß,

    GByte
     
  5. atomme

    atomme Idared

    Dabei seit:
    25.10.06
    Beiträge:
    28
    ja es sind alle bilder noch brav im iphoto libary ordner.
    sowie vorher auch. die ordnerstruktur hab ich nicht geändert.
    die FP auch nicht umbenannt oder so. ich hatte sie wie gesagt nur mal
    einzeln mitgenommen um bilder zu präsentieren. dabei ging der laptop akku alle.
    jetzt hängt die besagte exteren FP mit der iphoto libary wieder schön in der firewire kette.
    und iphoto kann nix mehr zuordnen.
    ich besitze noch nicht da neue ilife paket.
    das muss man doch kaufen oder?
    hab bis jetzt nur auf iphoto 606 geupdated.
    :::::::::::::
     
    #5 atomme, 02.10.07
    Zuletzt bearbeitet: 02.10.07
  6. gbyte

    gbyte Gelbe Schleswiger Reinette

    Dabei seit:
    07.04.07
    Beiträge:
    1.750
    Hattest Du iPhoto mal gestartet ohne das die externe Festplatte angeschlossen, bzw. gemounted war? Normalerweise sollte iPhoto die Daten nicht verlieren. Was Du aber mal probieren kannst ist:

    • iPhoto beenden und dann mit gedrückter ?-Taste neustarten. Das Programm wird Dich fragen, was Du machen möchtest, wähle einfach Dein Fotoarchiv von der externen Festplatte aus.
    oder
    • Die externe Platte ausbinden, bzw entfernen und danach alle Bilder in iPhoto entfernen; den Papierkorb nicht vergessen. Danach die Platte wieder anschließen und die Bilder neu importieren.
    Das stimmt, das neue iLife muss käuflich erworben werden. Es ging nur darum, weil sich in der neuen iLife-Version die Art der Ordnerstruktur geändert hat.

    Gruß,

    GByte

    [EDIT] Da fällt mir noch ein; ist die iPhoto-Bibliothek komplett auf der externen Platte? Oder anders formuliert, was hast Du in den iPhoto-Einstellungen bei Erweitert -> Importieren angehakt, bzw. nicht angehakt? [/EDIT]
     
  7. atomme

    atomme Idared

    Dabei seit:
    25.10.06
    Beiträge:
    28
    ja danke,
    hab ich grad probiert mit der alt taste zu starten.
    ich verweise ihn also an den bestehenden iphoto ordner.
    danach legt er den Minuatur-Cache neu an. Das macht er aber auch, wenn ich iphoto ganz normal starte. das dauert so knapp 10 sek. (bei immerhin 11GB Fotos?!).
    das er jedesmal den miniatur cache neu anlegen muss, hat er früher auch nicht gemacht!.

    letztenendes sehe ich aber immernoch keine bilder sondern nur leere rahmen.

    danke nochma!
     
  8. gbyte

    gbyte Gelbe Schleswiger Reinette

    Dabei seit:
    07.04.07
    Beiträge:
    1.750
    Nochmal die Frage bezüglich der Art wie iPhoto Deine Bilder verwaltet. Ist die Library komplett auf der externen Platte, oder ist sie auf dem Mac und nur die Daten liegen auf der Externen?

    Gruß,

    GByte
     
  9. atomme

    atomme Idared

    Dabei seit:
    25.10.06
    Beiträge:
    28
    also ich denke alles liegt auf der externen.
    screenshot anbei.
    wie heisst denn die libary?
    sorry.
    /Users/tomkretschmer/Temp/Bildschirmfotos/Bild 78.jpg
     
  10. gbyte

    gbyte Gelbe Schleswiger Reinette

    Dabei seit:
    07.04.07
    Beiträge:
    1.750
    Du kannst auch mal folgende Dateien löschen:

    • ThumbJPGSegment.data
    • Thumb64Segment.data
    • Thumb32Segment.data

    nach einem Neustart von iPhoto werden diese dann neu angelegt.

    Gruß,

    GByte

    [EDIT]
    Was hast Du in den iPhoto-Einstellungen bei Erweitert -> Importieren angehakt, bzw. nicht angehakt?

    Die Library liegt entweder in /Users/tomkretschmer/Bilder/ und heißt iPhoto Library oder sie liegt auf Deiner externen Platte und heißt dann /Volumes/"Deine Platte"/iPhoto Library.
    [/EDIT]
     
  11. atomme

    atomme Idared

    Dabei seit:
    25.10.06
    Beiträge:
    28
    in iphoto unter erweitert aktiviert ist :
    "beim hinzufügen...in die iphotolibary kopieren" und "colorsync hinzu"


    wie kann ich hier denn bilder (screenshots von der iphoto libary) reinsetzen
    über grafik einsetzen funtzt nicht.
     
  12. gbyte

    gbyte Gelbe Schleswiger Reinette

    Dabei seit:
    07.04.07
    Beiträge:
    1.750
    Bilder müssen erst hochgeladen werden, einfach in das Fenster ziehen funktioniert leider nicht. Du musst dazu auf "Anhänge verwalten" gehen, etwas weiter unten hier im Browserfenster (wenn Du einen Beitrag verfasst natürlich).

    Gruß,

    GByte
     
  13. atomme

    atomme Idared

    Dabei seit:
    25.10.06
    Beiträge:
    28
    ich sehe ich habe zwei libarys
    eine auf meiner systemplatte
    und eine auf der externen, wo ich auch die ganzen iphoto bilder verwalten lasse.
    letztere "Library6.iPhoto" ist auch recht groß (34 MB)
    soll ich den ordner auf der systemplatte einfach löschen?
    es kann sein, dass er diesen ja angelegt hat als ich den rechner ohne die Bilder-Platte hochgefahren habe.
    danke.
     

    Anhänge:

  14. atomme

    atomme Idared

    Dabei seit:
    25.10.06
    Beiträge:
    28
    Yippi

    ey danke.
    also, ich habe die zweite iphoto libary gelöscht (die kleine auf der systemplatte)
    und dann iphoto mit alt neu hochgefahren und auf die exterene FP verwiesen
    und jetzt hat er wieder alle daten und vorschaubilder.
    YEAH!!!!

    heisst das ich darf iphoto nie ohne meine externe fotoplatte hochfahren.
    kann man nicht auch Bibliotheken zusammenführen wie in itunes?


    und noch was. wenn ich nun mal ne fette datensammlung an bildern habe
    und ich will mal was am lappi präsentieren und nicht jedesmal die externe platte mitschleppen,
    kann man da nicht den jeweiligen ordner den ich präsentieren will auf die interne platte kopieren
    (innerhalb iphoto)????
    versteht ihr.?!?!?!?

    oder sollte ich dochmal zu aperture wechseln?!
    danke vielemals gbyte
     
  15. gbyte

    gbyte Gelbe Schleswiger Reinette

    Dabei seit:
    07.04.07
    Beiträge:
    1.750
    Nichts zu danken, freut mich das Du zu dem Ergebnis gekommen bist, welches Du wolltest.

    Was iPhoto und Deine Wünsche angeht, so ist dieses Programm nicht grad die beste Lösung. Du kannst natürlich verschiedene Libraries anlegen und dann bei jedem Start von iPhoto dir die passende raussuchen, aber die perfekte Lösung ist das auch nicht.

    Was ich Dir für ein solches Vorhaben empfehlen kann, ist Adobe Photoshop Lightroom. Dieses Programm ist eine Verwaltungsrakete und bietet ungeahnte Möglichkeiten in der Online/Offline Bildverwaltung, bzw. Bilderansicht. Außerdem ist Lightroom etwas günstiger als Aperture.

    Ich fahr bestens mit diesem Programm und möchte es nicht mehr missen. Aber generell ist es auch mit iPhoto zu bewerkstelligen, es können nur eben schneller Probleme auftauchen.

    Gruß,

    GByte
     
  16. atomme

    atomme Idared

    Dabei seit:
    25.10.06
    Beiträge:
    28
    und was ist mit adobe bridge.
    damit kann man doch auch gut verwalten.
    und der vorteil ist das die ordner genauso sind wie auf der FP.

    was mich bei iphoto noch stört ist:
    wenn ich ein bild aus iphoto in photoshop ziehe bearbeite und speichere ist es noch lange nicht in iphoto aktualisiert, geschweige denn ich lege ne kopie von diesem bild an und möchte es automatisch in iphoto importiert wird....???

    das heisst ich habe immer zwei hauptordner, eines mit den origianlfotos von iphoto verwaltet und dann nochmal nen anderen ordner den ich von hand verwalte und in den ich meine bearbeiteten bilder speichere. das ist aber eigentlich auch recht unsinnig.
     
  17. gbyte

    gbyte Gelbe Schleswiger Reinette

    Dabei seit:
    07.04.07
    Beiträge:
    1.750
    Bridge und Lightroom sind Programme, welche stark vom Geschmak des Users abhängen. Wie gesagt, meine objektive Meinung, ist Lightroom genau das, was für meine Bedürfnisse gaschaffen ist.
    Als Beispiel, man kann aus Lightroom herraus die Bilder mit Photoshop bearbeiten und es aktualisiert. Die Ordnerstruktur in Lightroom ist identisch mit der Platte; man kann Verzeichnisse auch synchronisieren, oder auch Überwachte Ordnerstrukturen anlegen. Außerdem benötigt man nicht immer die Originaldateien. Wenn Du mit Deinem Laptop außer Haus bist, die Daten aber auf der FW-Platte zu Hause sind, kannst du trotzdem noch Deine Bilder ansehen und bearbeiten, da Änderungen nie an den Daten, sondern in entsprechenen Einstellungsdateien gespeichert werden. Somit kannst Du auch jede Änderung wieder Rückgängig machen.

    Och, da gibt es so viel drüber zu schreiben, wird aber auch zur genüge im Internet publik gemacht. Da ich eher der Fotografie, als der überdimensionierten Bildbearbeitung nahe komme, reicht fast immer Lightroom. Nur in seltenen Fällen nutze ich Photoshop und/oder GIMP.

    Gruß,

    GByte
     
  18. StefanK

    StefanK Grahams Jubiläumsapfel

    Dabei seit:
    16.03.05
    Beiträge:
    106
    Ich habe heute dasselbe Problem gehabt: iPhoto (Version 6, unter Tiger) hat keine Bilder mehr angezeigt, nur die gestrichelten Rahmen. Alle Strukturen wie Filme, Schlüsselwörter, Bewertungen, Alben etc. waren noch vorhanden. Anlegen des Miniatur-Caches oder Löschen der Thumbnail-Dateien und Starten mit Wiederherstellungs-Funktion hat nichts gebracht.

    Die Ursache: Ein Wackelkontakt in der Verbindung zu der externen Platte, auf der mein Foto-Archiv liegt. Irgendwann kam eine Meldung, dass ich externe Geräte nur mit Abmelden trennen darf... die Platte war aber trotzdem sichtbar, exakt wie vorher(!).

    In der PList-Datei von iPhoto habe ich dann festgestellt, dass der Pfad zu den Bilddateien (RootDirectory) nicht stimmte, denn er zeigte auf die lokale Platte -- das war ganz falsch.
    Ich habe ihn dann auf /Volumes/Archiv/Medien/Foto-Archiv/Hauptsammlung gestellt -- das ist der Pfad zu meiner iPhoto-Library. Als es dann immer noch eine Fehlermeldung gab, wurde ich stutzig, und die Überprüfung im Terminal brachte zutage, dass der tatsächliche Pfad /Volumes/Archiv 1/Medien/Foto-Archiv/Hauptsammlung hieß.

    Ich vermute, dass durch den Wackelkontakt die Platte neu gemountet wurde. Da der alte Mountpoint /Volumes/Archiv aber noch nicht freigegeben war, wurde in Mac-Manier eine Zweit-Datei /Volumes/Archiv 1 angelegt. Auswerfen und Neuanmelden der Platte hat diese aber immer wieder unter dem Zweit-Pfad angemeldet. Auf dem Desktop und im Finder war die Platte immer unter ihrem richtigen Namen "Archiv" sichtbar, ohne „1“.

    Im ersten Pfad hatte iPhoto inzwischen sogar seine Meta-Dateien angelegt -- die hätten dort niemals etwas zu suchen gehabt, denn ein Mountpoint ist ein leeres Verzeichnis
    .
    Also habe ich das vermurkste Verzeichnis /Volumes/Archiv gelöscht und die Platte neu angemeldet, woraufhin sie wieder wunschgemäß unter /Volumes/Archiv (ohne „1“) erscheint.
    Und iPhoto findet seine Fotos wieder. Momentan sagt er, dass er noch 18 Stunden zum Geradebürsten der Sammlung braucht... :)
     
  19. franzka

    franzka Becks Apfel (Emstaler Champagner)

    Dabei seit:
    17.04.05
    Beiträge:
    339
    Hallo,

    ich verwalte seit 2 Jahre die Fotos meiner Elter in iPhoto. Jetzt möchte mein Dad sie endlich mal einige entwickeln lassen und wir wollte gerade ein paar raussuchen, aber die Fotos, die älter als ein Jahr sind werden nicht mehr angezeigt und ich frag mich warum o_O. Im Fotoarchiv sind noch alle da, aber sobald ich sie vergößern möchte, erscheint nur ein graues Rad, so als müsste etwas berechnet oder so werden, jedoch dauert dies jetz schon länger als 20 min an. Und kein Foto erscheint.
    Wenn ich auf Information des Bildes klicke, steht noch alles da. Ich hab an iPhoto nix verändert, da ich sowas eigentlich verhindern wollte, dass es je passiert. Was leider nicht funktioniert hat.

    Die alten Fotos habe ich auch noch auf meiner Festplatte, aber nur reinkopiert, als Sichheit. Kann es sein, dass ich durch diesen Weg nur noch die Fotos mithilfen der FP angucken kann? Oder was ist hier falsch. Ich hoffe ihr könnt mir da weiter helfen.

    Danke, Franzi
     
  20. Delar

    Delar Gloster

    Dabei seit:
    07.10.05
    Beiträge:
    63
    Danke für diesen Threat!

    Hatte genau das selbe Problem mit meinem alten iPhoto 5. Bei mir ging dann die Zuordnung beim Start mit gedrückter alt-Taste wieder. Zu meinem Ausfall kam es, da meine Library auf d. externen-FP Stromausfall hatte.
    Wenn ich dieses Forum nicht hätte ;)
     

Diese Seite empfehlen