1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Installer ohne Icon

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Kernelpanik, 15.10.05.

  1. Kernelpanik

    Kernelpanik Ingol

    Dabei seit:
    05.03.04
    Beiträge:
    2.098
    Mein installer hat das Icon verloren, das heisst es zeigt nur das generic icon. Die .pkg files muss ich immer von Hand dem installer zuweisen, über öffnen mit. Gibts da Abhilfe?
     
  2. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.897
    Das übliche Programm ... plus "LaunchServices Datenbank" neu anlegen.
     
  3. Kernelpanik

    Kernelpanik Ingol

    Dabei seit:
    05.03.04
    Beiträge:
    2.098
    Könntes Du das ein wenig präziser formulieren. Ich hab mal die LaunchServices prefs gelöscht ohne Erfolg. Installer zeigt immernoch generic icon. Wenn ich ein .pkg file über die Info dem Installer zuweise heisst es: Sie können nicht... Das File ist defekt...
     
  4. Kernelpanik

    Kernelpanik Ingol

    Dabei seit:
    05.03.04
    Beiträge:
    2.098
    Merkwürdigerweise ist es nur bei einem User so beim Admin nich.
     
  5. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.897
    Probier mal (von diesem Benutzer aus) die Radikalkur:
    (nur der Lesbarkeit halber als Mehrzeiler...)

    1) Sämtliche Programme beenden, nur Terminal öffnen.
    Andere Nutzer sollten grundsätzlich auch nicht angemeldet sein.
    2) Alle Finderfenster schliessen (noch besser: beenden).
    3) Terminal:

    cd /System/Library/Frameworks/
    cd ApplicationServices.framework/Frameworks/
    cd LaunchServices.framework/Support/
    ./lsregister -kill -R /

    Das wird etwas dauern und baut die LS-DB komplett neu und sauber auf.
    Anschliessend *sofort* abmelden.
    Dann sollte wieder alles funzen.
     
    Kernelpanik gefällt das.

Diese Seite empfehlen