1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

if-Anweisungen in Excel?

Dieses Thema im Forum "Office:Mac" wurde erstellt von zoom, 19.09.06.

  1. zoom

    zoom Antonowka

    Dabei seit:
    06.03.06
    Beiträge:
    356
    Hallo!

    Ich würde in Excel gerne so etwas wie eine if-Anweisung nutzen. Soll heißen: der Wert x soll überprüft werden. Wenn x > 5, dann soll x um 0,5 vermindert werden. Wenn x > 10, dann soll x um 1 vermindert werden.
    Kann man so etwas in Excel realisieren?
     
  2. svewie

    svewie Jamba

    Dabei seit:
    22.11.05
    Beiträge:
    56
    Probiere es mal damit:

    In Zelle A1 steht der Wert "x"

    =WENN(A1>5;A1-0,5;WENN(A1>10;A1-1))

    (oder so ähnlich)

    Klappt das?

    Gruß,
    Sven.
     
  3. zoom

    zoom Antonowka

    Dabei seit:
    06.03.06
    Beiträge:
    356
    Hm, als Ergebnis liefert er mir dann 0? Das kann nicht sein.
     
  4. zoom

    zoom Antonowka

    Dabei seit:
    06.03.06
    Beiträge:
    356
    Ach ne, ich habe ein falsches Feld angegeben. Es funktioniert bedingt. Bei x > 10 liefert er mir nur x-0,5. Irgendwie muss das zweite WENN anders verbaut werden?
     
  5. zoom

    zoom Antonowka

    Dabei seit:
    06.03.06
    Beiträge:
    356
    Ich habe den Fehler gefunden. Logisch: Mann muss natürlich mit >10 anfangen. Denn die Anweisung >5 verschlingt ja schon das >10.
    Also: =WENN(A1>10;A1-1;WENN(A1>5;A1-0,5;A1))

    Trotzdem vielen Dank an svewie! Jetzt habe ich das System durchschaut ;)
     
  6. svewie

    svewie Jamba

    Dabei seit:
    22.11.05
    Beiträge:
    56
    Und damit?
    =WENN(A1>10;A1-1;WENN(A1>5;A1-0,5;A1))

    Gruß,
    Sven.
     
  7. svewie

    svewie Jamba

    Dabei seit:
    22.11.05
    Beiträge:
    56
    Zwei Doofe... ;)

    Mann kann die Anweisungen auch in einem Formular bearbeiten, wenn man oben in der Symbolleiste auf das "=" klickt.

    Viel Erfolg!

    Gruß,
    Sven.
     

Diese Seite empfehlen