1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

HP Laserjet 5L über WLAN-Router/ LPD ansprechen

Dieses Thema im Forum "WLAN, Airport & TimeCapsule" wurde erstellt von Rookie79, 25.01.06.

  1. Rookie79

    Rookie79 Tokyo Rose

    Dabei seit:
    08.11.05
    Beiträge:
    68
    Hallo zusammen,

    Ich werde echt noch wahnsinnig mit der Druckerionstallation.
    Vielleicht kann mir ja jemand helfen, ich weiss keinen Rat mehr.

    Ich möchte meinen alten HP Laserjet 5L über den WLAN Router (T-Sinus 130 DSL)
    benutzen.
    Der Drucker hängt am Router, mit der XP Professional Dose klappt es als TCP/IP Drucker mit LPR ohne Probleme.
    Auf dem Powerbook leider nicht :(

    Den grössten Erfolg habe ich erzielt indem ich ihn als IP Drucker mit dem Protokoll Line Printer Daemon (LPD) eingerichtet habe.
    IP Adresse des Routers eingegeben und als Warteschliste LPT1, das braucht der Router offenbar laut Anleitung.

    Egal ob ich ihn nun als Postscript Drucker oder als Laserjet5 per CUPS und Gutemprint betreibe, er fängt auf den ersten Seiten an wirre Zeichen und wirre Programm - Code Zeilen zu drucken, ab der dritten Seite zieht er die Blätter einfach nur leer durch.
    Dabei wollte ich einfach nur ein 2seitiges Word Dokument drucken!

    Auch ein Abbruch des Druckauftrages bringt nichts, ich muss dem Drucker das Papier nehmen und ein aus- und wieder einschalten, dann hört er auf.

    In der Drucker- Auftragsliste steht "Spooling LPR Job" und die Prozent Anzeige geht in maximal 5% Schritten unendlich langsam nach oben.

    Woran kann das liegen bzw. was mache ich da falsch?
    Alle anderen einstellungen führen zu keinerlei Ergebnis, die Druckaufträge werden vorzeitig mit Fehlermeldungen oder "Host is busy..." Meldungen abgebrochen.

    Für eine Hilfestellung wäre ich echt unendlich dankbar, das ganze wurmt mich tierisch!
    Alle anderen Einstellungen am neuen Powerbook waren kinderleicht aber das hier krieg ich nicht gebacken.
     
  2. MrFX

    MrFX Zehendlieber

    Dabei seit:
    01.09.05
    Beiträge:
    4.129
    Moin!

    lpd://IP_DES_ROUTERS/LPT1 ist korrekt, anscheinend kommt aber statt der Druckdaten PostScript aus'm Mac raus... daher auch die Codezeilen.

    Pobier mal als Treiber HPIJS:

    http://linuxprinting.org/macosx/hpijs/

    HPIJS UND Ghostscript installieren... dann als Druckermodell HP LaserJet 5L Foomatic/hpijs auswählen.

    MfG
    MrFX
     
  3. Rookie79

    Rookie79 Tokyo Rose

    Dabei seit:
    08.11.05
    Beiträge:
    68
    Halleluja, es geht :D

    Ich bin begeistert, er druckt :D

    Herzlichen Dank @MrFX...!!

    Ich bin zunehmend begeistert von diesem Forum!
     
  4. iDaniel

    iDaniel Bismarckapfel

    Dabei seit:
    08.11.04
    Beiträge:
    141
    Hallo,

    ich habe leider das gleiche Problem. Ich habe meinen HP Deskjet 5150 an meinen Router angeschlossen und als Protokoll LPD eingestellt. Dann die ip Adresse des Routers (192.168.2.1) und die Warteschleife (lpd://192.168.2.1/LPT1) ausgefüllt. Die Treiber von MrFX habe ich mir auch schon runtergeladen, aber wenn ich dann etwas drucken will, wird der Vorgang immer automatisch gestoppt, egal ob ich als Druckertyp diesen Post Script Drucker oder meinen Deskjet 5150 als der Liste gewählt habe. Immer wird der Druckvorgang abgebrochen.


    Was mache ich falsch?

    Gruß
    iDaniel
     
  5. iDaniel

    iDaniel Bismarckapfel

    Dabei seit:
    08.11.04
    Beiträge:
    141
    ach ja: Wenn ich nur LPT1 eingebe, hat mein Drucker die gleichen Symphtome wie bei Rookie79.
     
  6. MrFX

    MrFX Zehendlieber

    Dabei seit:
    01.09.05
    Beiträge:
    4.129
    Moin!

    Was für ein Router und welche Symptome?

    MfG
    MrFX
     
  7. iDaniel

    iDaniel Bismarckapfel

    Dabei seit:
    08.11.04
    Beiträge:
    141
    Es ist ein T- Sinus 154 DSL Router. Wenn ich den Drucker an den freien USP-Port am Router anschliesse und bei der Druckerkonfiguration in der Warteliste LPT1 eingebe, fängt er auch an, komische Codzeilen zu drucken und zieht dann nur noch leere Blätter durch.

    Bei Rookie79 wurde das Problem behoben, indem er deinen Tipp in der Warteliste befolgt hat (lpd://IP_DES_ROUTERS/LPT1).

    Wenn ich das jedoch in die Warteliste eingebe (lpd://192.168.2.1/LPT1), wird der Drucker weiterhin als inaktiv erkannt und wenn ich etwas drucke, wird es in der Warteliste automatisch abgebrochen.

    HPIJS ist installiert und mein Drucker (HP Deskjet 5150) befindet sich in der Auswahlliste.


    Wie kann ich den Drucker zum drucken bringen?


    Gruß
    iDaniel
     
  8. MrFX

    MrFX Zehendlieber

    Dabei seit:
    01.09.05
    Beiträge:
    4.129
    Moin!

    Nene, in die Warteliste kommt nur LPT1... das lpd:// bezog sich auf die komplette Adresse...

    Wenn was aus dem Drucker kommt, geht die Kommunikation schon mal.

    Du hast aber auch Ghostscript mit installiert?

    MfG
    MrFX
     
  9. iDaniel

    iDaniel Bismarckapfel

    Dabei seit:
    08.11.04
    Beiträge:
    141
    Ja, Ghostscript ist installiert. Was muss ich genau einstellen, dass das funktioniert?

    Muss ich meinen Drucker aus der Liste auswählen, oder soll ich den Post Script Drucker lassen?
     
  10. MrFX

    MrFX Zehendlieber

    Dabei seit:
    01.09.05
    Beiträge:
    4.129
    Moin!

    Du mußt HP DeskJet 5150 Foomatic/hpijs auswählen...

    Wenn da ein PostScript-Listing aus dem Drucker kommt, ist irgendwas mit Ghostscript nicht richtig... am besten, du bügelst das von der HPIJS-Seite nochmal drüber.

    MfG
    MrFX
     
  11. iDaniel

    iDaniel Bismarckapfel

    Dabei seit:
    08.11.04
    Beiträge:
    141
    Erfolg!!!

    Ich habe jetzt LPT1 eingegeben und meinen Drucker ausgewählt. Ich habe ihn eine Zeile drucken lassen und er hat die Zeile sauber ausgedruckt. Allerdings hat er danach noch eine leere Seite durchgezogen, wie bekomme ich das noch weg?

    Die neusten HP Treiber habe ich in Form der neusten HP inject Toolbox schon.

    Der Drucker wird immer noch als inaktiv bezeichnet.

    schon mal vielen Dank!

    iDaniel
     
  12. MrFX

    MrFX Zehendlieber

    Dabei seit:
    01.09.05
    Beiträge:
    4.129
    Moin!

    Also wie jetzt, welche Treiber nimmst du nun?

    MfG
    MrFX
     
  13. iDaniel

    iDaniel Bismarckapfel

    Dabei seit:
    08.11.04
    Beiträge:
    141
    Ich habe jetzt die Treiber für meinen Deskjet 5150 genommen.
     
  14. MrFX

    MrFX Zehendlieber

    Dabei seit:
    01.09.05
    Beiträge:
    4.129
    Moin!

    Und was war mit den HPIJS-Treibern? Ging das nicht?

    MfG
    MrFX
     
  15. iDaniel

    iDaniel Bismarckapfel

    Dabei seit:
    08.11.04
    Beiträge:
    141
    Hallo,

    doch, es geht jetzt schon mit den HPIJS Treibern, nur zieht der Drucker bei jedem Druckvorgang ein zusätzliches leeres Blatt durch, nachdem er gedruckt hat.
    Das ist zwar erträglich, aber überflüssig. Hast du eine Ahnung, woran das liegen kann?


    Gruß
    iDaniel
     
  16. MrFX

    MrFX Zehendlieber

    Dabei seit:
    01.09.05
    Beiträge:
    4.129
    Moin!

    Hm... hast du die neuste Firmware auf dem Router? Ich hatte das auch mal mit 'nem Router...
    Aber ob es wirklich daran liegt?

    MfG
    MrFX
     
  17. iDaniel

    iDaniel Bismarckapfel

    Dabei seit:
    08.11.04
    Beiträge:
    141
    Die aktuelle Firmware ist bereits installiert.
     
  18. Rookie79

    Rookie79 Tokyo Rose

    Dabei seit:
    08.11.05
    Beiträge:
    68
    Ich muss mal diesen alten Thread von mir wieder ausgeben weil ich im Moment gerade echt etwas ratlos bin:

    Mein Drucker funktionierte seit Dezember einwandfrei.
    Nun plötzlich kann ich nichtmehr drucken.
    Dabei hab ich nix verändert, garnix... gleicher Router, gleiches Powerbook.
    Aber er druckt nichtmehr :( Und ich hab keine Ahnung warum.

    Ich bekomme im Druckerdialog ne komische Fehlermeldung:

    "The Process "foomatic-rip" stopped unexpectedly with status 1"

    Ich hab schon Gutenprint deinstalliert und die aktuellste Version installiert.
    Fehlermeldung bleibt die selbe.

    Der Drucker funktioniert, zumindest kann ich vom WinXP Rechner der noch am Router hängt einwandfrei drucken.

    Nun wärs reizend wenn vielleicht jemand ne Idee hätte, ich hab langsam keine mehr.
    Und mit Drucker am PowerBook ginge es mir viel viel besser, alles übers Netz kopieren, zum Win Rechner laufen und da ausdrucken nervt mich :D

    Danke schonmal!
     

    Anhänge:

  19. MrFX

    MrFX Zehendlieber

    Dabei seit:
    01.09.05
    Beiträge:
    4.129

Diese Seite empfehlen