1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Hostname am Terminal.

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von macnewbie, 27.10.05.

  1. macnewbie

    macnewbie Idared

    Dabei seit:
    30.08.05
    Beiträge:
    28
    Hostname am Terminal. Feature oder Bug?!

    Hallo,

    mir ist heute aufgefallen das bei mir auf der Shell nicht mehr der richtige Hostname angezeigt wird. In den Systemeinstellungen unter Sharing ist angegeben z.b. "XYZ" und auf der Shell und mit uname -n zeigt er mir "localhost" an. Woran liegt das? Das war nicht immer so, habe ich unbewusst eine Einstellung gemacht die das zur Folge hat?

    Gruss,
    macnewbie
     
    #1 macnewbie, 27.10.05
    Zuletzt bearbeitet: 27.10.05
  2. macnewbie

    macnewbie Idared

    Dabei seit:
    30.08.05
    Beiträge:
    28
    Re: Hostname am Terminal. Feature oder Bug?!

    Hallo,

    habe nochmals meine letzten Änderungen scharf überdacht und habe rausgefunden woran das liegt. Wenn ich als Nameserver einen Server im internen Netz angebe bleibt es bei dem Originalnamen auch in der Shell, sobald ich einen externen Nameserver angebe, z.b. einen von Arcor oder so ändert sich der Hostname in der Shell in "localhost". Und jetzt möge man mir erklären woran das liegt.

    Gruss,
    macnewbie
     
    #2 macnewbie, 27.10.05
    Zuletzt bearbeitet: 27.10.05
  3. Duke Leto

    Duke Leto Boskop

    Dabei seit:
    05.05.05
    Beiträge:
    204
    Salut Newbie,

    manchmal hilft auch eine einfache Forensuche schnell weiter, das spart Doppelspurigkeiten.
    Mit einer Suche nach hostname hättest Du diesen Thread gefunden, der unter anderem Deine Frage beantwortet. ;)

    Grüsse
     
  4. macnewbie

    macnewbie Idared

    Dabei seit:
    30.08.05
    Beiträge:
    28
    Hallo,

    den Thread habe ich gesehen, der beantwortet aber nicht meine Frage. Bei mir ändert sich der Hostname in "Localhost" wenn ich einen externen Nameserver angebe. Das ist nicht ganz das selbe. Der Lösungsansatz wie man das verhindern kann ist zwar damit beantwortet aber nicht warum das ganze beim ändern des Nameserver passiert. Zumal arbeite ich in dem Fall ohne DHCP. Es wird dann nervig wenn man sich innerhalb eines Netzes an einem 2 Mac per SSH anmeldet und dann mehrere Terminalfenster offen hat und dann überall am Anfang "Localhost"stehen hat. Wenn dann noch zu allem Überfluss der Username der selbe ist wirds langsam schwierig zu wissen auf welchem System man sich aktuell befindet. Zumal ich mich auch nicht mit dem System direkt einwähle.

    Gruss,
    macnewbie
     
  5. Duke Leto

    Duke Leto Boskop

    Dabei seit:
    05.05.05
    Beiträge:
    204
    Da habe ich Dich wohl falsch verstanden :innocent: und nehme alles mit dem Ausdruck des Bedauerns zurück.

    Aber wäre es nicht eventuell dennoch die Lösung, gerade auch wenn Du kein DHCP verwendest, die /etc/hostconfig zu ändern, wie im genannten Thread beschrieben? Damit kannst Du dann ja Deinen gewünschten hostname erzwingen, egal was der Rest der Welt wünscht.
     
  6. macnewbie

    macnewbie Idared

    Dabei seit:
    30.08.05
    Beiträge:
    28
    Kein Thema :)

    Ist auch so schon geschehen. Mich interessiert trotzdem warum das so ist. Ich denke nicht das es von Apple bzw. den Darwin Entwicklern so gewollt ist. Zumindest kann ich keinen Grund dafür finden. Danke trotzdem für den Tip in diesem Thread zu schauen, hätte ja richtig sein können denn der "Fehler" hört sich ziemlich gleich an.

    Gruss,
    macnewbie
     
  7. IceHouse

    IceHouse Ribston Pepping

    Dabei seit:
    30.09.04
    Beiträge:
    297
    Re: Hostname am Terminal. Feature oder Bug?!

    Das eine, hat mit dem anderen rein gar nichts zu tun. Du suchst Infos um den Mechanismus von hostname(1) besser zu verstehen. Ein kleiner "hint":
    Code:
    For instance, if you're using DNS and your nameserver is off your
    local subnet, then you'll need your default route set before you can
    resolve the hostname of your default router.
    Der "APPLETALK_HOSTNAME" hat mit dem hostname(1) rein gar nichts zu tun (SSHSERVER, WEBSERVER, and APPLETALK_HOSTNAME are modified by the System Preferences Sharing panel. Do it there.)

    Gruss von IceHouse
     
  8. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Versuch die /etc/hostconfig zu ändern (mit vi oder pico). Ändere den hostname auf:

    "HOSTNAME=nameDeinerWahl"
    Momentan steht dort wahrscheinlich:
    "HOSTNAME=-AUTOMATIC-"

    Idealerweise kommentierst Du die Zeile einfach aus, so daß es wie folgt aussieht:
    Code:
    # Network configuration
    #HOSTNAME=-AUTOMATIC-
    HOSTNAME=meinNeuerTollerHostName
    
    Die Ursache kann sein, daß bei "automatic" Dein hostname vom Router bezogen wird.
     

Diese Seite empfehlen