1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

"ftp root" verzeichnis in home directory

Dieses Thema im Forum "macOS & OS X Server" wurde erstellt von marccaballero, 10.12.06.

  1. Hallo zusammen,

    bei mir wird im home verzeichnis eines jeden benutzers ein "ftp root" directory angelegt, welches auf das "Users" verzeichnis zeigt. somit kann jeder der sich über ftp einloggt auch alle anderen home verzeichnisse sehen. dies möchte ich allerdings nicht. wenn ich dieses "ftp root" verzeichnis von hand lösche taucht es bei jedem login eines benutzers über ftp wieder auf. Wie kann ich das verhindern?

    ich habe in den ftp server einstellungen eigestellt, dass jeder benutzer auf sein home directory und die netzwerkordner zugriff hat. ich habe nämlich in manchen home directorys links auf freigegebene ordner gelegt.

    Vielen Dank schon mal im Vorraus und Grüße

    Marc
     
  2. Appleboy

    Appleboy Neuer Berner Rosenapfel

    Dabei seit:
    04.12.05
    Beiträge:
    1.976
    Hallo,

    wenn sich ein Benutzer einloggt, kann er nur sein Homeverzeichnis sehen. Oder ist das bei dir anders?

    Viele Grüße

    Timo
     
  3. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    ich auch nicht!
    das feature nennt man chroot.
    damit kämpfe ich seit osx server 10.1.x herum.

    seit 10.2.x greife ich den integrierten ftp server unter os x server nicht mehr an.
    hat mir schon zuviel kopfweh gekostet.

    es kommt darauf an, was du mit dem ftp server vorhast.....
    aber ich verwende entweder pureftp manager oder für richtige transfer server rumpus.
    bei letzterem braucht man keinem ftp erklären, weil alles auch unter webupload funktioniert.

    HTH
    mike
     
  4. wenn sich ein benutzer einlogt kann er nur sein home verzeichnis sehen. bei bestimmten accounts sind allerdings links auf freigegebene netzwerkordner vorhanden. somit musste ich in der konfiguration für den ftp server einstellen, dass der benutzer sein home verzeichnis und auch netzwerkordner sieht.
    das klappt soweit ja auch alles prima bis dann eben immer dieser ftp root ordner wieder erscheint.
    ich glaube ich werde mal den pureftp manager testen...

    grüße marc
     
  5. eXiNFeRiS

    eXiNFeRiS Leipziger Reinette

    Dabei seit:
    30.08.05
    Beiträge:
    1.804
    Dito
     
  6. Kernelpanik

    Kernelpanik Ingol

    Dabei seit:
    05.03.04
    Beiträge:
    2.098
    Ich habe PureFTP drauf. Es läuft eigentlich recht gut bis auf eines:
    Das Directory direkt auf dem Server sieht so aus:

    Das Directory als ftp auf dem Client so:

    Warum den nur?
     
    #6 Kernelpanik, 20.02.07
    Zuletzt bearbeitet: 23.02.07
  7. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    hast falsche zugriffsrechte innerhalb des root ordners?
    poste mal, wie die aussehen....
     
  8. Kernelpanik

    Kernelpanik Ingol

    Dabei seit:
    05.03.04
    Beiträge:
    2.098
    z.B. Akai Alias und der Arven Alias auf dem Server haben die exakt gleichen Zugriffsrechte.
     
    #8 Kernelpanik, 20.02.07
    Zuletzt bearbeitet: 23.02.07
  9. meister eder

    meister eder Cripps Pink

    Dabei seit:
    10.05.05
    Beiträge:
    152
    Hi habe mal mitgelesen, ich habe den Pure Manager installiert aber ich bekomme in nicht zum laufen, meine FTP Client ist der Meinung der FTP Server sei erreichbar jedoch bekomme ich immer die MELDUNG: "launchproxy[29649]: execv(): No such file or directory". Diese Meldung bekomme ich auch wenn ich pure deaktiviere und sen original server ftp verwende, was mache ich falsch. Für eure Hilfe wäre ich Euch sehr dankbar.
    Der Eder
     
  10. Kernelpanik

    Kernelpanik Ingol

    Dabei seit:
    05.03.04
    Beiträge:
    2.098
    Ja das Problem scheinen alle mehr oder weniger zu haben. Ich hab es folgendermassen gelöst: FTP ein FTP aus WEB Sharing ein WEB Sharing aus, Neustart und das ganze nochmal und dann lief es. Frag' mich aber nich' warum. Sobald localhost läuft is' es gut.
     

Diese Seite empfehlen