1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Flash 8 & Dreamweaver 8 -> swf wird in Browser nicht angezeigt!

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von gildo, 07.11.06.

  1. gildo

    gildo Alkmene

    Dabei seit:
    19.05.05
    Beiträge:
    32
    Hallo,

    ich bin einfach verzweifelt...
    Weder in Firefox 2.0, noch im Internet Explorer oder Safari wird die .swf-Datei angezeigt.
    Ich weiß einfach nicht was ich falsch mache. Hier der Auszug aus der html:

    <table width="500" height="900" border="0" align="center" cellpadding="0" cellspacing="0">
    <tr background="http://fcgummiplatz.fc.funpic.de/3kclub/gifs/navi.gif">
    <td height="160" colspan="2"><script type="text/javascript">
    AC_FL_RunContent('codebase','http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0','width','500','height','160','align','middle','src','http://fcgummiplatz.fc.funpic.de/3kclub/flash/navigation','quality','best','wmode','transparent','bgcolor','#ffffff','allowscriptaccess','sameDomain','pluginspage','http://www.macromedia.com/go/getflashplayer','movie','http://fcgummiplatz.fc.funpic.de/3kclub/flash/navigation' ); //end AC code
    </script><noscript>
    <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="500" height="160" align="middle">
    <param name="allowScriptAccess" value="sameDomain" />
    <param name="movie" value="http://fcgummiplatz.fc.funpic.de/3kclub/flash/navigation.swf" />
    <param name="quality" value="best" />
    <param name="wmode" value="transparent" />
    <param name="bgcolor" value="#ffffff" />
    <embed src="http://fcgummiplatz.fc.funpic.de/3kclub/flash/navigation.swf" quality="best" wmode="transparent" bgcolor="#ffffff" width="500" height="160" align="middle" allowscriptaccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" /></embed>
    </object>
    </noscript></td>


    Was mache ich falsch?

    Über Hilfe würde ich mich freuen...
     
  2. dewey

    dewey Gewürzluiken

    Dabei seit:
    01.05.06
    Beiträge:
    5.732
    das wars dann mitdem layout:p
     
  3. gildo

    gildo Alkmene

    Dabei seit:
    19.05.05
    Beiträge:
    32
    Was meinst du damit?
     
  4. wapplegraph

    wapplegraph Normande

    Dabei seit:
    12.04.06
    Beiträge:
    571
    Hallo Gildo

    Ich würde dir anraten, wenn du etwas nicht weisst, dass du es z.B. in der Entwurfsansicht machst und dann den Code anschaust.
    Probiere es einmal so.
    Habe leider noch nie beim programmieren, eine Flash Datei eingefügt, doch beim Websiten zeichnen.

    dewey meint mit seinem Beitrag, glaube ich, dass das Layout mit Tabellen altmodisch ist.

    wapplegraph
     
  5. gildo

    gildo Alkmene

    Dabei seit:
    19.05.05
    Beiträge:
    32
    Danke für die Hilfe, aber das löst mein Problem leider nicht.
    Dreamweaver sagt mir sogar, dass der code so da stehen müsste, aber die browser zeigen nix an!
     
  6. wapplegraph

    wapplegraph Normande

    Dabei seit:
    12.04.06
    Beiträge:
    571
    Ja funktioniert überhaupt deine swf Datei?
    Hast du sie mit dem Flash Player getestet?
     
  7. gildo

    gildo Alkmene

    Dabei seit:
    19.05.05
    Beiträge:
    32
    Ja, die swf funktioniert! Habe es im Flash-Player getestet!
     
  8. wapplegraph

    wapplegraph Normande

    Dabei seit:
    12.04.06
    Beiträge:
    571
    Wie steht es wenn du eine andere Datei einfügst?
     
  9. Moriarty

    Moriarty Pommerscher Krummstiel

    Dabei seit:
    17.05.04
    Beiträge:
    3.032
    Veröffentliche mal im Flash den Film anstelle ihn zu exportieren. Du erhälst eine HTML-Datei mit eingebettetem SWF dazu. Kopiere einfach aus dem Quellcode die entsprechenden zeilen in deine HTML-Seite.

    Gehts jetzt?
     
  10. gildo

    gildo Alkmene

    Dabei seit:
    19.05.05
    Beiträge:
    32
    Super, jetzt geht's! In Safari und Firefox klappt alles, weiß nur nicht wie mit dem IE aussieht. Danke für die Hilfe!
     
  11. Moriarty

    Moriarty Pommerscher Krummstiel

    Dabei seit:
    17.05.04
    Beiträge:
    3.032
    Gern geschehen!:)

    gruß
    Dennis
     
  12. wapplegraph

    wapplegraph Normande

    Dabei seit:
    12.04.06
    Beiträge:
    571
    Hallo
    Habe jetzt auch erade das gleiche Problem.

    <img src="image/homeback1.jpg" id="homebackimg" />

    <script src="../Scripts/AC_RunActiveContent.js" type="text/javascript"></script>
    </script><script type="text/javascript">
    AC_FL_RunContent( 'codebase','http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0','width','550','height','59','id','flash_index','align','middle','src','flash_index','quality','high','bgcolor','#ffffff','name','flash_index','allowscriptaccess','sameDomain','pluginspage','http://www.macromedia.com/go/getflashplayer','movie','flash_index' ); //end AC code
    </script><noscript><object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="550" height="59" id="flash_index" align="middle">
    <param name="allowScriptAccess" value="sameDomain" />
    <param name="movie" value="flash_index.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#ffffff" /><embed src="flash_index.swf" quality="high" bgcolor="#ffffff" width="550" height="59" name="flash_index" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
    </object></noscript>

    Es klappt einfach nicht. Das ganze ist im Zusammenhang mit php.
    Das Dokument, was es mir ausgegeben hat funktioniert. kopiere ich den Code geht es nicht mehr. Fehlt vielleicht der richtige Pfad? Wo?

    wapplegraph
     
  13. Hilarious

    Hilarious Gelbe Schleswiger Reinette

    Dabei seit:
    10.08.05
    Beiträge:
    1.759
    Schwer zu sagen, da ich nicht weiß, was in der AC_RunActiveContent.js drin ist (vermutlich eine allgemeine Bibliothek, die Flash/Dreamweaver mitbringt?).

    Deine Vermutung mit dem Pfad könnte natürlich auch stimmen. Bei Flash musst Du berücksichtigen, dass das Flash-Modul sich selbst immer auf den Pfad bezieht, in dem es ausgeführt wird, also der Pfad der referenzierenden Datei, und nicht der Pfad, in der die SWF-Datei liegt.

    Wenn Du sicherstellen möchtest, dass es gehen soll, kannst Du auch alle Pfade, die in dem SWF und innerhalb der <object>-Tags angesprochen werden absolut statt relativ definieren. Dazu notierst Du den Dateipfad mit führendem Schrägstrich und zählst alle Ordner ab dem DocumentRoot auf, als würdest Du einfach den Teil der Adresse mit dem Protokoll und der Domain weglassen.
     

Diese Seite empfehlen