1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Firefox stellt plötzlich kein ð und Ð mehr dar...

Dieses Thema im Forum "Browser" wurde erstellt von MasterDomino, 31.08.05.

  1. MasterDomino

    MasterDomino Roter Eiserapfel

    Dabei seit:
    28.04.05
    Beiträge:
    1.440
    Hallo liebe Apfeltalker!

    Habe seit ca. einer Woche ein seltsames Problem: Firefox stellt plötzlich nicht mehr die isländischen Buchstaben ð und Ð dar, stattdessen gibt er sie als Zeichen dar, die wie > und < aussehen (und zwar tatsächlich in dieser Reihenfolge, obwohl das erste ja eigentlich der Klein- und der zweite der Großbuchstabe sind und es bei den Klammern andersherum ist...) nur etwas gedrungener sind (habe also eigentlich keine Ahnung welches Zeichen es ist... reinkopieren hier in Safari (das ich gerade benutze) kann ich es auch nicht, da es dann wieder als das isländische ð erscheint.
    Betroffen sind zudem auch die isländischen Buchstaben þ und Þ. Sie werden seltsamerweise durch fl und fi ersetzt?!
    Nicht betroffen sind æ und Æ.
    Das Problem tritt erst seit kurzem auf und ließ sich auch nicht mit einem Update von Firefox 1.0.3 auf 1.0.6 beheben... und wie gesagt: In Safari funktioniert alles einwandfrei...
    Das Problem wäre an sich auch nicht so frappierend, wenn ich mich nicht gerade für ein Jahr in Island aufhalten würde und daher schon des Öfteren mit diesen Buchstaben konfrontiert bin...

    Wäre sehr dankbar, wenn mir jemand weiterhelfen könnte...

    OS ist 10.4.2

    Danke,

    MasterDomino
     
  2. msx3000

    msx3000 Martini

    Dabei seit:
    19.05.05
    Beiträge:
    646
    mmh, ich kann zu dem Thema nur rateno_O.
    Aber vielleicht liegt es ja an den eingestellten Tastaturlayouts. Vielleicht orientiert sich der Firefox an der eingestellten Tastatur-Vorgabe und stellt die zeichen akkurat dar wenn du im isländischen Modus arbeitest?

    schönen Gruß

    msx

    EDIT: ich sehe gerade Du kannst im Firefox unter Options-General-Language die Spracheinstellung verändern. Vielleicht musst Du den Browser dort auf isländisch umstellen. (bei dem mac firefox wahrscheinlich unter Preferences-General)
     
  3. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    Das liegt mit hoher wahrscheinlichkeit an der zeichenkodierung.

    im Quelltext des html-dokumets sollte der charset in den meta-angaben definiert sein, z.b.:
    Code:
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
    Das sagt aus, dass das dokument mit dem unicode 8-bit zeichensatz gespeichert worden ist (hoffentlich), und gibt dem browser den hinweis die richtige codierung zu verwenden.

    fehlt diese angabe, was ich annehme, dann probiere einfach die zeichensätze unter Ansicht > Zeichenkodierung durch.

    lg.c7.
     
  4. MasterDomino

    MasterDomino Roter Eiserapfel

    Dabei seit:
    28.04.05
    Beiträge:
    1.440
    Das sorgt aber meines Erachtens nur dafür, dass die Seite in Isländisch dargestellt wird, sobald die Seite in zwei Sprachen vorliegt und eine davon isländisch ist... was wohl eher selten ist... Hat jedenfalls nichts verändert.

    Im Quellcode der Seite steht allerdings nicht dieser unicode 8-bit Zeichensatz, sondern der ISO-8859-1 . Was bedeutet das jetzt? Der ist bei Firefox bei mir aber auch schon angekreuzt gewesen...
    Außerdem habe ich ja das Problem, dass er das auf GAR keiner Seite mehr darstellen kann, ich kann den Buchstaben noch nicht einmal in die Adresszeile tippen...
    Was kann ich jetzt machen, um das Problem zu beheben, ich bin sehr verwirrt? Zumal das ja immer hervorragend funktioniert hat und jetzt nicht mehr...

    Gruß, MasterDomino
     
  5. moornebel

    moornebel Pomme Miel

    Dabei seit:
    13.04.04
    Beiträge:
    1.488
    Hast Du ev. irgendeine Schrift installiert/deinstalliert/deaktiviert in den letzten Tagen? Oft liegt es daran, wenn Zeichen nicht mehr korrekt dargestellt werden.

    Gruss ins geliebte Island
    moornebel
     
  6. MasterDomino

    MasterDomino Roter Eiserapfel

    Dabei seit:
    28.04.05
    Beiträge:
    1.440
    Aber dann würde es in Safari doch auch nicht mehr funktionieren, oder?
    Betroffen ist wie gesagt nur Firefox...

    Gruß, MasterDomino
     
  7. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    tritt das phänomen bei allen seiten mit isländischem buchstaben auf, oder nur auf einer bestimmten?
    Könntest du mal einen link posten?

    c7.
     
  8. MasterDomino

    MasterDomino Roter Eiserapfel

    Dabei seit:
    28.04.05
    Beiträge:
    1.440
    Nein, auf allen Seiten, das ist ja das komische. Zum Beispiel auch auf dieser hier, wo ich zahlreiche isländische Buchstaben poste, wenn ich sie mit Firefox darstellen lasse...

    Link ist daher: diese Seite hier ;)

    Weiß vielleicht noch irgendjemand was?

    Gruß, MasterDomino
     
  9. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    ups, das habe ich wohl überlesen... :innocent:

    jo, ich hab keine ahnung mehr.
    am besten: schmeiss den ordner (firefox.app) raus und installiere ihn neu.

    c7.
     

Diese Seite empfehlen