1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Festplatte kann nicht mehr aktiviert werden

Dieses Thema im Forum "Desktop-Macs" wurde erstellt von Nick, 05.01.06.

  1. Nick

    Nick Rheinischer Krummstiel

    Dabei seit:
    26.02.05
    Beiträge:
    387
    Ich hatte in meinem PM G4 bis vor kurzem 3 Platten eigebaut.
    Jetzt habe ich noch eine neue 300GB HD nachgerüstet und die Platte die am gleichem "Kabel"(das was auf die Hauptplatine führt) angeschlossen ist kann nicht mehr aktiviert werden.
    Auch im Festplatten-Dienstprogramm wird zwar die HD an sich erkannt aber die Partition nicht.

    Wenn ich dann versuche die Partition zu aktivieren erhalte ich in etwa diese Fehlermeldung:

    Aktivieren fehlgeschlagen
    Die Festplatte „disk0s10“ konnte nicht aktiviert werden.
    Verwenden Sie „Erste Hilfe“ und aktivieren Sie sie dann erneut.


    Erste Hilfe kann die Partition auch nicht reparieren (bricht auch mit einer Fehlermeldung ab).

    Dann habe ich die neue 300GB wieder ausgebaut und gehofft ,dass ich die Daten von der besagten Platte noch retten kann aber sie wird jetzt immer noch nicht erkannt.

    Kann es sein, dass ich die alte Platte damit beschädigt habe?
    Ich denke sie würde wieder funktionieren wenn ich sie formatieren würde aber ich muss zuvor unbedingt noch meine Daten sichern.

    Vielleicht kann mir ja jemand helfen

    Gruß Nick
     
  2. mathilda

    mathilda Leipziger Reinette

    Dabei seit:
    17.02.05
    Beiträge:
    1.787
    Die Wahrscheinlichkeit, dass Du Deine Daten damit beschaedigt hast, ist gering, aber groesser als Null.

    Wenn Du noch Daten auf der Festplatte hast, die Du unbedingt brauchst, dann formatiere sie auf keinen Fall. Geh an einen anderen Rechner (von einem Freund zB) und versuche dort mittels Firewiregehaeuse die Platte zu aktivieren und Deine Daten zu sichern.
     
  3. marcozingel

    marcozingel Brettacher

    Dabei seit:
    07.12.05
    Beiträge:
    7.482
    ist die putt?
    Ja immer diese Experimente ohne vorherige Datensicherung.
    Hoffentlich bekommst du das wieder hin.
     
  4. Nick

    Nick Rheinischer Krummstiel

    Dabei seit:
    26.02.05
    Beiträge:
    387
    Auf der Platte sind meine ganzen Spiele:p .

    Also sind die Daten nicht so extrem wichtig.
    Ich hatte mit dieser Platte (Standardfestplatte die beim Rechner dabei war [80GB]) schon von Anfang an Probleme :
    Nach dem Starten hat die Platte erst einmal ca 30 Sekunden gebraucht um überhaupt "anzulaufen". Also habe ich auf der Platte auch nur Spiele gespeichert, weil es mir zu gefährlich gewesen wäre wichtige Daten auf die Platte zu sichern.

    @mathilda:
    ich werde mal versuchen die Platte in das Gehäuse von meiner externen LaCie d2 umzubauen
     
  5. Nick

    Nick Rheinischer Krummstiel

    Dabei seit:
    26.02.05
    Beiträge:
    387
    So, jetzt habe ich die Platte in mein externes Gehäuse eingebaut, bin zu einem anderem Computer (Mac) gegangen und hatte das gleiche Problem.
    Wenn sie angesteckt wird kommt sofort eine Fehlermeldung "CD/DVD Medium wurde nicht erkannt…" mit den Optionen "Initialisieren, Ignorieren, Auswerfen".

    Ich denk mal meine Daten sind jetz weg?!

    Gruß
    Nick
     
  6. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.903
    Das bedeutet, dass dort nicht mal eine Partitionstabelle gefunden wird.
    Vermutlich ist die Platte im Eimer und läuft mit dem schwachen Netzteil des externen Gehäuses nicht mal mehr an.
    Hörst du Drehgeräusche?
     
  7. Nick

    Nick Rheinischer Krummstiel

    Dabei seit:
    26.02.05
    Beiträge:
    387
    Ja, die Platte läuft an und auch Drehgeräusche kann ich hören.
    Auch im PowerMac war es das Gleiche.
     
  8. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.903
    Gib mal folgendes (hüstel...) im Terminal ein.
    Am besten mit Copy&Paste, die Zeile ist *ziemlich* lang und Tippfehler alles andere als wünschenswert. Obacht, du musst die *ganze* Zeile in einem Rutsch eingeben:

    Code:
    _MY_OLDSHOPT_="$(shopt -p extglob)"; shopt -s extglob; declare -x _RDEV_12345_="" _MY_TMPDIR_12345_="${HOME}/Desktop/Disk-Liste_v3"; sudo -k; if [ ! -f "${_MY_TMPDIR_12345_}.tbz2" ] && (echo -e "\nAdministrator-Kennwort bitte...\n") && (sudo -v) && (mkdir "${_MY_TMPDIR_12345_}"); then { mount &> "${_MY_TMPDIR_12345_}/mount_out.txt"; for _RDEV_12345_ in $(ls -1d /dev/rdisk+([[:digit:]])); do { echo $_RDEV_12345_; sudo sh -c 'pdisk -l ${_RDEV_12345_} &> "${_MY_TMPDIR_12345_}/${_RDEV_12345_:5}_pdisk_out.txt"; dd if="${_RDEV_12345_}" bs=512 count=1024 skip=263968 of="${_MY_TMPDIR_12345_}/${_RDEV_12345_:5}_dd_out.bin" 2> "${_MY_TMPDIR_12345_}/${_RDEV_12345_:5}_dd_err.txt"; hdiutil hfsanalyze ${_RDEV_12345_} &> "${_MY_TMPDIR_12345_}/${_RDEV_12345_:5}_analyze_out.txt"; '; }; done; sync; sudo sh -c 'chown -R ${SUDO_UID}:${SUDO_GID} "${_MY_TMPDIR_12345_}"; '; chmod -R a+rwX "${_MY_TMPDIR_12345_}"; sudo -k; tar -cjf "${_MY_TMPDIR_12345_}.tbz2" -C "${_MY_TMPDIR_12345_}" . ; rm -r "${_MY_TMPDIR_12345_}"; echo -e "\nFertig.\a"; }; else echo -e "\nAbbruch\n"; fi; ${_MY_OLDSHOPT_}; unset _MY_OLDSHOPT_ _MY_TMPDIR_12345_ _RDEV_12345_;
    
    
    Du brauchst Administratorrechte, sollte logisch sein.
    Und alle erwähnten Platten natürlich in Betrieb.
    (Externe darfst du gerne abklemmen, dann geht das ganze flotter)

    Anschliessend findest du auf deinem Schreibtisch eine Datei namens:
    "Disk-Liste.tbz2" (keine Sorge, da ist nichts sonderlich geheimes drin.)
    Poste die mal hier als Anhang, dann kann dir besser gehelft werden.

    (Falls du irgendwie was verpatzt und das erneut laufen lässt, musst du erst vorher die alten Ausgabedateien vom Schreibtisch entfernen. Ich lösche bei dir nicht gerne irgendwas automatisch...muss nicht sein.)
     
    #8 Rastafari, 09.01.06
    Zuletzt bearbeitet: 17.01.06
  9. Nick

    Nick Rheinischer Krummstiel

    Dabei seit:
    26.02.05
    Beiträge:
    387
    Vielen Dank erstmal für den Tipp.

    Ich habe nur im Moment leider überhaupt keine Zeit das mal auszuprobieren.
    Aber ich werde dann berichten in ein paar Tagen.

    Gruß Nick
     
  10. Nick

    Nick Rheinischer Krummstiel

    Dabei seit:
    26.02.05
    Beiträge:
    387
    So, Datei ist angehängt.

    Gruß Nick
     

    Anhänge:

  11. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.903
    Es wurden 3 Platten registriert.
    Eine mit 186 GB (Startvolume)
    Eine mit 74 GB (aka "80er...")
    und eine mit 280 GB.
    Die Partitionstabellen sind soweit in Ordnung, der Datentransfer funktioniert zumindest mal rudimentär, das ist schon mal was gutes.

    Du solltest jetzt mal jeweils nur *eine* Platte angeschlossen lassen, von CD starten und versuchen die Volumes *einzeln* zu reparieren.

    Sag mal...
    Als du die beiden Platten am gemeinsamen Kabel hängen hattest...
    ...da hattest du schon ganz korrekt und gewissenhaft die eine als "Master" gejumpert und die andere als "Slave" - oder etwa nicht?
     
  12. Nick

    Nick Rheinischer Krummstiel

    Dabei seit:
    26.02.05
    Beiträge:
    387
    Doch, hatte ich gemacht. Die am Ende des Kabels angeschlossene Platte hab ich zum Master gemacht, die andere zum Slave.

    Ich probier das jetzt mal aus mit dem *einzelnen* reparieren^^
     
  13. Nick

    Nick Rheinischer Krummstiel

    Dabei seit:
    26.02.05
    Beiträge:
    387
    Ich habe das ganze jetzt einmal ausprobiert und nur die Problem-Platte angesteckt.

    --> gleiches Problem:
    Beim Reparieren kommt wieder die gleiche Fehlermeldung
     
  14. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.903
    Ich habe die Skript-Zeile aus meinem vorigen Posting etwas modifiziert. Kannst du das Spiel nochmal wiederholen, dann habe ich mehr Infos... (mal sehen, ob sich was machen lässt).
     
  15. Nick

    Nick Rheinischer Krummstiel

    Dabei seit:
    26.02.05
    Beiträge:
    387
    #15 Nick, 14.01.06
    Zuletzt bearbeitet: 15.01.06
  16. Nick

    Nick Rheinischer Krummstiel

    Dabei seit:
    26.02.05
    Beiträge:
    387
    *hochschieb*
     
  17. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.903
    Sieht nicht gut aus.
    Aber einen Versuch hast du noch, das gleiche Spiel nochmal, bitte.
    Wenn diesmal auch nichts brauchbares rauskommt, kannst du das Volume leider abschreiben.
     
  18. Nick

    Nick Rheinischer Krummstiel

    Dabei seit:
    26.02.05
    Beiträge:
    387
  19. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.903
    Auf die Gefahr hin, dass du jetzt Weinkrämpfe bekommst... das Volume ist weg.

    Und ich meine nicht "beschädigt", sondern ich meine: "weg"!
    Dort, wo früher mal wohl ein Dateisystem war, befinden sich jetzt ausschliesslich Nullen. Alles komplett mit Leerdaten überschrieben. Nichts mehr zu machen. Aus.

    Ich kann nicht nachvollziehen, was da geschehen ist. Bist du sicher, nicht versehentlich was dummes angeklickt zu haben?
     
    Nick gefällt das.
  20. Nick

    Nick Rheinischer Krummstiel

    Dabei seit:
    26.02.05
    Beiträge:
    387
    Ne, ich hab da ganz sicher nichts dummes angeklickt;) .

    Die Platte hatte ja auch schon früher Probleme gemacht aber trotzdem vielen Dank für die Mühen.

    Gruß und schönen Abend
    Nick
     

Diese Seite empfehlen