1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Doppelte url anzeige in Safari

Dieses Thema im Forum "Browser" wurde erstellt von MarkusQ, 31.01.06.

  1. MarkusQ

    MarkusQ Gast

    Morgen!
    Ich habe ein großes Problem..
    Dauernd surfe ich mit Mozilla Firefox und Microsoft internet Explorer rum.
    Jetzt bin ich im Geschäft mal an den Linuxrechener und hab mit dem Safaribrowser
    mal unsere Homepage angesteuert.
    Die URL müsste eigentlich >>www.delta-sys.de<< lauten
    Er zeigt diese an.. Wenn ich aber auf einen Button klick kommt folgendes:

    SOLL: www.delta-sys.de/?page=historie
    IST: www.delts-sys.de/www.delta-sys.de/?page=historie >>resultat: 404 Error
    :mad::mad:

    Ich hab auch Opera und so probiert.. da geht es. aber mit Safari eben nicht.
    Ich habe PHP und CSS benutzt.. Muss ich bei Safari in der Index.inc.php irgendein Abfangmanöver machen?

    DAnke für Antworten!
     
  2. G5_Dual

    G5_Dual Melrose

    Dabei seit:
    31.05.04
    Beiträge:
    2.476
    Bei mir ist eine ganz normale Anzeige.
     
    #2 G5_Dual, 31.01.06
    Zuletzt bearbeitet: 25.03.06
  3. MarkusQ

    MarkusQ Gast

    Welche Safariversion benutzt du?

    Ich kenne mich nur laienhaft mit Linux aus.
     
  4. G5_Dual

    G5_Dual Melrose

    Dabei seit:
    31.05.04
    Beiträge:
    2.476
    Safari 2.03
    Aber Safari läuft mit Mac OS X, nicht mit Linux
     
  5. MarkusQ

    MarkusQ Gast

    [​IMG]Mac OS X ist, soweit ich weis ein Linux system ;)

    Ahso. .. noh n Browser der nicht funzt ist "Konquerror" moment.. muss gleich n screenshot hochladen
     
    #5 MarkusQ, 31.01.06
    Zuletzt von einem Moderator bearbeitet: 31.01.06
  6. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    der Fehler liegt im header:
    Code:
    	<base href="www.delta-sys.de">
    muß richtig heissen
    Code:
    	<base href="http://www.delta-sys.de">
    Gruß Stefan
     
    G5_Dual gefällt das.
  7. G5_Dual

    G5_Dual Melrose

    Dabei seit:
    31.05.04
    Beiträge:
    2.476
    Ah der Spezialist, danke für die Hilfe.
     
  8. MarkusQ

    MarkusQ Gast

    :D LOOL

    Ich glaubs net.. nur wegem den bissl >>http://<<

    Achso!!
    *edit*

    DANKE !!!!! So ein dummer Leichtsinnsfehler kommt mir bestimmt nicht mehr vor

    :D:D:D:D
     
  9. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    es fehlt halt einfach der richtige Einsprungpunkt

    Code:
    www.irgendwas.de
    wird dann zum nachfolgenden Pfadnamen von dem Punkt beginnend, an dem Du stehst, während
    Code:
    http://www.irgendwas.de
    eindeutig sagt, das Du eine komplette URI vor Dir hast. Ein erheblicher Unterschied, den aber offenbar Konqueror sehr viel strenger (und korrekter) interpretiert als der Rest.

    Das zeigt mal wieder wie wichtig es ist, die eigenen Machwerke mit verschiedenen Browsern zu testen um Anwender nicht in Fallen laufen zu lassen!

    Gruß Stefan
     
  10. MarkusQ

    MarkusQ Gast

    Jop..
    so sieht es aus..
    Ich hätte NIE gedacht, das diese 7 zeichen so einen Unterschied machen!
    SCHANDE über mich!!!

    Zumal.. ich lerne ja diesen Job. Medienoperator.. :-c:-c

    Schande Schande
     

Diese Seite empfehlen