1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Deutsche Sonderzeichen im Terminal

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von paninaro95, 21.01.06.

  1. paninaro95

    paninaro95 Gast

    Hallo,

    ich weiß, daß diese Frage schon oft gestellt wurde, nur sind die bisherigen Lösungen unzureichend: wie erhalte ich vollständige Unterstützung von deutschen Sonderzeichen im Terminal?

    Mit den bisherigen Konfigurationen in der .inputrc und .bashrc, die hier gefunden habe, kann ich zwar nun deutsche Umlaute eingeben, aber das Terminal kann diese nicht unbedingt verarbeiten:

    Ist in den Fenstereinstellungen unter "Darstellung->Zeichensatz-Codierung" ISO-Latin1 eingestellt, bekomme ich folgende Ausgabe:

    $ touch ä
    touch: ä: Invalid argument

    Habe ich UTF-8 eingestellt, funktioniert zwar "touch ä", aber ein "ls -la" fördert folgendes zu Tage:

    $ ls -la
    -rw-r--r-- 1 xxxxx xxxxx 0 21 Jan 10:55 a??

    Ein "ls -la ä" hingegen:

    $ ls -la ä
    -rw-r--r-- 1 xxxxx xxxxx 0 21 Jan 10:55 ä

    Was soll das? Warum ist das soooooo kompliziert unter Mac OS X (verwende übrigens 10.4.4), wenn alles andere sooooo einfach ist???

    Über entsprechende Hilfestellungen wäre ich sehr dankbar,
    Markus
     
    #1 paninaro95, 21.01.06
    Zuletzt von einem Moderator bearbeitet: 21.01.06
  2. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Hm, bei mir funktioniert es :) Wirf mal einen Blick auf meine Beiträge in den Threads ;)
     
  3. Daisy

    Daisy Uelzener Rambour

    Dabei seit:
    14.01.06
    Beiträge:
    366

    Hallo Markus,

    ich musste mich da auch vor kurzem erst aufklären lassen:

    probier's mal mit

    ls -law

    oder

    ls -lav

    dann klappt's auch mit dem 'ä'.

    Blöd, aber standardmäßig wirft ls die Sonderzeichen nicht richtig aus - schau mal in die manpage.

    Grüße

    Daisy
     
  4. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Ich habe einen Alias für ls in meiner .bashrc stehen:

    Code:
    # Show umlaut characters correctly and use color for file types.
    alias ls='ls -vwG'
    
    Parameter "a" ist nicht nötig.

    Und als Zeichensatz habe ich "Unicode UTF-8".
     
  5. Daisy

    Daisy Uelzener Rambour

    Dabei seit:
    14.01.06
    Beiträge:
    366
    was heisst da 'nicht nötig'? Parameter "a" hatte Kollege paninaro95 schon in seinem Beispiel - ich nehme an, er wollte die Ordner, die mit '.' starten auch listen ...

    ;) Daisy
     
  6. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Nicht nötig für teut'sche Umlaute.
     
  7. paninaro95

    paninaro95 Gast

    Danke für eure Hinweise! Mit dem Alias alias dir='ls -lavwG' hab ich nun das gewünschte Resultat.

    Nur die Vervollständigung von Dateinamen per Tab funktioniert nicht, wenn der erste Buchstabe ein Sonderzeichen ist. Folgendes Beispiel:

    $ touch ähm amen
    $ vi ä<t>
    $ vi a<t>
    amen ähm

    Drücke ich also nach dem ä auf Tab, passiert nichts. Drücke ich nach dem a auf Tab, steht mir amen und ähm zur Auswahl.

    Hat hier irgendwer noch nen Trumpf im Ärmel?

    Markus
     

Diese Seite empfehlen