1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Client am Xserver Opendirectory anmelden!

Dieses Thema im Forum "macOS & OS X Server" wurde erstellt von meister eder, 25.01.07.

  1. meister eder

    meister eder Cripps Pink

    Dabei seit:
    10.05.05
    Beiträge:
    152
    Hallo, ich hätte da ne Frage, wir wollen unsere Macs über Xserve Tiger unter OpenDirectory anmelden, hatte es mal geschaft dies einzurichten doch irgendwie hänge ich. Die Benutzer sind auf dem Server eingerichtet, DNS auch. Aber wie sage ich dem Client das er sich nicht local anmelden soll, habe im Verzeichnsient des Clients unter Ldap den erver angegebn aber er meldet sich immer nur local an. Jetzt erschlagt mich icht wieder von wegen wenn keine Ahnung lass es sein....Wir haben dafür eine testumgebung eingerichtet es geht wirklich mal um zu schauen wie es funzt. Einen Windows Mann für Dc´s haben wir im Boot. Wir haben euch einen Dienstleister nur um sich sowas einrichten zu lassen nur zu mal kucken ill ich keinGeld in die Hand nehmen. learning by doing ist angesagt! Kann mir jemand weiterhelfen??? Vielen Dank schon mal im voraus!
     
  2. Appleboy

    Appleboy Neuer Berner Rosenapfel

    Dabei seit:
    04.12.05
    Beiträge:
    1.976
    Hi,

    wenn du dich abmeldest, muss zusätzlich zum lokalen Account noch das Feld "Andere" erscheinen. Wenn du da drauf klickst, kannst du die Anmeldeinformationen, welche auf dem Server gespeichert sind, eingeben. Jetzt müsste es funktionieren.

    Viele Grüße

    Timo
     
  3. meister eder

    meister eder Cripps Pink

    Dabei seit:
    10.05.05
    Beiträge:
    152
    Hallo, vielen Dank. Ja das Anmeldefeld Andere erscheint bei mir jedoch funktioniert die Anmeldung nicht. In den Open Directory Einstellungen habe ich den Pfad gesehen (AFP) für den betreffenden User und mich mal manuel via Apfel K angemeldet, also da werde ich Akzeptiert, der User funktioniert also über AFP! Nur über Opendirectory will es nicht gehen! Was muss bei Suchpfad Ldap denn drinne stehen?
     
  4. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    erster wichtigster Test ist immer: klick mal im Anmeldefenster auf das graue "OS X". Da stecken noch sehr viel mehr Infos dahinter: Build, Seriennummer, IP-Adresse und der Verfügbarkeitsstatus der LDAP-Homedirs. Und? Rot, gelb oder grün?

    Gruß Stefan
     
  5. meister eder

    meister eder Cripps Pink

    Dabei seit:
    10.05.05
    Beiträge:
    152
    Ja lEute Vielen Dank! Bin schon einen Schritt weiter, konnte mich auch anmelden, dioch er (Server) erstellt miur einfach keine Privat ordner und dies meckert er dann auch an im LDAP log und beim anmelden sagt er es sei keine Homedirectory vorhanden.

    Und auf das graue os habe ich auch mal gedrückt da bekomme ich die Grüne Meldung Network Accounts seien verfügbar. Es liegt am Server!!! Wenn ich so ein homedirectory manuell anlege komme ich auch nicht weiter! Was kann ich noch tun?
     
  6. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Ist der Sharepoint den Du für die User bereit stellts als Automount Sharepoint in der LDAP Domain eingetragen und hast Du auch den Gastzugriff darauf aktiviert?
    Gruß Pepi
     
  7. meister eder

    meister eder Cripps Pink

    Dabei seit:
    10.05.05
    Beiträge:
    152
    Ja ist auch als Gast freigegeben.
    Also wenn ich keine Homeordner verwende gehts super gut kann auch die Einstellungen verändern wird auch schön übernommen. Aber warum:
    1. Ist Standard network User System in English
    2. Mein Homeordner heisst immer "99"

    Ist dies bekannt?
     
  8. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    ja - der 99er kommt, wenn kein HomeDir gezogen werden kann.

    Stimmen die Freigabenamen und Pfade der Shares, die Du im WGM den Usern zuweist? Schon ein "/" am Ende oder eben nicht macht einen Unterschied!

    Gruß Stefan
     
  9. Poste mal die Ausgabe von:
    lookupd -q mount
    und
    dscl /Search -read /Users/HIER_DEN_KURZNAMEN_EINES_USERS_HIN | grep HomeDirectory

    -Ralph
     
  10. meister eder

    meister eder Cripps Pink

    Dabei seit:
    10.05.05
    Beiträge:
    152
    Ich ahne etwas, also bei dem ersten Befehl bekomme ich die Ausgabe:
    lookup failed!
    Beim zweiten: apa2:~ root# dscl /Search -read /Users/demo | grep HomeDirectory
    NFSHomeDirectory: 99

    Der Server heisst directory im Terminal heisst er apa2 dies habe ich mit vielen MAcs im Netz, der Terminalname stimmt mit dem Namen im Feld Sharig nicht überein, der Server hat eine Manuelle IP und bezieht sie nicht vom Microsoft DC der im Netz läuft dennoch zieht er sich PC Namen und dies verstellt nach einer Zeit den Suchpfad der Anfangs stimmt, und sich später umbenennt! Oh gott zu diesem Problem konnt mir noch keiner helfen!

    So sieht mein Suchpfad in der Opendirectory Einstellungen aus: dc=directory,dc=grafik,dc=local
    Warum stehen da 3 Versionen drinne?
     
  11. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Weil das wohl der Hostname des Directory Servers ist. Was mir sehr sauer aufstößt ist, daß dort .local als letztes dc aufgeführt wird. Ihr verwendet hoffentlich nicht wirklich .local als Domain im LAN, oder? Bitte setz (mindestens) einen DNS Server auf und vergib mal ordentliche Hostnamen, sonst wird das mit dem Kerberos nie was.

    Dein User wird außerdem auf id 99 gemapped, das wäre dann nobody.

    Ist der Home Directory Sharepoint per AFP oder NFS freigegeben? Wie ist der automount in der Domain eingestellt? Erlaubt die Domain am Server überhaupt, daß sich Rechner an sie binden?
    Gruß Pepi
     
  12. Ab 10.4 ist .local als TLD übrigens kein Problem mehr. Einfach "local" bei den Domainnamen eintragen.

    -Ralph
     
  13. meister eder

    meister eder Cripps Pink

    Dabei seit:
    10.05.05
    Beiträge:
    152
    Hallo, also ich habe mal den OpenDirectory neu konfiguriert!

    So schaut der Suchbeginn aus:

    dc=directory,dc=directory.vorstufe.,dc=local

    DNS steht:

    Zonen Name: vorstufe
    Servername: directory

    Client Seite ist ok, erreicht den Server einwandfrei.
    Es gibt dann im AGM einen User mit dem Namen "demo" in den privat Einstellungen ist folgender Pfad aktiviert:

    Netzwerkordner:
    afp://directory/Users
    Pfad:
    demo
    Privat:
    /Network/Servers/directory/Users/demo

    Bei dem Maschinenname habe ich auch schon mit der IP versucht, kein Erfolg.

    So, der User Ordner Demo ist auch im Sharing unter AFP und LDAP inkl. Gast Zugriff im Netz freigegeben. (ich muss dazu sagen dass der Ordner nicht automatisch angelegt wurde sondern von mir manuel, ich denke er müsste automatisch geriert werden wenn ich den Privat Ordner angebe und sichere!)

    Was kann ich noch tun?
     
  14. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Mal den Firewall begutachten, daß alle notwendigen Ports offen sind. Checken ob der User auch im LDAP und nicht versehentlich in der lokalen Netinfo Domain angelegt wurde.

    Das Home Directory wird per default erst beim ersten erfolgreichen Anmelden des Users angelegt. Das sollte eigentlich kein Problem sein.

    Was durchaus möglich ist, daß Du den Client und evt. sogar den Server nach Veränderungen im Direcory Server neustaren mußt. (Lästig, ich weis, aber manchmal gehts nicht ohne.)

    Ich gehe mal davon aus, daß Dein OD als Master konfiguriert ist und nicht als Stand Alone Server. Außerdem gehe ich davon aus, daß Du die IP des Servers nach der Installation nicht mehr verändert hast. Darf ich von diesen Dingen eh ausgehen? :)
    Gruß Pepi
     
  15. meister eder

    meister eder Cripps Pink

    Dabei seit:
    10.05.05
    Beiträge:
    152
    Hallo, ich denke da ist alles erfüllt, habe noch eine Frage zum User wie kann ich sehen das er im Ldap und nicht im localen Netinfo angelegt ist, ich sehe nur in der Accountzusammenfassung bei Ort:
    directory.vorstufe/LDAPv3/127.0.0.1

    ich denke dies ist auch ok!

    Bin etwa verzweifelt! ;)
     
  16. meister eder

    meister eder Cripps Pink

    Dabei seit:
    10.05.05
    Beiträge:
    152
    Hallo, jetzt dreh ich völlig durch, habe die Situation soeben zu Hause mit einem alten iMac nachgestellt, ich kann mich ohne Homedirectory einloggen (99) und mit kommt die gleiche Fehlermeldung......ich raffs nicht! Hilfe!
     
  17. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Sieht gut aus, mal abgesehen davon, daß mir das ohne FQDN und so wirklich nicht zusagt. Die Frage die Du noch nicht beantwortet hast ist ob der Users SharePoint in der Domain als Automount definiert ist!
    Gruß Pepi
     
  18. meister eder

    meister eder Cripps Pink

    Dabei seit:
    10.05.05
    Beiträge:
    152
    wo sehe oder stelle ich dies ein?
     
  19. meister eder

    meister eder Cripps Pink

    Dabei seit:
    10.05.05
    Beiträge:
    152
    Danke noch mal! Learning by doing! Nach langem suchen habe ich den Fehler gefunden, bei den Einstellungen im AGM für den jeweiligen Benutzer gibt es den Punkt Anmeldung da muss Netzwerk Privatordner hinzufügen angeklickt sein! Also soweit geht alles!

    Aber mir stellt sich schon die nächste Frage: wie kann ich einen schon vorhandenen localen Benutzer mit all seinen Eigenschaften und Daten in einen OpenDirectory Benutzer migrieren?
     
  20. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Heißer Tip zum Server Administrieren:
    Entferne bei den Server Management Programmen alle Lokalisierungen außer der englischen Sprache! Du tust Die leichter mit anderen über ein Problem zu reden weil alle wissen wovon Du redest und es beugt auch Fehlkonfigurationen durch Übersetzungsfehler des GUI vor.

    Einen lokalen Benutzer kannst Du nicht automatisiert umwandeln. Einfach am Server anlegen und den Inhalt des bestehenden Homes in das neue Serverbasierte rüberkopieren. (Nicht auf die diversen .irgendwas Dateien vergessen!)
    Gruß Pepi
     

Diese Seite empfehlen