1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

all-inkl.com stellt Umlaute nach Upload nicht korrekt dar

Dieses Thema im Forum "Browser" wurde erstellt von Cohen76, 09.03.07.

  1. Cohen76

    Cohen76 Morgenduft

    Dabei seit:
    15.05.06
    Beiträge:
    170
    Hallo,

    ich bin gestern mit meiner unter iWeb kreierten Webseite von 1&1 zu all-inkl.com umgezogen. Der Umzug selbst hat prima geklappt. Jetzt stehe ich jedoch vor folgendem Problem, das bislang auch der Support von all-inkl.com nicht lösen konnte:

    Sämtliche Umlaute, die lokal (also in der Offline-Version) korrekt dargestellt werden, sind nach dem Upload meiner Seite "zerschossen" (unter Firefox und Safari). Wenn ich mir nun eine Datei meiner Webseite wieder per FTP auf den Rechner runterziehe und diese dann lokal öffne, zeigt mir der Browser die Umlaute wieder korrekt an.

    Ich habe bis jetzt lediglich herausgefunden, dass, wenn ich die Zeichenkodierung des Browsers von Westlich (ISO 8859-1) auf UTF-8 umstelle, die Umlaute auch korrekt angezeigt werden. Doch das kann nicht die Lösung sein, weil ich meinen Webseiten-Besuchern nicht zumuten kann/will, ihre Browser-Zeichencodierung ebenfalls umzustellen.

    Kennt jemand eine Lösung für das Problem? Auch das explizite Einstellen der Übertragungscodierung auf UTF-8 unter Captain FTP oder Cyberduck hat keine Besserung gebracht. Komisch ist, dass unter dem 1&1-Webhosting nie dieses Problem auftauchte.

    Beste Grüße & Gute Nacht,
    Cohen76
     
  2. Hallo, scheint ja ein toller Hoster zu sein :/

    Das Problem liegt an der Apache konfiguration, dein Hoster ALL-inkl.com soll den Default Charset mal umstellen:

    in der Regel findet er die in der httpd.conf

    Dort gibt es den eintrag:

    AddDefaultCharset UTF-8

    Da wir aber in Deutschland leben und es ja auch ein Deutscher Hoster ist sollte er die Codierung entsprechend einstellen:

    AddDefaultCharset ISO-8859-1

    ist schon ganz schön schwach ! ich würde es mir mal überlegen bei so einem hoster zu bleiben, der noch nicht mal in der lage ist seinen Server richtig zu konfigurieren.
     
    Cohen76 gefällt das.
  3. Cohen76

    Cohen76 Morgenduft

    Dabei seit:
    15.05.06
    Beiträge:
    170
    Hallo Shadowsnake,

    danke für deinen detaillierten Tip. Nach einer unruhigen Nacht habe ich heute Morgen eine ganz ähnliche Lösung gefunden:

    1. Erstellen einer Textdatei
    2. Inhalt dieser Textdatei - lediglich eine Zeile: "AddCharset UTF-8 .html .htm .php" (Ohne die Anführungszeichen natürlich)
    3. Upload dieser Textdatei per FTP in das Root-Verzeichnis meines Servers
    4. Umbenennen dieser Textdatei in ".htaccess" (d.h ohne Dateinamen - nur ein Punkt und die Endung)
    5. Voilá - fertig!

    Es funktioniert. Nun stellt der Browser jedesmal automatisch, wenn die Webseite aufgerufen wird, auf UTF-8-Codierung um. Diesen Tipp werde ich mal dem Support weiterleiten, der mir aber auch ein bisschen leid tut, weil ich da so spät abends angerufen habe und ich die schöne entspannte Stimmung dort torpedierte. ;)

    Zur Kontrolle könnt ihr ja mal gucken: www.hasenblog.de

    Falls ihr Probleme mit der Darstellung habt, bitte ich um eine kurze Nachricht - dann muss die Suche von Neuem losgehen.

    Gruß, Cohen76
     
  4. maxg

    maxg Prinzenapfel

    Dabei seit:
    16.10.06
    Beiträge:
    553
  5. Trunks

    Trunks Zuccalmaglios Renette

    Dabei seit:
    09.03.06
    Beiträge:
    256
    @Shadowsnake Na du bist mir ja einer. Beurteilt einen Hoster nur nach dieser einen Aktion. Ich bin selbst seit einigen mit einigen Accounts bei All-Inkl und bin Top-Zufrieden. Spitzen Support und super Server. Deshalb nicht so schnell aburteilen ;)
     
  6. freshy

    freshy Macoun

    Dabei seit:
    19.11.06
    Beiträge:
    122
    Besseres Preis-Leistungsverhältnis wie bei all-inkl.com wird man selten finden. Der Support ist einfach top, e-Mail anfragen werden nahezu unverzüglich bearbeitet. Ausserdem: Wozu irgendwelche configs umstellen? HTML bietet für sehr viele Umlaute und Sonderzeichen eigene Codes an. Siehe Post von maxg. Normalerweise gibt man in jedem Head einer HTML-Datei auch das default-charset an. Dürfte für keinen Browser ein Problem darstellen.

    @cohen: Bei mir wird alles sauber angezeigt (auch unter Windows).
     
  7. Hilarious

    Hilarious Gelbe Schleswiger Reinette

    Dabei seit:
    10.08.05
    Beiträge:
    1.759
    Gerade deshalb wird seit der Version 2.0.x der Apache mit der Voreinstellung UTF-8 ausgeliefert, was gerade in Deutschland und anderen Ländern, die mehr Buchstaben kennen als im englischen Sprachraum in Benutzung sind, seinen Vorteil gegenüber den ISO-8859-Gruppen ausspielen kann. Wenn der Hoster bewusst auf ISO-8859-1 umstellt, ist das aus seiner Sicht sogar dümmer, wo doch inzwischen (neben OS X und Linux) sogar seit XP die Windowswelt vermehrt auf UTF-8 setzt als auf Dinge wie ISO-8859-1, ISO-8859-15 oder gar Mac OS Roman.
     
  8. peternie

    peternie Morgenduft

    Dabei seit:
    02.01.07
    Beiträge:
    166
    Einfach geht es auch mit einem

    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

    im Header der jeweiligen Seite, bzw. im Template. Das iso-8859-1 entsprechend Deinen Wuenschen (UTF-8) anpassen.

    @Cohen76: Nettes Fotoalbum, dein Gästebuch ist jedoch tot
     
    Cohen76 gefällt das.
  9. Cohen76

    Cohen76 Morgenduft

    Dabei seit:
    15.05.06
    Beiträge:
    170
    Ok, danke für eure Tipps. Da ich (noch) mit iWeb arbeite, macht das Von-Hand-Einarbeiten von HTML-Code in die einzelnen Seiten keinen Spaß. Mir jedenfalls nicht. Da bevorzuge ich die derzeitige Lösung mit der .htaccess-Datei auf dem Server. Mal gucken, wenn ich eine schöne, einfach benutzbare Alternative zu iWeb gefunden habe, steige ich um. Wie sieht's eigentlich mit Dreamweaver aus? Oder doch lieber Rapidweaver?

    Ach ja, mit All-Inkl.com bin ich ansonsten sehr zufrieden. Der Wechsel hat sehr schnell funktioniert - und bei welchem Webhoster findet man schon eine Hotline, die lediglich Festnetzgebühren kostet und dazu noch bis 24 Uhr erreichbar ist? Ich find's prima, vor allem bei dem Preis.

    Danke - das mit dem Gästealbum habe ich auch bemerkt. Das habe ich "vergessen", mit rüberzunehmen. Wird demnächst gelöscht. Aber da trägt sich eh kaum einer ein, da die Seite normalerweise nur unsere Freunde und Verwandte zu sehen bekommen und die sagen uns so klipp und klar, was sie von der Seite halten. ;)
     
  10. freshy

    freshy Macoun

    Dabei seit:
    19.11.06
    Beiträge:
    122
    Ja, und im Vergleich zu 1und1 zum Beispiel vieeel mehr Leistung fürs Geld, keine nervigen Werbepopups die nur gegen Aufpreis verschwinden (ich hab gedacht ich spinne). Für 8 Euro im Monat unbegrenzt Traffic. Gut das du gewechselt bist. :)
     
  11. Hallo nochmal,

    bevor wir hier eine Diskusiton über "Guter Hoster, Schlechter Hoster" oder welches ist die Beste zeichencodierung machen. Möchte ich noch mal schnell was klarstellen :)

    Ich wollte mit dem Argument :

    nur ausdrücken das es aus meiner sicht schwach ist dem Kunden keine erklährung und/oder lösung für dieses Problem zu bieten. Schießlich ist es ja ein Webhoster und es ist sein Beruf!

    Ich will dem Webhoster hier nichts unterstellen aber in dem Fall war mein erster gedanke die Apache Konfiguration.

    Gerade im "Low Budget" Webhosting tümmeln sich einige die nicht wirklich wissen was sie machen, diesen Beruf auch nie gelent habe (was nicht gleich abwertent gemeint ist).

    Aber wenn ich mir allein anschau das für die genannte Domain nur 2 DNS Server laufen ...
    Naja ich will jetzt das thema nicht weiter anheizen!

    Also sorry das ich mich nicht richtig ausgedrückt habe!

    LG

    Shadowsnake

    PS: Nein ich bin kein Webhoster !
     
  12. peternie

    peternie Morgenduft

    Dabei seit:
    02.01.07
    Beiträge:
    166
    all-inkl bekommt von mir auch ne glatte 1. habe jetzt sogar für 3 Jahre im Voraus bezahlt mit riesen Abschlag, bin etwa 5 Jahre dabei, Hotline super erreichbar und faehig.

    Ich habe einmal, trotz mehrfachem Hinweis von all-inkl im Vorfeld, ein PHP-Update bekommen und mir gedacht, lass die mal schreiben, passiert schon nichts. Ja schade, danach ging nichts mehr. Der Hotline eine Mail geschrieben und erstmal 6 Stunden nichts gehoert. Komisch dachte ich, sonst hattest du innerhalb von 30 Minuten ne Info. Dann, nach 6 Stunden, habe ich ne Antwort bekommen. Geht wieder alles ! Wie das ? Ja, wir haben mal eben Ihre gesamten Skripte (!!!) auf die neue PHP-Version angepasst. Wow, das hat mich dann doch umgehauen.

    Aber an eins solltest Du denken, es gibt nur ein Backup der Datenbanken bei all-inkl. Kein Backup vom Content. Habe ich einmal leidvoll erfahren, als jemand meine Seite gehackt hat und alles weg war und ich natuerlich mal wieder kein Backup hatte :(
     
  13. Cohen76

    Cohen76 Morgenduft

    Dabei seit:
    15.05.06
    Beiträge:
    170

    Im Augenblick ist das für mich kein Problem, weil ich die Webseite im Moment noch mit iWeb erstelle und sie daher auch zwangsläufig keine dynamischen Inhalte umfasst. Dadurch habe ich die Webseite komplett gespiegelt auf meiner Festplatte und kann sie im Fall eines Falles einfach neu hochladen. :)

    Ach ja, ist es denn schlimm, dass für meine Domain nur 2 DNS-Server laufen? Ich kenne mich da nicht so gut aus. Immerhin wurde mir all-inkl.com hier im Forum empfohlen. Und da jetzt alles klappt, bin ich auch zufrieden. :)
     
  14. Hi,

    schlimm ist es nicht, solange alles gut läuft.
    Soweit ich mich errinern kann sind von Denic jedoch 3 empfohlen ?!?!?
    Koregiert mich wenn ich mich irre!

    Wenn du/ihr sonst mit dem Hoster zufrieden seit ist doch alles ok.
    Will hier keine Hoster Diskusion anfangen :)

    Schönes WE noch!

    Lg

    Shadowsnake
     
  15. freshy

    freshy Macoun

    Dabei seit:
    19.11.06
    Beiträge:
    122
    Deine Webseite läuft schnell und ist gut erreichbar, Support stimmt und du bist zufrieden: Mach dir keine Gedanken.

    All-inkl ist auf Webhostlist und vielen anderen Toplisten zumeist unter den ersten fünf. Wenn man irgendwo etwas schlechtes finden will, dann findet man es auch. Also nur nicht reinreden lassen. :)
     
  16. cenk

    cenk Alkmene

    Dabei seit:
    31.12.06
    Beiträge:
    35
    Also, ich finde all-inkl auch toll :)
     
  17. Hilarious

    Hilarious Gelbe Schleswiger Reinette

    Dabei seit:
    10.08.05
    Beiträge:
    1.759
    Wenn der Server die eine Kodierung verwendet (zum Beispiel UTF-8) und die WebSite über den Meta-Tag eine andere verlangt, ist das leider nicht immer gleich die Lösung. Safari lässt sich dadurch leider nicht beirren und dann kommt es schon einmal zu Fehldarstellungen (Raute mit Fragezeichen).

    Man sollte daher schon darauf achten, dass man auch im Hinblick auf Sonderzeichen die eigene WebSite mit verschiedenen Browsern und Betriebssystemen testet. Und hier vor allem auch nicht die Kontaktformulare vergessen ;)
     
  18. gilligamer

    gilligamer Adams Parmäne

    Dabei seit:
    20.01.06
    Beiträge:
    1.296
    Hey!

    Da ich es bis jetzt wirklich noch nicht geschaft hatte, meine iWeb Seite richtig auf Ohost zum laufen zu bringen, muss ich dir oder ... danken!

    Als erstes hatte ich das Problem, das Ohost meine iWeb erstellten .html Dateien als PHP liesst und danach eine "line 1" Fehlermeldung brachte.

    Dieses Problem löste ich durch... ... ...

    Danach waren die Zeichen falsch und dies löste ich indem ich ... ... ...

    ... ... ...

    ---

    Wisst ihr was!? Es würden sich sicherlich viele hier darüber freuen, wenn ich ein Tutorial schreibe, indem ihr erfährt, wie mache ich meine (kostenlose) WebSite mit iWeb und das auch alles funktioniert!

    Da ich jetzt wirklich schon lange an diesen iWeb Problemen herumtüftle werde ich dieses Tutorial so bald wie möglich hier auf Apfeltalk veröffentlichen. Aber jetzt ist mir zu spät, ich werde mich morgen mal daran setzen, sobald ich von der Schule zurück komme.

    Aber ob ich auch Morgen fertig werde, kann ich noch nicht sagen.

    Als ich noch keine Ahnung von iWeb hatte, hätte ich mich sicherlich über ein solches Tutorial gefreut.

    Noch kurz was:

    Soll ich das Tutorial direkt hier auf Apfeltalk erstellen oder zuerst in Word, TextEdit etc.?

    MFG gilligamer
     
  19. KOmaSHOOTER

    KOmaSHOOTER Erdapfel

    Dabei seit:
    31.12.13
    Beiträge:
    2
    "UTF-8 erzwingen" war gestern... Jetzt kommt PHP!!!

    Das Problem liegt in der Konfiguration vom FTP Server.
    Der FTP Server bei www.strato.de und www.all-inkl.de benutzt Ansi aber Apache benutzt Default charset UTF8.
    Bei www.server4you.de hat man dieses Problem nicht! :) Ich empfehle den vServer PRO X5 für nur 8.85 € pro Monat (http://www.server4you.de/vserver/vserver-vergleich.php?server=PRO)

    Dafür bietet all-inkl.com PHP 5.2 oder PHP 5.3

    Leider sind die Administratoren von Strato und all-inkl nicht in der Lage die FTP Server Konfiguration zu ändern. Hier zählt nur noch "Friss oder stirb!"

    Optional geht es auch mit "UTF-8 erzwingen" in den Einstellungen vom FTP Client.
    Doch dies möchten wir nicht!
    Nicht jeder FTP client kann "UTF-8 erzwingen". Adobe Dreamweaver kann dies z.B. nicht.
    Aber FileZilla kann das!

    "UTF-8 erzwingen" verursacht Probleme beim Löschen oder Verschieben von Dateien. Man kann diese Dateien nur mit "UTF-8 erzwingen" bearbeiten. Außerdem kann man diese Dateien doppelt hochladen, so dass man am Ende 2 Dateien hat. Der Unterschied ist dann nur auf dem Apache Server sichtbar.

    Die Lösung ist PHP + mod_rewrite + Regular Expression
    Mit mod_rewrite wird auf eine php Datei umgeleitet. (Besipiel: http://de.selfhtml.org/servercgi/server/rewrite.htm)
    Mit PHP kann man nun die gewünschte Datei mit readfile(utf8_decode('FILENAME_ÖÄÜ'.'.jpg')) einlesen.
    (Beispiel: http://www.electrictoolbox.com/image-headers-php/)

    Damit ist der FTP-File-Upload mit Modus "AUTO" und Umlauten im Dateinamen kein Problem mehr.
    PS: Im Directory Index generiert der Apache Server trotzdem falsche Links, weil die Dateinamen nicht mehr im UTF-8 Format sind.
    PHP kann mit utf8_decode und mod_rewrite den richtigen Dateinamen finden.

    Beispiel
    file: Blätter.jpg -> Umleitung auf image.php?image=Blätter.jpg

    Apache Link Bl�tter.jpg
    Der Apache Link ist identisch mit utf8_decode($file) // return: Bl�tter.jpg
    wenn AddDefaultCharset utf-8 benutzt wird.

    .htaccess file
    Code:
    AddDefaultCharset ISO-8859-1
    Options +Indexes
    IndexOptions charset=ISO-8859-1
    AddCharset ISO-8859-1 .jpg
    ServerSignature On
    
    RewriteEngine on
    RewriteRule ^(.*)\.jpg$ image.php?image=$1
    
    image.php file
    Code:
    <?php
    header('Pragma: no-cache');
    header('content-type: image/jpeg');
    $file = utf8_decode($_GET["image"]).".jpg";
    readfile($file);
    exit();
    ?>
    Oder laden von einen anderen Server -> Default charset UTF-8

    .htaccess file
    Code:
    ## AddDefaultCharset utf-8
    ## Options +Indexes
    ## IndexOptions charset=utf-8
    ## AddCharset UTF-8 .jpg
    ## ServerSignature On
    
    RewriteEngine on
    RewriteRule ^(.*)\.jpg$ image.php?image=$1
    
    image.php file
    Code:
    <?php
    if($_GET['image']==""){
      header('HTTP/1.0 404 Not Found');
      readfile('http://www.domain.de/404.html');
      exit();
    }else{
      $file = ("http://www.domain.de/images/".$_GET['image'].'.jpg');
      header('Pragma: no-cache');
      header('content-type: image/jpeg');
      readfile($file);
      exit();
    }
    ?>
    Links:
    http://stackoverflow.com/questions/437256/sending-a-404-error-in-php
    http://de.wikipedia.org/wiki/HTTP-Statuscode#3xx_.E2.80.93_Umleitung
    http://www.supernature-forum.de/tut...viderwechsel-kk-antrag-so-funktioniert-s.html
     
    #19 KOmaSHOOTER, 31.12.13
    Zuletzt bearbeitet: 01.01.14
  20. KOmaSHOOTER

    KOmaSHOOTER Erdapfel

    Dabei seit:
    31.12.13
    Beiträge:
    2
    Damit es auch mit HTML Sonderzeichen wie & [&amp;] funktioniert
    muss htmlspecialchars_decode und urldecode benutzt werden


    file name: "feuer_&_wasser.jpg"

    url: "http://.../feuer_&_wasser.jpg"
    oder
    url: "http://.../feuer_&amp;_wasser.jpg"

    Beides funktioniert

    Wegen dem Undzeichen hat $_Get["image"] eigentlich nur den Wert "feuer_"
    Wir benutzen einfach den QUERY_STRING und substr

    image.php file
    PHP:
    <?php //ini_set('arg_separator.output','&amp;'); ?>
    <?php 
    //ini_set('arg_separator.input','&amp;'); ?>
    <?php
    $image 
    substr($_SERVER['QUERY_STRING'],6,strlen($_SERVER['QUERY_STRING']));
    $_GET['image'] = htmlspecialchars_decode((urldecode($image)));

    if(
    $_GET['image']==""){
        
    header('HTTP/1.0 404 Not Found');
        
    readfile('http://www.domain.de/404.html');
        exit();
    }else{
        
    $file = ("http://www.domain.de/images/".($_GET['image']).'.jpg');
        
    header('Pragma: no-cache');
        
    header('content-type: image/jpeg');
        
    readfile($file);
        exit();
    }
    ?>
     
    #20 KOmaSHOOTER, 03.01.14
    Zuletzt bearbeitet: 03.01.14

Diese Seite empfehlen