1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Ä,Ö,Ü werden in Smultron nicht angezeigt.

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von iMars, 29.12.06.

  1. iMars

    iMars Salvatico di Campascio

    Dabei seit:
    07.12.06
    Beiträge:
    429
    Hallo, habe ein kleines Problem.
    Alle HTML-Dateien, die ich mit Smultron erstelle und in denen Ä,Ö oder ähnliches vorkommen, werden mit merkwürdigen Zeichen abgespeichert.

    Beim schreiben des Codes zeigt er Sonderzeichen an, aber nachdem ich sie abspeicher und noch einmal öffne oder webhoste dann kommt sowas "?&%" oder so.

    Habe schon in den Einstellungen geschaut...wegen Westeuropäisch oder so. Aber stimmt meines Wissens alles. HILFE!

    Mfg iMars
     
  2. floeschen

    floeschen Horneburger Pfannkuchenapfel

    Dabei seit:
    13.08.06
    Beiträge:
    1.402
    Du musst die Zeichen sowieso maskieren, die schwedische Erdbeere macht das leider nicht selber. also
    - ä für ä
    - ü für ü
    - ö für ö
     
  3. MacApple

    MacApple Lord Grosvenor

    Dabei seit:
    05.01.04
    Beiträge:
    3.470
    Man muss beim Öffnen von Textdateien die gleiche Codierung verwenden, wie beim Speichern. Passt das bei Dir zusammen?

    MacApple
     
  4. iMars

    iMars Salvatico di Campascio

    Dabei seit:
    07.12.06
    Beiträge:
    429
    Also in den Einstellungen steht "Automatisch erkennen". Manche HTML-Dokumente habe ich damals noch auf meiner Dose in Phase 5 erstellt, ich hab also keine ahnung was für ne codierung das war. Wie weiß ich also welche Codierung das ist?!?!

    Und auf maskieren hab ich ehrlich gesagt keinen bock ^^ trotzdem danke flöschen... du kennst dich aber auch mit allem aus, fällt mir gerade auf!
     
    #4 iMars, 29.12.06
    Zuletzt bearbeitet: 29.12.06
  5. MacApple

    MacApple Lord Grosvenor

    Dabei seit:
    05.01.04
    Beiträge:
    3.470
    Die automatische Erkennung kann höchstens zwischen UTF-16 und nicht UTF-16 unterscheiden, weil nur die UTF-16 Codierung eine Kennung am Anfang der Datei hat. Alle anderen Codierungen kann ein Computer schlicht nicht erkennen, weil der sieht nur eine Folge von Zahlen. Die Zuordnung zu den Zeichen steht in den Dateien nicht drin.

    Zuverlässig hilft da nur ausprobieren. Öffne die Datei mit verschiedenen Codierungen, bis Du die richtige gefunden hast. Bei den Dateien, die Du unter Windows gespeichert hast, dürfte die Wahrscheinlichkeit, dass es sich um Westeuropäisch (Windows Latin 1) handelt recht hoch sein.

    MacApple
     

Diese Seite empfehlen