1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

A/V-Verzögerung bei mpeg2-TV-Streams

Dieses Thema im Forum "Musikproduktion" wurde erstellt von da_jones, 17.05.06.

  1. da_jones

    da_jones Luxemburger Triumph

    Dabei seit:
    06.02.06
    Beiträge:
    500
    Bonjour AT-Community,

    wie immer von mir mehr Gefrage als Antwort, aber was solls?:
    Ich (kleiner Musik-Fanatiker) nehme furchtbar gern über Digital-SAT Live-Konzert als mpeg2-Streams auf. MTV, der tolle *knirsch* Sender strahlt aber nicht in den PAL genormten 640x480 bzw. 720x576, sondern in 58xmal300nochwas aus. Die Folge: wenn ich das auf einen Silberling packen will, muss ich es hochrechnen lassen.
    Nun hab ich einige Software zur Verfügung und auch ausprobiert. Sowohl ffmpegX als auch Compressor 2 (!!!) liefern das selbe Ergebnis: eine Verzögerung von Ton- und Bildspur. Das ganze ist vollkommen unabhängig, ob ich die Files muxed oder demuxed konvertieren lasse, ob ich .m2a oder .ac3 als Audio nehme.
    Noch als letzter Hinweis - es ist die Videospur, die am Ende länger wird. Ich stehe vor einem Rätsel. Wer gerne ein Test-File hätte, dem kann ich gerne eines zusenden.

    Vielen Dank im Voraus schon mal an den überaus findigen Menschen, der die Lösung zu meinem Problem kennt.

    da_jones
     
  2. yjnthaar

    yjnthaar Schwabenkönig

    Dabei seit:
    07.06.04
    Beiträge:
    2.657
    Moin,

    Eindeutig: Die Framrate stimmt nicht. Die Videospur wird (so wie es den Anschein hat) in NTSC mit 29,97 Frames/Sekunde laufen und hat daher mehr Bilder. Probier mal nur die Videospur als PAL 25 Bilder zu speichern und schau ob es dann passt.

    Gruss,
    Simon
     
  3. zetagi

    zetagi Finkenwerder Herbstprinz

    Dabei seit:
    12.02.04
    Beiträge:
    466
    Joa ein eindeutiges normen problem. das problem ist es könnte beim wandeln nacher ruckeln. gute normenwandlung ist aufwändig und teuer.
     
  4. da_jones

    da_jones Luxemburger Triumph

    Dabei seit:
    06.02.06
    Beiträge:
    500
    vielen Dank schonmal,

    werde das gleich nochmal abklären, bin aber der Meinung, dass sowohl mpegstreamclip, ffmpegX, QT als auch Compressor für den Ausgangsstream eine PAL-Norm mit 25fps angezeigt haben. Hab dann auch entsprechend weiterhin in PAL codieren lassen. (nebenbei: ich glaube euren Fachkentnissen, aber im Moment kann ich mir nur schwerlich vorstellen, dass bei eingestellter PAL-Aufnahme in NTSC aufgezeichnet wird)
    Ich melde mich nochmal, wenn's soweit ist

    schönen Feierabend

    da_jones
     
  5. yjnthaar

    yjnthaar Schwabenkönig

    Dabei seit:
    07.06.04
    Beiträge:
    2.657
    Servus,

    Falls Du mal einen paar sekunden Schnipsel des Aufzeichnungsmaterials zur Verfüngung stellen würdest, könnte ich das mal ankucken.

    Gruss,
    Simon
     
  6. da_jones

    da_jones Luxemburger Triumph

    Dabei seit:
    06.02.06
    Beiträge:
    500
    Erstmal vielen Dank für alle bisherige (angebotene) Hilfe!
    Hab das Problem jetzt in den Griff bekommen. Folgender Modus: 1. Stream demuxen 2. .m2v als .ts in gewünschter Auflösung hochrechnen lassen 3. wieder demuxen 4. .m2a in .ac3 codieren (muss natürlich nicht) 5. entweder muxen oder über dvd studio pro direkt auf 'nen Silberling bannen.
    Das Problem hatte anscheinend nicht, wie vermutet, etwas mit NTSC/ PAL Spezifiktationen und entsprechender Inkompatibilität zu tun. Die genaue Ursache kenne ich leider auch noch nicht.
    @yinthaar ('tschuldigung, wenn ich mich jetzt verschrieben habe): auf dein Angebot würde ich gerne zurückkommen. Hab nur leider keine Homepage, um etwas online zu stellen. Hab schon ein kleines File vorbereitet (8sek, ca 4MB). Wenn du mir verrätst, wie ich dir das übermitteln kann, dann mach ich das.

    Nochmals danke, schönen Abend & schönen Gruß

    da_jones
     

Diese Seite empfehlen