1. Am Dienstag dem 21.05.19 ab ca. 9:30 Uhr werden wir eine größere Server-Wartung vornehmen. Das Forum und das Magazin werden bis Mittag (wenn alles gut geht) nicht erreichbar sein.
    Information ausblenden

Veränderung des Parameters "Ruhezustand verhindern" einer MacOS App – möglich?

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von pstruebe, 12.03.19.

  1. pstruebe

    pstruebe Granny Smith

    Dabei seit:
    30.04.18
    Beiträge:
    12
    Hallo zusammen,

    ich hoffe, ich habe hier das richtige Unterforum gewählt – da das Problem etwas spezieller ist und mit ich am ehesten noch eine Lösung durch einen entsprechenden Terminal-Befehl / Veränderung einer Datei erhoffe, habe ich es hier gepostet. Ansonsten bitte gerne verschieben, in dem Fall Pardon für die Umstände und Herzlichen Dank im voraus!

    Folgende Situation: Ich habe auf dem Mac eine App ("Rocksmith"), die ich gerne im Hintergrund durchgängig geöffnet lassen möchte, aber dann verhindert, dass nach 10 Minuten mein Bildschirmschoner einsetzt, wenn ich vom Computer mal länger weg bin. Es ist die einzige App, die unter "Aktivitätsanzeige – Energie" unter "Ruhezustand verhindern" ein "Ja" anzeigt.

    Auch wenn ich mir wenig Hoffnungen mache: Gibt es irgendeinen Terminal-Befehl, mit dem ich den "Ruhezustand verhindern"-Parameter für diese App (oder auch generell für alle Apps) auf "Nein" umstellen kann? Oder alternativ eine Möglichkeit, eine der zur App zugehörigen Dateien entsprechend zu bearbeiten? Eine Drittanbieter-App, die das Schlafengehen des Displays / Systems nach X Minuten erzwingt (quasi das Gegenteil von "Caffeine") gibt es meines Wissens nicht.

    Bin wie gesagt eher pessimistisch, aber falls es doch eine Möglichkeit gibt, würde ich mich über einen Hinweis freuen. Mich nervt das seit Jahren, und ich möchte nicht immer daran denken müssen, bei jedem längeren Verlassen des iMacs / vor dem Schlafgehen manuell meine aktive Ecke zu nutzen. Der Rechner läuft bei mir durch und die langen Ladezeiten für "Rocksmith" nerven, wenn ich einfach immer zwischendurch nur mal schnell ein paar Minuten spielen will – anderseits aber kriege ich, wenn ich die App offen lasse und der Bildschirm nicht mehr ausgeht, Probleme mit Ghosting-/Burn-In-Effekten auf meinem Display bzw. kürzere Lebensdauer.

    Der guten Vollständigkeit halber: Bin auf Mac OS Mojave, sollte aber nicht weiter relevant sein. Das Problem ist kein Bug, sondern besteht schon immer. (Wahrscheinlich vom Entwickler halt so gewollt, warum auch immer.)

    Danke im voraus für die Mühe!
     
  2. MACaerer

    MACaerer Welschisner

    Dabei seit:
    23.05.11
    Beiträge:
    11.694
    Eine nicht aktive App im Hintergrund sollte normalerweise das Ruhezustandverhalten nicht verändern. Wenn das trotzdem der Fall ist gibt es vier eventuelle Möglichkeiten zum ausprobieren:
    1. Die App ist aktiv, sie tut also irgend etwas. Dann gibt es keine Möglichkeit das wach bleiben zu verhindern
    2. Die App greift auf das Netz zu und das verhindert den Ruhezustand. Das kannst du in der Systemeinstellung "Energie sparen" deaktiveren. Alternativ geht das auch mit dem Terminalbefehl sudo pmset -a womp 0
    3. Powernap ist aktiviert. Deaktivieren ebenfalls in der o. g. Systemeinstellung oder mit sudo pmset -a powernap 0
    4. caffeinate ist aktiviert. Der Systemprozess ist eigentlich dafür gedacht einen ungewollten Ruhezustand zu verhindern. Das Gegenteil erreicht man, wenn man den eventuell aktivierten Prozess abschaltet mit sudo killall caffeinate
     
  3. pstruebe

    pstruebe Granny Smith

    Dabei seit:
    30.04.18
    Beiträge:
    12
    Vielen Dank für deine Antwort. Von den vier Punkten kann eigentlich nur Punkt 1 in Frage kommen – trotzdem sollte der Bildschirmschoner eigentlich einsetzen können. Rocksmith (die betreffende App) ist zwar im Hintergrund geöffnet, aber auch nicht weiter aktiv als zum Beispiel Mail, Safari, Word, Tweetbot oder was auch immer. Da sie wie gesagt unter "Aktivitätsanzeige" und dort "Energie" als einzige laufende App bei "Ruhezustand verhindern" mit "Ja" vermerkt ist (siehe auch Screenshot), gehe ich davon aus, dass Ubisoft / Steam es bei Rocksmith bewusst eingestellt haben, obwohl es grundsätzlich nicht nötig ist. (Ist auch die einzige Ruhezustand-Verhindern-App, die mir diesbezüglich so rigoros je untergekommen ist und selbst den Bildschirmschoner / Monitor Sleep nicht zulässt.) Ich lasse die App, wenn sie im Hintergrund ist, mit dem Programm "AppTamer" sogar inzwischen komplett stoppen, mehr "einfrieren" geht gar nicht – aber das eingebaute Setting "Ja" bei "Ruhezustand verhindern" bleibt anscheinend doch die alles entscheidende Instanz. Dabei will ich meinen Mac noch nicht mal in den Ruhezustand versetzen – einschlafendes Display bei normal weiterlaufendem Rechner reicht mir völlig aus ...

    Wie auch immer, sieht dann wohl schlecht aus. Trotzdem Danke für die Hilfe!
     

    Anhänge:

    #3 pstruebe, 12.03.19
    Zuletzt bearbeitet: 12.03.19
  4. MacApple

    MacApple Schmalzprinz

    Dabei seit:
    05.01.04
    Beiträge:
    3.573
    „sollte normalierweise“ bedeutet aber nichts. Eine macOS App kann dem System mitteilen, dass es nicht in den Schlafmodus gehen soll. Dabei ist es unerheblich, ob die App im Vordergrund aktiv was macht oder im Hintergrund herum gammelt. Das gleiche gilt übrigens auch für das Verhindern des Bildschirmschoners.

    Nun, woher weißt du, dass das nicht nötig ist? Wer weiß, was das Programm Rocksmith für „Probleme“ bekommen würde, wenn der Rechner in den Ruhezustand geht? Vielleicht ist Rocksmith in der Hinsicht auch einfach nur sch.... programmiert. Aber das weiß nur der Programmierer.
     
  5. pstruebe

    pstruebe Granny Smith

    Dabei seit:
    30.04.18
    Beiträge:
    12
    Ich "würge" Rocksmith ja wie gesagt mitunter mit Hilfe der App "AppTamer" sogar in einen kompletten eingefrorenen Zustand ab (zur Sicherheit: Die hat mit dem Problem definitiv nichts zu tun) – wenn ich die App dann wieder aktiviere, funktioniert alles ganz normal. Es kann schon gut sein, dass die Entwickler es bewusst wollen, dass der Rechner beim Laufen der App nicht in den Ruhezustand gehen kann, und ich gehe inzwischen sogar davon aus (lange dachte ich, dass dies ein Bug sei, der irgendwann behoben wird). Ist trotzdem echt nervig, denn es gibt wirklich keinen Grund dafür – das wäre dann noch viel eher begründbar bei unzähligen anderen geöffneten Apps, die nicht gerade aktiv benutzt werden, doch Rocksmith ist die erste, die mir mit dieser Einstellung untergekommen ist. Zumal ich wie gesagt noch nicht mal das Versetzen des iMacs in den Ruhezustand brauche / will, den hab ich eh abgestellt – aber das selbst meine Display-Energiespar-Einstellung, dass nach 10 Minuten Inaktivität von Maus/Tastatur der Bildschirmschoner anspringt und nach 15 Minuten das Display ausgeht, nur durchs Offenlassen von Rocksmith gekillt werden, finde ich heftig ...

    Hatte einfach gehofft, dass man diesen "Ruhemodus verhindern"-Parameter irgendwie (wie so vieles) über eine Terminal-Kommandozelle von "JA" auf "NEIN" umstellen kann. Scheint aber ja leider nicht der Fall zu sein.
     
    #5 pstruebe, 12.03.19
    Zuletzt bearbeitet: 12.03.19