Bluetooth lässt sich nicht deaktivieren

Dieses Thema im Forum "Mobil-Macs" wurde erstellt von macnamura, 25.03.13.

  1. macnamura

    macnamura Jonagold

    Dabei seit:
    05.12.12
    Beiträge:
    23
    Hallo!
    Bei meinem Macbook Pro (2009) lässt sich das Bluetooth nicht deaktivieren und ich kann auch keine Verbindung zu meinem Handy herstellen.
    Hatte vor kurzem das System komplett neu aufgesetzt und nur die Daten aus der Time Machine rüberkopiert. Jetzt habe ich wie vorher wieder 10.8.3 drauf. Vorher hatte ich absolut keine Probleme.
    Seit einer Woche hatte ich das Problem, dass die Internetverbindung immer mal wieder abgebrochen ist. Daraufhin habe ich mir das ganze mal am Wochenende angeschaut und habe gelesen, dass bei anderen Bluetooth und Wlan (bei mir über eine Fritzbox) Probleme machen. Hatte das Problem zwar vorher überhaupt nicht, hab aber mal nachgeschaut. Dabei ist mir aufgefallen, dass ich Bluetooth in der Statusleiste gar nicht deaktivieren kann. Egal was ich anklicke, es bleibt angeblich an. Letzte Woche hatte ich es mal angemacht (ist normalerweise aus, keine Magic Mouse oder Trackpad vorhanden) und nach Gebrauch wie immer deaktiviert.
    Habe schon andere Lösungsvorschläge versucht (Terminal dies und jenes killen/eingeben), aber nichts hat geholfen. Habe ML vorhin drüber installiert, aber das hat auch nicht geholfen. Ein Vorschlag war u.a. den Prozess Blued zu stoppen - bei mir läuft kein solcher Prozess.
    Jetzt frage ich mich zum einen, ob BT überhaupt läuft und wie ich es wieder normal (de)aktivieren kann, was vorher immer problemlos klappte.
     

    Anhänge:

  2. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.755
    In deinem Preferences-Order (~/Library / Preferences) liegen jede Menge Bluetooth.plist – ziehe sie mal alle in einen Ordner auf den Schreibtisch. Melde dich ab und wieder an. Wenn sich nichts verschlimmert hast, kannst du die Dateien in den Papierkorb ziehen, sie sollten sich automatisch neu bilden.
    Wenn das Ersetzen dieser Einstellungdateien nicht hilft, kannst du es auch mit com.apple.systempreferences.plist probieren.
    Aber die Dateien so lange aufheben, bis alles wieder klappt (oder so bleibt wie davor), erst dann in den Papierkorb damit.
    Salome
     
  3. macnamura

    macnamura Jonagold

    Dabei seit:
    05.12.12
    Beiträge:
    23
    Hab folgende Dateien wie beschrieben raugeschoben, hat sich aber nichts geändert. Weitern kann ich Bluetooth nicht deaktivieren und Internet über Wlan macht andauernd Probleme.

    com.apple.BluetoothFileExchange.plist
    com.apple.BluetoothFileExchange.plist.lockfile
    com.apple.BluetoothSetupAssistant.plist
    com.apple.driver.AppleBluetoothMultitouch.mouse.plist
    com.apple.driver.AppleBluetoothMultitouch.trackpad.plist
    com.apple.driver.AppleBluetoothMultitouch.trackpad.plist.lockfile
    com.apple.systempreferences.plist

    Gibts eigentlich einen Unterschied zwischen HD/Library und HD/Benutzer/yxc/Library?
    Hat noch jemand eine Idee?! :(
     
  4. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.755
    Ja der Unterschied ist, dass ~/Library (die Bibliothek in deinem User Ordner) nur für dich zuständig ist. Während /Library auch vom System beschickt wird und Files enthält die für sämtliche User gelten.
    Vielleicht hilft es, das ComboUpdate (Apple Support Site) drüber zu installieren.
    Salome
     
  5. macnamura

    macnamura Jonagold

    Dabei seit:
    05.12.12
    Beiträge:
    23
    Klingt logisch. :)
    Ich les im Netz immer wieder Sachen im Zusammenhang mit dem Prozess blued, der bei mir nicht existiert und z.B. Terminal-Einträgen wie "sudo launchctl load /System/Library/LaunchDaemons/com.apple.blued.plist", bei dem dann bei mir aber "nothing found to load" kommt. Könnte das ein Problem sein?
     
  6. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.755
    Es ist einen Versuch wert.
    Schaden entsteht keiner, ein aktuelles Backup hat man aber immer.
    Salome
     
  7. macnamura

    macnamura Jonagold

    Dabei seit:
    05.12.12
    Beiträge:
    23
    Hab das schon ausprobiert, aber "nothing found to load"... Und einen Prozess namens blued gibts halt auch nicht... :-[
     
  8. simmac

    simmac Melrose

    Dabei seit:
    22.03.11
    Beiträge:
    2.482
    ComboUpdate drüber installieren...
     
  9. macnamura

    macnamura Jonagold

    Dabei seit:
    05.12.12
    Beiträge:
    23
    Hab OSXUpdCombo10.8.3 installiert. Bluetooth lässt sich weiterhin nicht aussschalten... :(
     
  10. simmac

    simmac Melrose

    Dabei seit:
    22.03.11
    Beiträge:
    2.482
    OS X drüberinstallieren. Geht ohne Datenverlust.

    Mfg
    SimMac
     
  11. FelixMacintosh

    FelixMacintosh Herrenhut

    Dabei seit:
    28.07.12
    Beiträge:
    2.290